Trademarks

Afterburner, AppletAce, Attain, Attain Enterprise Learning System, Attain Essentials, Attain Objects for Dreamweaver, Authorware, Authorware Attain, Authorware Interactive Studio, Authorware Star, Authorware Synergy, Backstage, Backstage Designer, Backstage Desktop Studio, Backstage Enterprise Studio, Backstage Internet Studio, Design in Motion, Director, Director Multimedia Studio, Doc Around the Clock, Dreamweaver, Dreamweaver Attain, Drumbeat, Drumbeat 2000, Extreme 3D, Fireworks, Flash, Fontographer, FreeHand, FreeHand Graphics Studio, Generator, Generator Developer's Studio, Generator Dynamic Graphics Server, Knowledge Objects, Knowledge Stream, Knowledge Track, Lingo, Live Effects, Macromedia, Macromedia M Logo & Design, Macromedia Flash, Macromedia Xtras, Macromind, Macromind Action, MAGIC, Mediamaker, Object Authoring, Power Applets, Priority Access, Roundtrip HTML, Scriptlets, SoundEdit, ShockRave, Shockmachine, Shockwave, Shockwave Remote, Shockwave Internet Studio, Showcase, Tools to Power Your Ideas, Universal Media, Virtuoso, Web Design 101, Whirlwind and Xtra are trademarks of Macromedia, Inc. and may be registered in the United States or in other jurisdictions including internationally. Other product names, logos, designs, titles, words or phrases mentioned within this publication may be trademarks, servicemarks, or tradenames of Macromedia, Inc. or other entities and may be registered in certain jurisdictions including internationally.

This guide contains links to third-party Web sites that are not under the control of Macromedia, and Macromedia is not responsible for the content on any linked site. If you access a third-party Web site mentioned in this guide, then you do so at your own risk. Macromedia provides these links only as a convenience, and the inclusion of the link does not imply that Macromedia endorses or accepts any responsibility for the content on those third-party sites.

Apple Disclaimer

APPLE COMPUTER, INC. MAKES NO WARRANTIES, EITHER EXPRESS OR IMPLIED, REGARDING THE ENCLOSED COMPUTER SOFTWARE PACKAGE, ITS MERCHANTABILITY OR ITS FITNESS FOR ANY PARTICULAR PURPOSE. THE EXCLUSION OF IMPLIED WARRANTIES IS NOT PERMITTED BY SOME STATES. THE ABOVE EXCLUSION MAY NOT APPLY TO YOU. THIS WARRANTY PROVIDES YOU WITH SPECIFIC LEGAL RIGHTS. THERE MAY BE OTHER RIGHTS THAT YOU MAY HAVE WHICH VARY FROM STATE TO STATE.

Copyright © 1997 - 2002 Macromedia, Inc. All rights reserved. This manual may not be copied, photocopied, reproduced, translated, or converted to any electronic or machine-readable form in whole or in part without prior written approval of Macromedia, Inc. Third Party Software Notices and/or Additional Terms and Conditions can be found at http://www.macromedia.com/go/thirdparty/.

First Edition: June 2002
Macromedia, Inc.
600 Townsend St.
San Francisco, CA 94103
CONTENTS

CHAPTER 1
Dreamweaver MX Tutorials ........................................ 5
What you will learn ........................................... 5

CHAPTER 2
Using Tables to Design a Page Layout Tutorial .............. 7
Before You Begin ................................................. 8
Create and modify a table in Standard view .................. 8
Add color to a table ........................................... 12
Set a relative width table in Standard view ................. 14
Create a pixel width based table .............................. 14
Design a page in Layout view ................................ 15
Draw a layout cell ............................................. 16
Add multiple layout cells .................................... 17
Move or resize a layout cell .................................. 18
Add color to a table ........................................... 20
Set a relative width table in Layout view .................. 21
Take the next step ............................................. 22

CHAPTER 3
Image Alignment and Image Maps Tutorial .................. 23
Before You Begin ................................................. 23
Set image alignment ........................................... 24
Set image spacing ............................................. 26
Create an image map ........................................... 26
Take the next steps ............................................. 30

CHAPTER 4
Working with Dreamweaver Design
Files Tutorial .................................................... 31
Before You Begin ................................................. 32
Working with code snippets ................................... 32
Insert a code snippet ......................................... 32
Add a content code snippet .................................. 35
Add a footer code snippet .................................... 36
Modify the snippet content ................................... 36
Save code as a snippet ........................................ 37
Take the next steps ................................................................. 38

CHAPTER 5
Designing with Cascading Style
Sheets Tutorial................................................................. 39
Before you begin ............................................................. 40
Open the CSS Styles panel ............................................. 41
Redefine an HTML tag .................................................. 41
Set a page background color ........................................ 43
Set a style for links ....................................................... 44
Export styles to create an external style sheet ................. 45
Attach an external style sheet ....................................... 45
Take the next steps ....................................................... 46

CHAPTER 6
Building a Master-Detail Page Set Tutorial...................... 47
Before you begin ............................................................. 48
Create a master-detail page set .................................... 48
Create a database recordset ......................................... 50
Insert a Master-Detail Page Set application object .......... 53
View your pages ............................................................ 55
Take the next steps ....................................................... 56

CHAPTER 7
Building an Insert Record Page Tutorial.......................... 57
Before you begin ............................................................. 57
Create an insert page .................................................... 58
Add form objects .......................................................... 59
Define an Insert Record server behavior ....................... 63
Test your page ............................................................. 65
Take the next steps ....................................................... 65
The Dreamweaver MX tutorials are step-by-step lessons, designed to teach you the fundamentals of Dreamweaver MX. We recommend that you go through the tutorials using the sample files installed in the GettingStarted folder within the Dreamweaver application folder.

By completing these hands-on tutorials, you'll learn how to use Dreamweaver's visual environment to add design elements as you create web pages and web applications. The tutorials are targeted toward beginner to intermediate-level web designers who are looking to get up-to-speed quickly with processes they may already perform while developing web pages and applications.

Each tutorial focuses on a specific web design feature or topic. We suggest that you complete the tutorials in sequence, although you may choose to review only the sections of interest to you.

Additional tutorials are available at the Macromedia website (http://www.macromedia.com/go/dreamweaver_tutorials).

What you will learn

Each tutorial takes approximately 30 - 45 minutes to complete, depending on your experience. The tutorials cover the following topics and tasks:

“Using Tables to Design a Page Layout Tutorial” on page 7 takes approximately 45 minutes to complete and focuses on the following tasks:
  - “Create and modify a table in Standard view” on page 8
  - “Add color to a table” on page 12
  - “Set a relative width table in Standard view” on page 14
  - “Design a page in Layout view” on page 15
  - “Draw a layout cell” on page 16

“Image Alignment and Image Maps Tutorial” on page 23, takes approximately 20 - 30 minutes to complete, and focuses on these tasks:
  - “Set image alignment” on page 24
  - “Set image spacing” on page 26
  - “Set space and alignment options” on page 26
  - “Create an image map” on page 26
  - “Set image map areas” on page 27
  - “Open a linked file in a new window” on page 29
“Working with Dreamweaver Design Files Tutorial” on page 31, takes approximately 20 - 30 minutes to complete, and focuses on these tasks:

• “Working with code snippets” on page 32
• “Insert a code snippet” on page 32
• “Modify the snippet content” on page 36
• “Save code as a snippet” on page 37

“Designing with Cascading Style Sheets Tutorial” on page 39, takes approximately 30 minutes to complete and focuses on these tasks:

• “Open the CSS Styles panel” on page 41
• “Open a document to work in” on page 40
• “Set a style for links” on page 44
• “Export styles to create an external style sheet” on page 45

“Building a Master-Detail Page Set Tutorial” on page 47, takes approximately 30 minutes to complete and focuses on these tasks:

• “Create a master-detail page set” on page 48
• “Create a database recordset” on page 50
• “Insert a Master-Detail Page Set application object” on page 53
• “View your pages” on page 55

“Building an Insert Record Page Tutorial” on page 57, takes approximately 40 minutes to complete and focuses on these tasks:

• “Create an insert page” on page 58
• “Add form objects” on page 59
• “Define an Insert Record server behavior” on page 63
• “Test your page” on page 65
CHAPTER 2
Using Tables to Design a Page Layout
Tutorial

If you are familiar with HTML coding, you already know that text or any other content you add in a web page flows from one margin to the other unless it is inserted in a “container,” such as a layer or a table. HTML tables are an excellent solution for designing web page layout, because they are easy to modify and compatible with most browsers. You can use tables to structure the layout of tabular data or to set the display of visual elements (such as Flash buttons, images, or paragraphs of text).

Dreamweaver has two views in which you can design tables—Standard view and Layout view. In this tutorial you learn to design page layout in both views. In the first section of the tutorial, you work in Standard view and insert a table in a page. In the latter section, you work in Layout view, where you use layout options to draw a table and table cells to design the layout.

This tutorial focuses on using tables as a page layout element. By completing this tutorial you will learn how to accomplish the following tasks:

• “Create and modify a table in Standard view” on page 8
• “Add color to a table” on page 12
• “Set a relative width table in Standard view” on page 14
• “Design a page in Layout view” on page 15
• “Draw a layout cell” on page 16
• “Add multiple layout cells” on page 17
• “Move or resize a layout cell” on page 18
• “Set a relative width table in Layout view” on page 21
• “Design a page in Layout view” on page 15
Before You Begin

If you haven't already done so, before you start the tutorial, create a new folder into which you'll transfer the GettingStarted sample files.

1 At the root level of your local disk, create a new folder and name it Sites—for example, C:\Sites (Windows) or Hard Drive:Sites (Macintosh).
   If you are using Windows XP or Macintosh OS X, create the Sites folder inside your user folder.

2 Locate the Tutorials folder in the Dreamweaver application folder on your hard disk. The path to the folder is:
   \Macromedia|Dreamweaver MX\Samples\GettingStarted\Tutorials

3 Copy the Tutorials folder into the Sites folder.

4 In Dreamweaver, define the Tutorials folder you copied as your local site. If you do not know how to define a local site in Dreamweaver, you can follow the directions provided in the chapter, “Creating Your First Website in Dreamweaver,” in Dreamweaver Help (Help > Using Dreamweaver).

   You can also use the Dreamweaver Site Definition Wizard to be guided through the site setup process. In Dreamweaver, choose Site > New Site, then click the Basic tab to begin setting up your site.

Create and modify a table in Standard view

Standard view is the typical Dreamweaver design view. To create a table in Standard view, you use the Insert Table command. Dreamweaver creates a table based on options you select in the Insert Table dialog box. You can easily modify the initial table structure to create more complex design by merging and splitting cells, and by inserting rows and columns.

You use the table cells (the boxes created at the intersection of each column or row in a table) to control the placement of text and images in a web page. Because you can make the borders of tables invisible, viewers won't see the underlying structure of your design when they look at the page in a browser.

1 In Dreamweaver, choose File > New.

   The New Document dialog box appears.

2 In the Blank Document list, choose HTML, then click Create to create a new HTML document.

3 In the Title text field in the Document toolbar, enter Table Design to add a title to your document.

4 Choose File > Save, then save the document in your local site folder. Name it tableModify.htm.

Insert a table

Now you're ready to insert a table in the document.

1 In the Document window, place the insertion point in the document, then do one of the following:
   • Select Insert > Table.
In the Insert bar’s Common category, click the Table icon. The Insert Table dialog box appears.

2 In the dialog box, set the following options:
   • In the Rows text box, type 2.
   • In the Columns text box, type 2.
   • In the Width text box, type 600, and then select Pixels in the pop-up menu to the right of the Width text box.
     Setting the width to 600 pixels creates a fixed width table. We’ll discuss table width in more detail a little later in this tutorial.
   • In the Border text box, type 1 to set a 1-pixel border around the table and table cells.

3 Click OK.
Dreamweaver inserts the table in the document.
4 Save your document by doing one of the following:
   • Select File > Save.
   • Press Control+S (Windows) or Command+S (Macintosh).

Modify the table

Next, you’ll modify the table’s layout. You’ll add rows and columns to the table, and learn how to merge and split cells to create the desired page layout.

1 Click in the top-left cell then drag down to the bottom row to select the left column.

2 Select Modify > Table > Insert Column.
   The table now contains three columns.

3 Click in the bottom left cell and then select Modify > Table > Insert Rows or Columns.
   The Insert Rows or Columns dialog box appears.

   Tip: Select the Insert Rows or Columns option when you want to add a specific number of rows or columns, or to choose where a row or column is inserted in a table.

4 In the dialog box, set the following options:
   For Insert, select Rows.
   In Number of Rows, type 2.
   For Where, select Above the Selection.

5 Click OK.
   The table updates. You now have a four-row by three-column table.

6 Save your changes (File > Save).
Merge and split cells

By merging and splitting cells you can customize a table’s design to fit your layout needs. Next, you’ll see how to use menu options or the Property inspector to merge or split table cells.

1. In the document, select the first two cells in the left column of the table, by dragging your pointer from the top left cell to the cell below it.

2. Choose Modify > Table > Merge Cells.

   The two cells merge into a single cell.

3. Click in the third row of the second column, then drag to the right and down to select the last two rows of cells in the second and third columns.

4. In the Property inspector, click the Merge button to combine the cells.

   The selected cells merge into one cell.

You can split a single cell or column.

5. Click in the top left cell.
6 In the Property inspector, click the Split Cell button. The Split Cell dialog box appears.

![Split Cell dialog box]

7 In the dialog box, set the following options:
- For Split Cell Into, select Columns.
- In Number of Rows, enter 2.

8 Click OK.

The table is modified.

![Modified table]

**Change row height and column width**

Let's adjust the table's dimensions. You'll increase the amount of space between the table rows, and adjust the amount of space between the table columns.

1 Move the pointer along the bottom table border until it changes into a border selector, then drag it down to resize the table.

![Resized table]

You can use this method to resize the other row heights in the table if you'd like.

2 Move the pointer along a column border until it changes to a border selector, then drag it to the left or right to change a column's width.

3 When you are done adjusting your table, save your document.

**Add color to a table**

You can add color to any part of a table. You’ll start by adding a background color to the entire table, then apply a different background color to cells in the table. You’ll finish by changing the border color.
1. In the document, click in any cell of the table, then in the tag selector located at the bottom left of the Document window, click the `<table>` tag to select the entire table.

2. Open the Property inspector (Window > Properties), if it isn't already open. Properties for the selected table appear in the Property inspector.

3. In the Property inspector, in the Bg Color text box select a color by doing one of the following:
   - Click the color picker pop-up, then choose a color from the color picker.
   - Enter a color using a hexadecimal value, for example `#CC9933`.
   - Enter a web-safe color name, such as goldenrod.
   A background color applies to the table.

4. You can apply a background color to the cells of the table the same way. Click in the top-left cell, then in the Property inspector, select a different color in the Bg Color text box.

5. Color additional cells as you desire.

**Add a border color**

Now, you'll set the table border color. Border color applies to both the outside and inside borders of a table.

1. In the Document window, select the table.

2. In the Property inspector, in the Brdr Color text box, use the color picker to select a border color for your table.

3. When you are done, save your document.

4. Press F12 (Windows only) or select File > Preview in Browser and select a browser to view the document in.
Set a relative width table in Standard view

A percentage-based table stretches and shrinks based on the width of a browser window. (For example if you specify that a table uses a width of 75%, the table stretches to fill 75% of the horizontal space regardless of the browser window size. This can be useful in some instances, such as making sure a navigation menu is always displayed when a window is resized.

When you want to set the size of a table regardless of how a user resizes the browser window, use pixel-based tables. When you want the table to stretch to the size of the browser window, percentage-based tables are best.

To see the difference in percentage-based and pixel-based tables, you’ll add one of each to a page, then view it in a browser.

1 In Dreamweaver, choose File > New.
2 In the New Document dialog box, the Basic Page category is already selected; in the Basic Pages list, double-click HTML to create a new HTML document.
   The document opens in the Document window.
3 Save this file to your local site folder. Name it tableWidth.
4 Place the insertion point in the document.
5 In the Common tab of the Insert bar, click the Table button.
6 In the dialog box that appears, set the following options:
   In the Rows text box, type 2.
   In the Columns text box, type 3.
   In the Width text box, type 90, and select Percentage in the pop-up menu to the right of the Width text box.
   In the Border text box, enter 1 to set a 1-pixel border around the table and table cells.
7 Click OK.
   The table appears in the document.
8 Click in the top, middle cell and drag to the bottom cell to select the middle column.
9 In the Property inspector, use the color picker to apply a background color to the column.

Create a pixel width based table

Now you’ll add another table. A pixel width table is set to a specific width and doesn’t adjust to the browser window size.

1 Insert a paragraph return after the table you just inserted.
2 In the Common tab of the Insert bar, click the Table button.
In the dialog box that appears, set the following options:

In the Rows text box, type 2.
In the Columns text box, type 3.
In the Width text box, type 600, and then select Pixel in the pop-up menu to the right of the Width text box.
In the Border text box, type 1 to set a 1-pixel border around the table and table cells.

Click OK.
The table appears in the document.

Select the middle column by clicking in the top, middle cell and dragging down to the bottom cell.

In the Property inspector, use the color picker to apply a background color to the column.

Press F12 (Windows only) or select File > Preview in Browser and select a browser to view the document in.

Resize the browser window to see how the two tables respond to browser window changes. The pixel-based table retains its size, while the percentage-based table adjusts to fill the browser.

When you are done viewing the document, close your browser window.

Save your document.

**Design a page in Layout view**

Now that you’ve learned how to work with the Insert Table command, let’s look at another way to work with tables—by drawing the table layout.

Next, you’ll work in Layout view, which allows you to draw layout cells or layout tables into which you can add content such as images, text, or other media.

In Layout view you can draw layout cells and layout tables to define the design areas of a document. You can start by inserting a table cell or a layout cell. When you insert a layout cell first Dreamweaver automatically creates a table to surround it.

**Create and save a new document**

In Dreamweaver, choose File > New.

In the New Document dialog box, Basic Page is already selected, in the Basic Pages list select HTML then click Create to create a new HTML document.

The document opens in the Document window.

Save the document in your local site folder, and name it **tableLayout.htm**.
Draw a layout cell

1 In the Insert bar, click the Layout tab, then click the Layout view button to switch from Standard view.

The Getting Started in Layout View dialog box appears and describes the Layout view options.

2 Review the options, then click OK to close the dialog box.

3 In the Insert bar there are two Layout options available—Draw Layout Cell and Draw Layout Table; these options aren’t available in Standard view.

4 If the Property inspector isn’t already open, choose Window > Properties to open it.

5 In the Insert bar, click the Draw Layout Cell button.

6 Move the pointer to the Document window; the mouse pointer changes to a drawing tool (looks like a small cross). Click in the upper left corner of the document, then drag to draw a layout cell.

When you release the mouse, a layout cell appears in a layout table.

The layout table expands to fill the Document window, and sets the page’s layout area. The white rectangle is the layout cell you drew. You can place additional layout cells in the empty area of the layout table.
7 Draw another cell to create a text area above the navigation buttons.

Add multiple layout cells

Next you’ll learn how to add a series of layout cells. You’ll add three layout cells next to the cell you just created to create layout for the page’s navigation buttons.

1 In the Insert bar, click the Draw Layout Cell button; then hold down the Control key (Windows) or Command key (Macintosh) so you can draw multiple cells in the table.
2 In the Document window, position the pointer below the last cell you drew; then drag to draw a layout cell.

Continue to hold the Control key (Windows) or Command key (Macintosh) and draw two more layout cells. Your screen should look similar to this:

3 Click in a blank area of the Insert bar, to deselect the Draw Layout Cell tool. (The drawing tool changes to a selection arrow.)

**Move or resize a layout cell**

If you need to line up the cells next to each other you can resize and move the layout cells. You change the size of a layout cell by using one of its resize handles.

You can move a layout cell to a new position in a document, as long as there is room in the layout table to reposition the cell. Sometimes you will have to resize surrounding cells to make a desired change. If you want to move a layout cell to reposition it in a document, follow these steps.
1 Click the border of a layout cell to select it.
Handles appear around a selected layout cell.

2 Do one of the following:
• Drag the layout cell to move it to another position.
• If there is space around the layout cell, use the left, right, or up arrow, as appropriate, to move the cell.

**Resize a layout cell**

To design a page precisely, you can set the size of cells you add in a document. You can also reposition cells in the page.

1 Click the border of the layout cell to select it.

2 To resize a layout cell:
   In the Property inspector for the layout cell, type a number for the desired cell width or height. For example, type 200 in the Height text box to set the cell's height to 200 pixels, then click in the document to see the cell width change.

*Note:* If you enter a pixel width or height that exceeds the dimension of the layout table, or that causes the cell to overlap another cell in a layout table, Dreamweaver alerts you and adjusts the cell width to a valid width.
Add color to a table

You can add color to any part of a table. You'll start by adding a background color to the entire table, then apply a different background color to cells in the table. You'll finish by changing the border color.

1. In the document, click in any cell of the table, then in the tag selector located at the bottom left of the Document window, click the <table> tag to select the entire table.

2. Open the Property inspector (Window > Properties), if it isn't already open. Properties for the selected table appear in the Property inspector.

3. In the Property inspector's Bg Color text box, select a color by doing one of the following:

   - Click the color picker pop-up then choose a color from the color picker.
   - Enter a color using a hexadecimal value, for example #CC9933.
   - Enter a web-safe color name, such as goldenrod.

   A background color applies to the table.

4. Select a cell by clicking the cell's border, then in the Property inspector choose a color to apply to it.
5  Add a background color to the other cells in your table, if you'd like.

6  Save your document.

**Set a relative width table in Layout view**

By default, when you draw a table or cell in Layout view, Dreamweaver creates the table with fixed width columns. You can change a fixed-width table or cell to relative width by using the Autostretch feature.

Autostretch allows you to create a relative width table, and applies flexible layout for the column you set as an expandable column, so that a table automatically spans to fill a browser window.

Information about column widths appears in the column header area at the top of each column of a table. Table width information appears in the table’s column header. A fixed-width column has a specific numeric width, such as 200 pixels, while the column header for an autostretch column contains a wavy line. You can only make one column in a table autostretch. You can easily change which column Autostretch applies to.

You’ll set one of the columns of your table to automatically stretch so that the table fills a browser when viewed.
1 In the document, in the column header click the table column you want to make autostretch.

![Image of a table with column headers and a menu for making columns autostretch]

2 In the pop-up menu that appears, choose Make Column Autostretch.

   The Choose Spacer Image dialog box appears.

3 In the dialog box, select Create a Spacer Image File.

4 The Save Spacer Image File As dialog box appears, accept the default values to save the image as spacer.gif, in a location relative to the Site Root.

   **Tip:** If you already have a spacer image you can select that choice so you don’t create different spacer images for each table you design.

   The column header changes from a numeric value to a wavy line. The Property inspector also updates to reflect that Autostretch is applied to the table.

5 Save your file.

6 Choose File > Preview in Browser, and select which browser to view your page in.

   The column automatically expands and contracts depending on the size of the browser window.

**Take the next step**

In this tutorial you learned how to create tables in Dreamweaver. Along the way, you modified table rows and columns, set background colors to table elements, and learned how to create “flexible” table design in both Standard and Layout view.

For detailed information about topics covered in this tutorial, see “Designing the Page Layout” and Presenting Content with Tables” in the *Using Dreamweaver MX* documentation or Dreamweaver Help (Help > Using Dreamweaver)
CHAPTER 3
Image Alignment and Image Maps Tutorial

Working with images in Macromedia Dreamweaver MX is quite easy. You can use various Dreamweaver visual tools to insert an image. This tutorial presents you with image options you can apply once an image is inserted in a page. You will learn about aligning images and text, and setting space around an image. You’ll also learn how to use a single image to link to multiple web pages.

This tutorial is designed for beginning Dreamweaver users. It covers some basic features in Dreamweaver and will help you understand how to align images, as well as how to create an image map.

In this tutorial you will accomplish the following tasks:

- “Set image alignment” on page 24
- “Set image spacing” on page 26
- “Set space and alignment options” on page 26
- “Create an image map” on page 26
- “Set image map areas” on page 27
- “Open a linked file in a new window” on page 29

Before You Begin

If you haven’t already done so, before you start the tutorial, create a new folder into which you’ll transfer the GettingStarted sample files.

1. At the root level of your local disk, create a new folder and name it Sites—for example, C:\Sites (Windows) or Hard Drive:Sites (Macintosh).
   
   If you are using Windows XP or Macintosh OS X, create the Sites folder inside your user folder.

2. Locate the Tutorials folder in the Dreamweaver application folder on your hard disk. The path to the folder is:

   \Macromedia|Dreamweaver MX|Samples\GettingStarted|Tutorials

3. Copy the Tutorial folder into the Sites folder.

4. In Dreamweaver, define the Tutorials folder you copied as your local site. If you do not know how to define a local site in Dreamweaver, you can follow the directions provided in the chapter, “Creating Your First Website in Dreamweaver,” in Dreamweaver Help (Help > Using Dreamweaver).

   You can also use the Dreamweaver Site Definition Wizard to be guided through the site setup process. In Dreamweaver, choose Site > New Site, then click the Basic tab to begin setting up your site.
Set image alignment

An image, like text, appears in the normal flow of HTML in a page and can appear as a paragraph by itself, or as part of a paragraph of text. You can set the alignment of an image in two ways in the Property inspector using the text alignment or image alignment controls.

Text alignment positions the paragraph in which the image is inserted and can be used to align an image to the left or right margin or to center it. Image alignment lets you set the relationship of an image to other content in the same paragraph (including another image). In Dreamweaver, the Align pop-up menu lets you select how the image aligns with the text.

Note: Not all of the image alignment options work in all browsers. In this tutorial you will use alignment options that work in Microsoft Internet Explorer and in Netscape Navigator.

View the completed document

Before you begin, look at the completed file to see what you’ll do in this tutorial.

1. Choose File > Open, and in the dialog box that appears, navigate to the GettingStarted folder you created, then navigate to Tutorials/Completed and open the file named imageAlign_comp.htm.

   The file opens in the Document window.

2. Press F12 (Windows only) or select File > Preview in Browser and select a browser to view the document in.

   The file shows three examples using image alignment and spacing to work with images and text together.

3. When you are done viewing the file close your browser window.

Open a file to work in

You’ll work in a partially completed document that contains three images and text in a table. The table confines the layout, enabling you to easily see how the different settings affect the alignment.

1. Choose File > Open and navigate to the imageAlign.htm file located in the Tutorials folder.

   This document contains the same images and text as the completed file you viewed previously.
In the Document window, click the first image (next to the table cell that contains the text Alignment).

The image is in the same paragraph as the text.

2. Open the Property inspector (Window > Properties), if it isn’t already open.

In the Align text box, notice that this is the default alignment for an image. It places the image on the baseline of the line of text.

3. With the image still selected, in the Align pop-up menu choose Middle to see what this setting does.

   The first line of text aligns to the middle of the image.

4. With the image still selected, in the Align pop-up menu, choose Left.

   The image now appears on the left and the text wraps along its right side.

   Tip: Text in the same paragraph as an image wraps around the image and then flows beneath the image. If you insert a paragraph return in the flowed paragraph, it is no longer aligned to the image and appears in a new paragraph below the image. If you want to add space without disrupting the text wrap use a paragraph break, Control+Enter (Windows) or Command+Return (Macintosh).

5. Choose File > Save to save your changes.

6. Select File > Preview in Browser, then select a browser to preview the document in or press F12 (Windows only) to view it in a browser window.

   You see the image and text aligned.

7. When you are done viewing the file, close your browser window.
Set image spacing

As you see, when you place an image in a paragraph, text appears right next to the edge of the image. In the next step you’ll add a margin of space between the image and text.

You can use the horizontal and vertical space properties in the Property inspector to create space around an image. The horizontal space property adds space to the Left and right of the image, while the vertical space property adds space above and below an image.

1 In the image_align.htm document, click the second image in the page (next to the table cell that contains the text Spacing).
2 In the Property inspector, enter 10 in the V Space text box to set the vertical spacing.
3 Move the pointer to the H Space text box, enter 30, then press Enter or Return to set the horizontal spacing.

A margin of space is created between the text and the image. The spacing also affects the distance between the image and the table border.

Set space and alignment options

As the final step in this part of the tutorial, you’ll set both alignment and space properties for the image.

1 In the imageAlign.htm document, click the third image in the page (next to the table cell that contains the text Alignment and Spacing).
2 In the Property inspector, in the Align pop-up menu choose Right.
   The image moves to the right.
3 In the HSpace text box, enter 30, then click elsewhere in the Property inspector or in the Document window for the value to update.
   A margin of space is added between the image and text.

Create an image map

An image map is an image that serves as a navigation device. With an image map, you can create multiple hotspots (clickable areas) in a single image and have each hotspot link to a different URL or file to open. You can also set where a linked document opens; for example you can open the document in a particular frame of a frameset document, or open it in a new browser window.
View the completed file

Take a look at the completed file to see what you’ll create. The completed image map includes links to other document. You will open the document in a browser window to see how the links work.

1. Choose File > Open, and in the dialog box that appears, navigate to the GettingStarted folder you created, then navigate to Tutorials/Completed and open the file named imagemap_comp.htm.

The document opens in the Document window.

2. Press F12 (Windows only) or select File > Preview in Browser then select a browser to view the document in.

3. Roll the pointer over the light purple areas. The pointer changes to a hand, letting you know that the areas link to another document.

4. Click North America.

A new page opens.

5. Click your browser’s back button to return to the world map page.

6. Click the other hotspot.

The linked document opens in a new browser window.

7. When you are done viewing the pages, close your browser.

Set image map areas

You will create an image map so that a single image links to multiple pages.

1. In Dreamweaver, choose File > Open, then navigate to and open the file named imagemap_start.htm.

2. In the document, click the image of the world map to select it.
Open the Property inspector if it isn’t already open, and click the expander arrow in the lower right area of the Property inspector to see all the image properties, if necessary.

Image map options appear in the expanded Property inspector.

In the Map Name text box, type **Locations**.

**Tip:** If you create more than one image map in a document, each map must have a unique name. Each image map can have multiple hotspots as well.

Click the Rectangular Hotspot Tool to select it.

In the Document window, click in the area above and to the left of North America, then drag the pointer down and to the right over the image to create a hotspot area.

A blue layer appears over the image, and the hotspot Property inspector appears.

In the Link text box, click the folder icon. In the dialog box that appears, navigate to the file named **location1.htm** to set a link to it.

In the Alt text box, type **North America**.
Note: You should always set alternate text for images in your documents, including image maps, this provides descriptive information about an image for page viewers who are using text-only browsers.

That's it—you've set the first hotspot. Let's set one more.

Open a linked file in a new window

So you can see how hotspot tools differ, this time you'll use the Polygon Hotspot tool to define the hotspot area. The polygon tool allows you to set connecting points to define a hotspot area. You'll also learn how to open the linked document in a new window.

1 In the Property inspector, click the Polygon Hotspot Tool to select it.
2 In the Document window, click the image where you want to start the hotspot, and move the pointer to the next position; a line forms between the dots.
3 Continue clicking around the shape to define Europe as the hotspot area.
   Note: As you click, the image map area adjusts and fills in, keep clicking around the shape to cover the area you want to include.
4 When you’re finished mapping the image, click the Arrow button in the Property inspector to change the pointer from a drawing tool.
5 In the Link text box, click the folder icon, then browse to the file named location3.htm to open this file when the hotspot is clicked.
6 In the Target pop-up menu, choose _blank.
   When a user clicks the hotspot, the Locations3 page will open in a new window.
7 In the Alt text box, enter Europe.
8 Press F12 (Windows only) or select File > Preview in Browser then select a browser to view the document in and test the links.
9 Save and close your file.
Take the next steps

In this tutorial you worked with several aspects of images. You learned how to use the Property inspector to set image alignment, define space around an image, and to create an image map.

For more information about topics covered in this tutorial, see the Inserting Images chapter, and the Linking and Navigation chapter in the Using Dreamweaver MX documentation and Dreamweaver Help.

Topics you may also be interested in:

- Cascading style sheets (positioning)
- Table alignment
- Attaching behaviors
Macromedia Dreamweaver MX comes with an extensive set of professionally designed assets—page layout documents, Cascading Style Sheets (CSS), and code snippets. You can use these assets to quickly get started creating professionally designed web pages.

In this tutorial, you will create a new document, then insert and modify design element code snippets. You’ll also learn how to create your own code snippet.

This tutorial focuses on the following tasks:

• “Working with code snippets” on page 32
• “Insert a code snippet” on page 32
• “Modify the snippet content” on page 36
• “Save code as a snippet” on page 37
Before You Begin

If you haven’t already done so, before you start the tutorial, create a new folder into which you’ll transfer the GettingStarted sample files.

1. At the root level of your local disk, create a new folder and name it Sites—for example, \Sites (Windows) or Hard Drive:Sites (Macintosh).
   If you are using Windows XP or Macintosh OS X, create the Sites folder inside your user folder.

2. Locate the Tutorials folder in the Dreamweaver application folder on your hard disk. The path to the folder is:
   \Macromedia\Dreamweaver MX\Samples\GettingStarted\Tutorials

3. Copy the Tutorials folder into the Sites folder.

4. In Dreamweaver, define the Tutorials folder you copied as your local site. If you do not know how to define a local site in Dreamweaver, you can follow the directions provided in “Creating Your First Website in Dreamweaver,” in Getting Started with Dreamweaver MX (Help > Using Dreamweaver)

You can also use the Dreamweaver Site Definition Wizard to be guided through the site setup process. In Dreamweaver, choose Site > New Site, then click the Basic tab to begin setting up your site.

Working with code snippets

Using code snippets can be a real time-saver in creating a professional looking page layout. Code snippets are reusable bits of code. You can insert existing code snippets that come with Dreamweaver or you can easily create your own code snippets to reuse in pages in your sites. You can create snippets of HTML, JavaScript, CFML, ASP, JSP, and more.

You’ll start by working with some of the code snippets that come with Dreamweaver.

You can create a new document that is based on a Page Design document in the New Document dialog box.

1. Select File > New.
   The New Document dialog box appears.

2. In the General tab, the Basic Page category is already selected.

3. In the Basic Page document list, select HTML, then click Create.
   The document opens in the Document window.

4. Save the document as myCodeSnippets in your site (File > Save).

Insert a code snippet

Dreamweaver comes with quite a variety of code snippets from which to choose. Code snippets are located in the Code panel. As you complete this tutorial, you’ll insert a navigation code snippet, a content snippet, and a footer snippet.

1. Place the insertion point in the document where you want the snippet inserted.

2. Open the Snippets panel by doing one of the following:
   • Choose Window > Snippets.
• In the Code panel, click the expander arrow if you need to, then choose Snippets.
The Snippets panel appears.

3 Click the plus (+) button in front of the Navigation folder to see its content.
Additional folders appear.
4 Click the plus (+) button in front of the Tab folder to see its content, then click Basic Tabs to select it.
The snippet is displayed in the preview pane.
5 In the Snippets panel, click the Insert button located at the bottom of the Snippets panel to insert it in the document. The snippet appears in the document.

6 Save your document (File > Save).
Add a content code snippet

Next you’ll add a table in which to add content. You’ll insert the snippet directly below the navigation table code snippet you just inserted.

1. Press Enter or Return to move the insertion point to the next line.

2. In the Snippets panel, click the plus (+) button in front of the Content Tables folder, then click the plus (+) button in front of the One-pixel-border folder to see the snippets in the folder.

3. Click Text B to select it, and then click Insert to insert the snippet in the document.

The snippet appears in the document.

4. Save your document (File > Save).
Add a footer code snippet

Now you’ll add the final snippet, a snippet for footer content.

1. Press Enter or Return to move the insertion point to the next line.
2. In the Snippets panel, click the plus (+) button in front of the Footers folder to see the snippets in the folder.
3. Click Basic: Brief Text to select it, and then click Insert to insert the snippet in the document.

The snippet appears in the document.

Modify the snippet content

Next, you’ll edit the placeholder text and apply color changes. You’ll apply background color to the cells to set your own color scheme.

1. Open the Property inspector (Window > Properties), if it isn’t already open.
2. Place the pointer in the first cell of the Navigation table you inserted. The cell contains the text “Lorem.”
3. In the Property inspector’s Bg text box, click the arrow on the color swatch to open the color picker, then select a color to apply to a background of the cell.

   We used purple, #9966FF.

4. Place the pointer in the cell that contains the text “Ipsum.”
5. In the Property inspector’s Bg text box, click the arrow on the color swatch, then choose a different color to apply to a background of the cell.

   We used a lighter purple, #9999FF.
6 Repeat step 5, applying the same color to the cells containing the text “Dolor” and “Amit.”

7 Click in the table cell that contains the text content, then select a color to apply to the table cell.

8 Make additional changes you want.

9 When you are done, save your document.

10 Press F12 (Windows only) or select File > Preview in Browser and select a browser to view the document in.

Save code as a snippet

Working with existing code snippets is very easy. You can just as easily create code snippets of your own. For example, let’s say you want to reuse the code snippets you updated in the document you just created.

Let’s save the navigation snippets as a new snippet.

1 In the Snippets panel navigate to the Navigation Folder, then to the Tab folder to select the folder in which the snippet will be saved.

2 In the Document window, click in the navigation cell which contains the text “Lorem.”

3 In the tag selector, located at the bottom left of the document window, click the <table> tag.

In the Document window, the table is selected.
4 Do one of the following to save the selection as a code snippet:

- Right-click (Windows) or control-click (Macintosh) the selected table, then choose Create
  New Snippet.

- In the Snippets panel, click the plus (+) button located at the bottom of the panel.
  The Snippet dialog box appears.

5 In the Name text box, enter a name to describe your snippet.
   We named the example snippet **purple navigation**.

6 In Description, enter a description for the snippet.

7 You can view snippet descriptions in the Snippets panel to the right of the snippet name.

8 For Snippet Type, select Insert Block. This will insert the snippet as a complete block of code,
   rather than a snippet that wraps the text it is applied to.

9 Click OK.

10 In the Snippets panel, the new code snippet is added to the Tab folder.

**Take the next steps**

In this tutorial, you learned how to locate, view, and insert code snippets that come with
Dreamweaver. You also learned that creating your own code snippets is a easy task to accomplish.
For more information about topics covered in this tutorial, see Dreamweaver Help (Help > Using
Dreamweaver).
You can use Cascading Style Sheets (CSS) in Macromedia Dreamweaver MX to apply style elements consistently across multiple pages of a site. CSS styles offer great flexibility in that style is not confined to text objects. You can define positioning and formatting styles to text, images, tables, layers, and so on.

In this tutorial you experiment with a few styles, and get a glimpse of just some of the many style options CSS affords you.

In this tutorial you will accomplish the following tasks:

- “Open the CSS Styles panel” on page 41
- “Redefine an HTML tag” on page 41
- “Set a style for links” on page 44
- “Export styles to create an external style sheet” on page 45
Before you begin

If you haven’t already done so, before you start the tutorial, create a new folder into which you’ll transfer the GettingStarted sample files.

1 At the root level of your local disk, create a new folder and name it Sites—for example, C:\Sites (Windows) or Hard Drive:Sites (Macintosh).

   If you are using Windows XP or Macintosh OS X, create the Sites folder inside your user folder.

2 Locate the Tutorials folder in the Dreamweaver application folder on your hard disk. The path to the folder is:

   \Macromedia\Dreamweaver MX\Samples\GettingStarted\Tutorials

3 Copy the Tutorial folder into the Sites folder.

4 In Dreamweaver, define the Tutorials folder you copied as your local site. If you do not know how to define a local site in Dreamweaver, you can follow the directions provided in the chapter, “Creating Your First Website in Dreamweaver,” in Dreamweaver Help (Help > Using Dreamweaver).

   You can also use the Dreamweaver Site Definition Wizard to be guided through the site setup process. In Dreamweaver, choose Site > New Site, then click the Basic tab to begin setting up your site.

Open a document to work in

You’ll start by opening a document to work in.

1 In Dreamweaver, select File > Open.

2 In the dialog box that appears, navigate to the Tutorial folder in the local site you defined, then double-click the file named css_start.htm to select it.

   The document opens in the Document window.

   ![Document window](image)

   This document includes several elements—text, tables, and links. Very few elements in the page have any formatting style applied to them at all. By redefining the body tag, you’ll define styles which will apply a global change to the document.
Open the CSS Styles panel

You use the CSS Styles panel to create, view, apply or edit style attributes.

The CSS Styles panel has two views or modes. Use the Apply Styles view to apply custom or class CSS styles, and you use the Edit Styles view to make changes to styles you have applied to your document. You can create a new style while working in either view.

1. Open the CSS Styles panel (Window > CSS Styles), if it is not already open.

2. In the CSS Styles panel, click the New CSS Style button (+) at the bottom of the panel. The New CSS Style dialog box appears.

Redefine an HTML tag

You can apply CSS styles to any tag in a document. The first style you’ll create will redefine the style attributes of the body tag.

1. In the New CSS Style dialog box, for Type, select Redefine HTML Tag.

2. In the Tag pop-up menu, select body.
3 In Define In, select This Document Only.
For now we'll apply the style to this document, later you'll see how to export the style so you can use it in other pages in the site. Your dialog box should look similar to this:

![CSS Style definition dialog box](image)

4 Click OK.
The CSS Style definition dialog box appears.

![CSS Style definition for body](image)

5 Set the following Type settings:
- In the Font pop-up menu, select Arial, Helvetica, sans serif.
- In the Size pop-up menu, select 12 and pixels.
- In Color, click the color picker, then use the eyedropper to select white.
Set a page background color

Next, you’ll use the Background category in the CSS Styles panel to set background options.

1. Under Category, select Background.
   
   CSS background attributes appear.

2. In Background Color, do one of the following to set a background color:
   
   • Click the color picker then use the eyedropper to select a dark blue or move eyedropper to the Document window and select the blue in the Global logo image.
   
   • In the Background Color text box, enter #333366
   
   3. Click OK.
      
      The dialog box closes and the style is immediately applied to the document.
4 In the CSS Styles panel, select Edit Styles.

The new style appears in the list along with a description of the style attributes.

Set a style for links

With the new style applied you can barely distinguish the hypertext links in the document. Let’s create a style for the links.

1 In the CSS Styles panel, click the New CSS Style button (+) located at the bottom of the panel. The New CSS Style dialog box appears.

2 In Type, select Use CSS Selector.

3 In the Selector pop-up menu, select a:link.

4 In Define In, select This Document Only.

5 Click OK.

The CSS Style definition dialog box appears.
6 Set the following Type attributes for the link:
   In Decoration, select Overline.
   In Color, in the text box, enter #FFCC99.
7 Click OK.
8 To see the style you applied to the links you must view the page in a browser, press F12 to preview your page.

Export styles to create an external style sheet

The CSS styles you’ve created so far have only applied to this document. Internal style sheets apply only to the document in which they were created. Now, you’ll learn how to create an external style sheet which contains the styles you defined in this document.
1 Choose File > Export > Export CSS Styles.
   In the Export CSS Styles dialog box appears.
2 In the dialog box, in the Save In (Windows) or Where (Macintosh) pop-up menu, navigate to your local site folder.
3 In File Name (Windows) or Save As (Macintosh), name the file mystyle.css.
   Note: You can name a CSS style sheet any name you want, with the following exceptions; the name must be lowercase and contain no spaces.
4 Click Save.

Attach an external style sheet

You’ll attach the CSS style sheet you just created to another document in your site. The document you’ll work with is the same as the original css_start.htm file, before you added style to it.
1 In Dreamweaver, open the Site panel (Window > Site), if it isn’t already open.
2 In the Site panel, locate the file named css_start2.htm, then double-click it to open it in the Document window.
3 In the CSS Styles panel, click the Attach Style Sheet button located at the bottom of the panel.
   The Link External Style Sheet dialog box appears.
4 In the File/URL text box, enter the path to mystyle.css or click Browse and in the dialog box that appears navigate to the mystyle.css file, then click OK to select it.
5 In the Link External Style Sheet dialog box, for Add As, select Link.
6 Click OK.
   The selected style sheet links to the current document, and the style attributes are immediately applied.
Take the next steps

In this tutorial, you learned how to create basic CSS styles. You also learned how to export styles you applied in a document to create an external CSS style sheet.

For more information about topics covered in this tutorial, see the following topics in Dreamweaver Help (Help > Using Dreamweaver).

About Cascading Style Sheets
Creating a new CSS style
Creating and linking to an external CSS style sheet
Creating a document based on a Dreamweaver design file
CHAPTER 6
Building a Master-Detail Page Set Tutorial

A Master-Detail Page set is a web application which presents information extracted from a database in two formats. The master page displays a list of all records retrieved as a result of a database search. A detail page links from the master page and usually provides more specific details about an item selected in the master page.

You can complete this tutorial in following server models—ColdFusion, ASP, and JSP.

In this tutorial you will build a master and detail page set. The tutorial takes approximately 20 minutes to complete, depending on your experience, and will teach you how to do the following tasks:

- “Create a master-detail page set” on page 48
- “Create a database recordset” on page 50
- “Insert a Master-Detail Page Set application object” on page 53
- “View your pages” on page 55
Before you begin

If you completed the chapter, “Developing a Web Application in Dreamweaver MX,” in the Getting Started with Dreamweaver MX section of this guide, the files you need to complete this tutorial are already located in your local site and your remote site.

If you did not complete the lesson, you will need to transfer the Sample files to your local drive and to your application server. See the appropriate setup chapter for your web application server for direction on how to set up the files.

For more information, see “Setup for Sample ColdFusion Site,” “Setup for Sample ASP Site,” or “Setup for sample JSP Site” in Dreamweaver Help (Help > Using Dreamweaver)

You must have completed the following tasks prior to starting this tutorial:

- Configured your system.
- Configured Dreamweaver to work with your chosen application server.
- Defined a connection to the database.

Create a master-detail page set

A good starting point for developing a database application is to display a list of the records stored in a database. The master-detail page set you develop will list the company’s car rental locations, as well as detailed information about each location, such as the telephone number and address.

All of the information about Global’s locations is stored in a Microsoft Access database file, global.mdb. If you followed the instructions in the appropriate Setup chapter in this guide, you should already have a connection to this database. The web application pages will not update without a connection to this database.

Let’s start by selecting a page to work in.

1 Do one of the following to open the Site panel:

- In the Files panel group, click the expander arrow, then select the Site tab if it is not already selected.
- Choose Window > Site.
• Press F8.
  The Site panel opens.

2 In the Sites pop-up menu, select the GlobalCar site you defined.

3 In the Site panel, double-click the locationMaster file to open it.
  The document opens in the Document window. You will edit the partially completed page.
Create a database recordset

Now you’ll create a recordset to display data that is stored in a database. A recordset is a subset of information extracted from a database by a database query. (In ASP.NET, a recordset is known as a DataSet.) A database query consists of search criteria, which defines what’s included in the recordset. You then use the information extracted as a source of data for your dynamic pages.

Dreamweaver MX provides an easy-to-use interface for creating simple SQL queries—you don’t need to know SQL to create a recordset in Dreamweaver.

You’ll create a recordset that selects all of the values from the Locations table.

1. In Dreamweaver, open the Recordset or DataSet (ASP.NET) dialog box by doing one of the following:
   - In the Insert bar’s Application tab, click the Recordset or DataSet (ASP.NET) button.
   - Choose Window > Bindings to open the Bindings panel, then click the Plus (+) button and select Recordset or DataSet.
   - In the Application panel group, select the Bindings panel, then click the Plus (+) button and select Recordset or DataSet.

   The Recordset orDataSet dialog box appears. The screen below shows the ColdFusion recordset dialog box. (In ASP.NET this is the DataSet dialog box; most of the recordset options are the same for all server models.)

2. In the Name text box, enter rsLocations.
   This is the name of the recordset you are defining.
3 In the Data Source pop-up menu (ColdFusion) or the Connection pop-up menu (other server page types), select connGlobal.

The Recordset or DataSet dialog box updates and displays information for the first table in the Global database.

**Note:** If the connGlobal connection doesn’t appear in the menu, click the Define button to create it.

4 In the Table pop-up menu, select LOCATIONS.

The recordset updates with records in the LOCATIONS table.

5 For Columns, accept the default setting, All.

**Tip:** To limit the information the recordset includes you can choose Selected, then select the column(s) you want to work with.
6 Click Test to test the recordset.

The database records that match your recordset request are displayed in the Test SQL Statement window.

7 Click OK to close the Test SQL Statement window.

8 Click OK to close the Recordset or DataSet dialog box, and add the recordset code to your page.

Dreamweaver confirms that a recordset has been added to the page and the recordset appears in the Bindings panel.

**Tip:** If you do not see all of the recordset fields, click the Plus button to expand the recordset branch.
Insert a Master-Detail Page Set application object

Dreamweaver includes several application objects that help you create web application pages quickly and easily.

Next, you'll use an application object to create a master-detail page set. Application objects create layout and server-side scripts for many common web applications. After you select a few options, the Master-Detail Page Set application object generates the forms and scripting for both the master list and the page containing the details for you. Additionally, the application object creates record navigation and a record counter in the master page.

1  Save your document (File > Save).
2  In the Document window the locationMaster file should still be open, place the insertion point after the "Rental Locations" text, then press Enter or Return to set where the live object will be inserted.
3  Insert the data, by doing one of the following:
   • In the Insert bar's Application tab, click the Master Detail button or drag it to the document.
   • Choose Insert > Application Objects > Master Detail Page Set.
     The Insert Master Detail Pages Set dialog box appears.

4  In the dialog box, in the Recordset pop-up menu, select rsLocations.
5  In the Master Page Fields list, select CODE, then click the Minus (-) button to remove it from the list of data which appears in the master page list.
6 Remove all the fields in the Master Page Fields list except LOCATION_NAME, CITY, and STATE_COUNTRY.

7 In the Link To Detail From pop-up menu, select LOCATION_NAME.

   To view the detail page for a location, a link needs to be created for each location that appears in the master list. When a site visitor clicks the Location Name in the master page the appropriate detail page will open.

8 In the Pass Unique Key pop-up menu, accept the default value, Code and make sure Numeric is not checked.

   The CODE field is the unique key or primary key in the Locations table. This field contains a unique three letter code for each record.

9 In Show, accept the default setting to display ten records at a time.

10 In Detail Page Name, click Browse, then in the Select File dialog box, navigate to the locationDetail file in your site folder.

11 Click OK.

12 In the Detail Page Fields, set the fields you want to appear in the detail page, by doing the following:

   In the Detail Page Fields list, select CODE, then click the Minus (-) button.

   Select REGION_ID, then click the Minus (-) button.

13 Click OK.

   Dreamweaver updates the master and detail pages, and adds all the necessary server scripts and queries for both the list page and the detail page.

   The master list page updates. It includes a table for the database data, a table for recordset page navigation, and a record set counter.

   The detail page also updates. It includes a table that lists details for each record in the master page.
View your pages

Next, you’ll save the pages, then view them to see how the application you developed works. To view pages as they would look when processed by the server, you can preview your page in a browser.

1. In the Document window, select the locationDetail document, and choose File > Save to save your work.

2. In the Site panel, select the locationDetail document, then click the Put Files button (blue up arrow) to copy the local file to your server.

3. In the Document window, select the locationMaster document, and choose File > Save to save it.

4. In the Site panel, select the locationMaster document, then click the Put Files button (blue up arrow) to copy the local file to your server.

5. With the locationMaster document still selected, press F12 to view the page in a browser. Test the links from the master page to the details page.

6. Below the table of data, click Next, to view the next set of ten records.

   The data table, navigation bar, and record counter update.

7. Click one of the location names to see the detail page.

   The master page passes the unique key to the server, the server processes the query, and the detail page opens and displays the data for the selected location.

8. Press the Locations button located at the top of the page to return to the locations list.

9. Close the browser window when you are finished viewing the pages.

10. In Dreamweaver, close your pages.
Take the next steps

In this tutorial you learned how to create a master-detail page set in Dreamweaver.

For detailed information about topics covered in this tutorial, see the following topics in the *Using Dreamweaver MX* documentation or Dreamweaver Help:

- Building master/detail pages rapidly
- Building master/detail pages block by block
- Modifying master/details pages
This tutorial walks you through the steps of building a form which inserts information into a database. As you create the insert page you’ll learn how to insert and define form fields. You’ll also learn how to create a form field which lets users insert information using a dynamically generated menu.

You can complete this tutorial in all of the server models supported by Dreamweaver MX—ColdFusion, ASP, ASP.NET, JSP, and PHP.

In this tutorial you will accomplish the following tasks:

- “Create an insert page” on page 58
- “Add form objects” on page 59
- “Define an Insert Record server behavior” on page 63
- “Test your page” on page 65

Before you begin

If you completed the chapter, “Developing a Web Application in Dreamweaver MX,” in Getting Started with Dreamweaver MX (Help > Using Dreamweaver), the files you need to complete this tutorial are already located in your local site and your remote site.

If you did not complete the lesson, you will need to transfer the Sample files to your local drive and to your application server. See the appropriate setup chapter for your web application server for direction on how to set up the files.

For more information, see “Setup for Sample ColdFusion Site,” “Setup for Sample ASP.NET Site,” “Setup for Sample ASP Site,” “Setup for Sample JSP Site,” and “Setup for Sample PHP Site,” in Dreamweaver Help (Help > Using Dreamweaver).

You must have completed the following tasks prior to starting this tutorial:

- Configured your system.
- Configured Dreamweaver to work with your chosen application server.
- Defined a connection to the database.
Create an insert page

The page you’ll create lets the site administrator insert new rental car location information in the Global Car Rental database.

You’ll start in a partially completed page. Along the way you’ll add form objects and dynamic content to the page.

Let’s start by selecting a page to work in.

1 Do one of the following to open the Site panel:
   • In the Files panel group, click the expander arrow, then select the Site tab if it is not already selected.
   • Choose Window > Site.
   • Press F8.

   The Site panel opens.

2 In the Site pop-up menu, select the Global Car site you defined for your application server type.
3 In the Site panel, double-click the insertLocation document to open it. The document opens in the Document window.

Add form objects

A table and some of the form fields have already been added to this page. A red, dashed rectangle appears in the document, this is the form boundary. Dreamweaver automatically inserts a form boundary in a document when you insert a form object.

Now you’ll add the remaining form fields for the insert page—three text fields, a list/menu field, a submit button, and a reset button.

You’ll also provide labels for form fields. Naming the fields makes it easier for you to identify the fields you are working with later when you connect the form fields to the database fields.

We’ll begin by looking at one of the existing form fields.

1 Open the Property inspector (Window > Properties), if it isn’t already open.

2 Move the pointer to the top-right cell, click the form field to select it.

   The Property inspector updates displaying the form field properties.

   The Name field contains the form object’s name, and the Char Width field sets the field’s width to 30 characters. You’ll update these same two fields in the text fields you add to the form.

3 In the document, place the insertion point in the table cell to the right of the State or Country label, then do one of the following to insert a text field:

   • In the Insert bar, click the Forms tab, then click the Text Field button (second from the left) or drag it from the Insert bar to the table cell.

   • Choose Insert > Form Objects > Text Field

   The text field form object is inserted in the document.
4 With the text field still selected, in the Property inspector, enter state_country in the Name text box and enter 30 in the Char Width text box.

5 In the document, place the insertion point in the table cell to the right of the Region label, then do one of the following to insert a List/Menu:
   - In the Insert bar’s Forms category, click the List/Menu button or drag it from the Insert bar to the table cell.
   - Choose Insert > Form Objects > Text Field
     The list/menu form object inserts in the document.

6 In the Property inspector, enter region_id in the Name text box.
   A list/menu object generates its character width to the length of the longest item in the list or menu. We’ll define the menu items and values for this field a little later.

7 Insert a text field for Telephone, and then in the Property inspector name it telephone, and in the Char Width field enter 30.

8 Insert a text field for Fax, and then in the Property inspector name it fax, and in the Char Width field enter 30.

9 In the document, place the insertion point in the bottom table cell.
10 Add a submit button for the form by doing one of the following:
  • In the Insert bar’s Forms category, click the Button button or drag it from the Insert bar to
    the table cell.
  • Choose Insert > Form Objects > Button.
    A Submit button inserts in the document. In the Property inspector, the button is already
    labeled and the Action is set to Submit form.

11 Repeat step 10 to add another button to the form. You’ll add a reset button to let a user reset
    the form if they need to.

12 In the Property inspector, for Action, select Reset form.

13 In the Button Name text box, enter Reset.

Your form is now complete and should look similar this:

14 Save your document.
Define the List/Menu form field

Now you'll update the list/menu field adding information which will let a user select the text name for a region, and update the database with its numeric value. This way a user doesn't have to check to verify which number matches which name.

1  In the document, click the Region_Id list/menu form field to select it.
   The Property inspector updates with information about the object.

2  In the Property inspector, click the List Values button.
   The List/Menu dialog box appears.

3  In the List Values dialog box, add Item Labels and Values to match the data in the REGIONS database table.

4  In Item Label, enter North America, press Tab, and in Value enter 1.

5  Click the plus (+) button to add another entry, then enter South/Central America, press Tab, then enter 2.

6  Repeat steps 4 and 5, until you enter all of the regions as in the dialog box below.

7  Click OK to close the dialog box.
Define an Insert Record server behavior

You'll use a server behavior to create the necessary server scripts for the application. You'll create a connection between the form field data and the database data so that completing the form and clicking the Submit button inserts the information into the database.

1 In the Server Behaviors panel (Window > Server Behaviors), click the plus (+) button and choose Insert Record from the pop-up menu.

The Insert Record dialog box appears.

2 In the Data Source (ColdFusion) or Connection pop-up menu (other server page types), choose connGlobal.
3 In the Insert Into Table pop-up menu, choose LOCATIONS.

![Insert Record Dialog Box](image)

The Columns list updates with information about how the form fields relate to the database fields.

4 Make sure REGION_ID's value is set to Numeric or Integer (ASP.NET), since the Region ID is a numeric value rather than a text value.

5 In After Inserting, Go To or On Success, Go To (ASP.NET), click Browse and in the dialog box that appears select the LocationOK file, then click OK to close the dialog box.

6 Click OK to close the Insert Record dialog box.

In the Document window, the form updates and the Server Behaviors panel shows the Insert Record behavior is added.

7 Save your document.
**Test your page**

Next, you’ll copy the completed page to your server, then open it in a browser and insert some information.

1. In the Site panel, select insertLocation, then click the Put Files button (blue up arrow) to copy the local file to your server. Choose Yes, when asked to copy dependent files.

2. With insertLocation selected in the Document window, choose File > Preview in Browser or press F12 (Windows) to view your document.

3. Enter test data in the form, then click the Submit button.

   The locationOK page appears indicating information was successfully inserted in the Global database.

4. To view the entry you added to the database do the following:

   In the Application panel group, select the Databases panel. Locate the connGlobal database, then click the plus (+) in front of it to expand it. Click the plus (+) in front of Tables to view the database tables. Right-click (Windows) or Control-click (Macintosh) the LOCATIONS table and then select View Data. The database records appear; the new record is the last entry in the database.

**Take the next steps**

In this tutorial you learned how to create a dynamic record insertion form in Dreamweaver. For detailed information about topics covered in this tutorial, see the following topics in the Using Dreamweaver MX documentation or Dreamweaver Help:

- Creating Interactive Forms
- Adding Dynamic Content to Web Pages
- Building a page to insert records
- Setting the Record Insertion Form dialog box options