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About This Book
Welcome to Data Analysis and Reporting with Brio Intelligence 6.6 — Tables, 
Pivot Tables, Charts, and Reports. This book is designed to help you learn the 
Brio Intelligence application, part of the Brio Intelligence integrated suite of 
powerful and easy-to-use business intelligence tools for query, OLAP analysis, 
and analytical reporting across the extended enterprise. 

Audience
Data Analysis and Reporting with Brio Intelligence 6.6 is written for all levels of 
Brio Intelligence users, from those who need to simply retrieve and view data 
in a report format, to those who need to build queries and reports as well as 
analyze data.

In This Book
Data Analysis and Reporting with Brio Intelligence 6.6 – Tables, Pivot Tables, 
Charts, and Reports, one of four books that explain how to use Brio Intelligence 
(see “Related Documents” on page xiii), shows you how to use Brio 
Intelligence to analyze database information and create a wide range of reports 
including tables, pivot tables, charts, and free-form, presentation-quality 
reports for broad-scale publishing across the organization. 

■ Chapter 1, “Introduction,” introduces the types of reports available in Brio 
Intelligence and provides an overview of reporting concepts. It also explains 
Brio Intelligence’s approach to analyzing and reporting data.

■ Chapter 2, “Working with Tables,” explains how to use tables to organize 
your data. 



■ Chapter 3, “Analyzing Data with Pivot Tables,” explains how to use pivot 
tables to quickly summarize or cross-tabulate large amounts of data. 

■ Chapter 4, “Charting Data,” explains how to use Brio Intelligence’s charting 
features to perform interactive analysis of your data in a graphic format.

■ Chapter 5, “Designing Custom Reports,” explains how to use the Report 
Designer, Brio Intelligence’s dynamic analytical report writer, to create free-
form, presentation-quality reports.

In addition, a glossary and index provide definitions and easy access to 
information contained in the book.

Typographic Conventions
This book uses the following type conventions:

■ Options, buttons, or tabs that you need to choose and text that you need to 
type are indicated in bold.

Select Typical Install. Type 1234.

■ Key names are shown in square brackets.

Press [Down Arrow]

■ Two key names joined with a plus sign (+) are consecutive keystrokes. Press 
and hold down the first key while pressing the second key. 

Press [Ctrl+Z].

■ Options in a menu command path are separated with an arrow. The 
example indicates that you are to open the File menu and choose the Open 
menu item.

Choose File→Open. [Ctrl+O]

Note When an instruction includes a menu command, the toolbar icon (if one exists) for the 

command appears in the left margin. The keyboard shortcut (if one exists) for the command is 
listed in brackets at the end of the line.

■ Variables you replace with specific information are shown in italics.

sp_adduser login_id

✏
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■ Files, directories, and paths are shown in a monospace font. 

Sample1.bqy is located in the BrioQuery/Samples directory.

■ A Note, Tip, or Caution is a brief side-note that deserves special attention or 
does not fit within the normal flow of text. These types of information are 
set off in the text by an icon in the margin.

Tip This is an example tip.

Caution This is an example caution.

Related Documents
Along with the Data Analysis and Reporting with Brio Intelligence 6.6 book, 
there are three additional Brio Intelligence books: 

■ Getting Started with Brio Intelligence 6.6 – Query and Results provides an 
overview of Brio Intelligence and explains the user interface and basic 
commands. It includes how to retrieve data, how to query new data and 
change existing queries, and how to query a single database as well as 
multiple databases. It also covers how to work with query results. 

■ Brio Intelligence 6.6 Administrator’s Guide explains data modeling, 
including how to modify existing data models, and create new data models. 
It also discusses metadata definitions, database connectivity, and document 
scheduling. 

■ Brio Intelligence Object Model and Executive Information Systems explains 
the Brio Intelligence Object Model and how to create custom EIS 
applications using JavaScript. 

Help
Brio Intelligence comes with a number of user manuals as well as an extensive 
online help system. If you need help with Brio Intelligence and cannot find the 
answers you need in the documentation, and you have a current Brio Technical 
Support agreement, call Brio Technical Support at +1(800)337-6324 (within 
North America) or +1(619)610-5769. You may also send an email message to 
support@brio.com.

Please be prepared to provide your valid customer number and company 
name. You also need to know the version of Brio Intelligence you are using.

✰
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1 Introduction

Welcome to Data Analysis and Reporting with Brio Intelligence 6.6 Tables, Pivot 
Tables, Charts, and Reports. This book shows you how to use Brio Intelligence 
to analyze database information and create a wide range of reports including 
tables, pivot tables, charts, and free-form, presentation-quality reports for 
broad-scale publishing across the organization. 

This book assumes that you are familiar with the terms and concepts covered 
in Getting Started with Brio Intelligence 6.6.

This chapter introduces the types of reports available in Brio Intelligence and 
provides an overview of reporting concepts. It also explains Brio Intelligence’s 
approach to analyzing and reporting data. This chapter includes:

■ Brio Ingelligence’s Approach to Data Analysis and Reporting

■ Brio Intelligence Reports
1-1



Brio Ingelligence’s Approach to Data Analysis and Reporting
Once a query is processed and data results are returned to the desktop, you can 
use Brio Intelligence’s reporting and analysis tools to create custom views, 
cross-sections, and drill-downs to slice and dice data and view the 
multidimensional relationships it contains. You may create as many different 
views of the data as you wish, and display the information in any form and 
from any angle possible. You can also use Brio Intelligence to work 
autonomously with data. Even without a database connection, you can analyze 
data and produce reports. 

Brio Intelligence’s report features include: 

■ A point-and-click interface for intuitive custom report building.

■ Easy, non-procedural navigation between reporting sections.

■ A drag-and-drop Outliner tool for developing reports and analyzing data.

■ Interactive pivot reporting that lets you perform unrestricted drill-down 
analysis of different data relationships.

■ Extensive formatting tools for creating compelling data presentations.

■ An easy-to-use, interactive charting utility for graphically displaying and 
drilling-down into data.
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Brio Intelligence Reports
Brio Intelligence enables you to create a wide variety of reports, including:

■ Tables – Columnar arrangements of data. Tables are used as building blocks 
in other reporting sections. You can apply limits to tables, add computed 
items, include subtotals and grand totals, as well as summary totals such as 
sum, count or average.

■ Pivot tables – Interactive tables that quickly summarize or cross-tabulate 
large amounts of data. You can rotate rows and columns to see different 
summaries of data or display the details for areas of interest. A pivot table 
summarized data by using a summary function that you specify, such as 
Sum, Count, or Average. You can include subtotals and grand totals 
automatically, or use your own formulas by adding computed items. 

■ Charts – A visual display of information; fully interactive, three-
dimensional views of data. Brio Intelligence displays data from results sets 
as bars, lines, columns, pie slices, or other shapes in the chart. When you 
create a chart, the values from the worksheet are automatically represented 
in the chart. Charts are linked to the data they are created from and are 
updated when you change the data.

■ Custom reports – Using Brio Intelligence’s Report Designer, you can create 
free-form presentation-quality reports with graphic objects, predefined 
fields, band-style report data from multiple data sources and computed 
fields, charts, and pivots; Smart reports allow you to embed charts and 
pivot tables and show only the data that is relevant to the section in which 
they are placed.
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2 Working with Tables

This chapter explains how to use tables to organize your data. It contains:

■ Table Section

■ Creating a Table

■ Tables as a Data Staging Area

■ Manipulating Table Data

■ Working with Table Components

■ Table Menu Command Reference
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Table Section
A table is a columnar arrangement of data. In Brio Intelligence, tables are used 
as building blocks in other reporting sections. Table sections function in much 
the same way as the Results section. All of the commands that are available on 
the Results menu are also available on the Table menu. However, you cannot 
apply complex limits or aggregate data in the Table section.

The data in a Table section is derived from the section that is active when you 
choose to insert a new table. When you insert a Table section from the Results 
section, the new Table Section is attached to the Results section. This means 
any changes to the results set are immediately propagated to the Table section. 

You can also create additional tables, pivot tables, charts, and other reports 
form a Table section’s dataset just as you would from the Results section. 
Limits, computed columns, grouping columns, and other actions that modify 
the active section’s data set carry over to all tables and reporting sections built 
from that section. 

Column Heading

Limit Line

Sort Line

Section
Pane

Catalog
Pane

Results 
Columns

Column
Title

Row

Cell

Table 
Outliner

Table Menu

Select All
Corner
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Creating a Table
Use the Table Outliner to construct, plot, and manage data. 

To create a table based on the Results section data:

1 From the Results section, choose Insert→New Table.

If the Table Outliner is not already displayed, click Outliner on the Section title 
bar.

2 Drag Results items from the Catalog pane to the Table Outliner.

Brio Intelligence automatically populates the table columns.

Tables as a Data Staging Area
Computed items in the Results section become mere data elements when 
added to a Table section. Thus, the Table section can become an intermediate 
calculation staging area. This ability comes in handy in applications where you 
wish to place limits on computed items.

For example, suppose you wanted a report of the top 10 producers in your 
organization. It is easy to add a computed item to your Results section that is 
based on the Rank function. (This function lets you find out each producer’s 
rank relative to the others.) However, when you try to limit the results based on 
that ranking, Brio Intelligence informs you that limits cannot be placed on 
aggregate items.

To get the results you want, you need to insert a new Table section that is based 
on your Results section. Then add all the relevant Results items, including the 
computed Rank field. Once Rank is a column in the table, it is no longer a 
computed item. It is a regular number on which you can now place a limit. 
Since the Table section is based on the Results section, your Top 10 report will 
automatically be updated each time you run the query.
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Manipulating Table Data
The Table menu provides a number of commands that allow you to 
manipulate the data in the Table section.

Limiting Data in a Table
Limiting data in a table filters the data displayed in the table columns. You can 
apply limits in the Table section in addition to any limits set in the originating 
section. Limits set in the Table section are automatically propagated to any 
other reports that inherit their data set from the table. You can apply only one 
limit per column.

To return data to the display and make it available for reporting, delete or 
suspend the limit.

To limit data in a table:

1 Select a column (click the column heading) and choose Table→Limit. [Ctrl+L]

The Limit dialog box appears.

2 Select an arithmetic or logical operator from the drop-down list.

3 Define the potential limit values by clicking one of the following options:

■ Show Values – Shows column values associated with the item. 

■ Custom Values – Supplies an empty field for inputting custom values. Click 
the check mark to add a value to the list.

4 In the Values list, select the values to include in the limit definition. 

Individually select values or click Select All and deselect the values you do not 
want to include.

5 When the values are highlighted in the values panel, click OK.

The limit is applied to the column and the column name is added to the Limit 
line.
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To remove a limit in a table:

To remove all limits in a table:

Sorting a Table
The rows in a table can be sorted by one or more columns in ascending or 
descending order. You can also apply sequenced, nested sorts to columns in the 
Table section. 

To sort a column:

To apply sort conditions using the Sort line:

1 Click Sort on the Section Title bar to display the Sort line.

2 Drag Results items from the Catalog pane to the Sort line.

You can add items to the Sort line that are not in the Outliner.

3 Establish a final sort sequence by reordering sort items.

Items are sorted left to right on the sort item. To reorder the sequence, drag 
each item to its new position.

4 Double-click specific sort items to toggle ascending and descending sort orders.

Ascending is the default sort order.

5 Click Sort Now on the Sort line.

➤ Select the limit item that you want to remove and choose Table→Remove. [Del]

➤ Click Limit on the Limit line and choose Table→Remove. [Del]

➤ Select the column you want to sort and choose Table→Sort Ascending or Sort 
Descending.
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Adding Computed Items
You can rank and provide statistics for the values represented in the totals or 
subtotals in your Table section. The Add Computed Item feature enables you 
to build equations to compute totals, or to apply functions to existing values. 
Computed items are like normal data items and can be included in reports or 
reused to compute other data.

For example, you can modify an Amount Sold item by building an equation 
around it, multiplying by a Unit Price item, and renaming the resulting item 
Revenue. You can also apply a scalar function such as Cume to Amount Sold and 
return each individual value as a cumulative running total, or simply multiply 
Amount Sold by the local tax rate to find the tax owed on each sale.

The Computed Item dialog is used to build a computed item expression. The 
computed item expression is a value, variable, logic statement, or equation that 
instructs Brio Intelligence how to perform a computation.

To create a computed item:

1 Choose Table→Add Computed Item.

The Computed Item dialog box appears. 

2 In the Name field, type a name that describes the computation.

The default name is Computed, which is numbered sequentially if there is 
more than one. If you assign a name to a computed item that is identical to an 
existing scalar function name, Brio Intelligence numbers the name starting 
with the number 2.
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3 Define the new data item by building an expression in the Definition text box. 

Use the operator buttons to insert arithmetic and logical operators at the 
insertion point. 

■ Click Reference to display the Reference dialog box, and select Request 
items to place in the equation.

■ Click Functions to apply scalar functions using the Functions dialog box.

You also may type any portion of the equation or the entire equation directly 
into the Definition text box using JavaScript. The names are case sensitive, and 
you must replace spaces in item names with underscores (‘_’). 

4 If necessary, click the Options button to set a new data type for the item.

5 When the equation is complete, click OK.

The computed item is added to the Outliner and appears as a column in the 
table. 

Adding Grouping Columns
Grouping columns, like computed items, is a way of creating new data in your 
results set by grouping data from an already existing column. You can use 
grouping columns to consolidate non-numeric data values into more general 
group values and map the group values to a new column in the data set.

Grouping columns are new items added to the Table section and are available 
for use in report sections.

For example, your company sales database may contain the items: State, Sales 
Region, and Country, which allow you to aggregate data on different levels in 
reports. However, suppose you are looking to track sales by subregion, or want 
to see data for one state versus an average for all other states combined. You 
can do this by grouping states together to create a subregion item or other 
custom dimension.

To add a grouping column:

1 Select a column as a base for your grouping column.

2 Choose Table→Add Grouping Column.

The Grouped Column dialog box appears. Use the column values to build the 
grouping categories for the new item.
Manipulating Table Data 2-7



3 Type a name for the new column in the Column Name field.

4 Create custom group values and link them to values in the base column.

■ Click New Groups to create groups and add them to the Groups list.

■ Select a group, and then select items from the Available Values list and use 
the arrows to add them to the Items In Group list for the selected group.

■ Remove selected values from a group by using the arrow to move them back 
to the Available Items list.

■ Double-click a group name to modify it.

■ Specify options for ungrouped values as follows:

❑ Column Name – Names the new grouping column in the table.

❑ New Groups – Creates a custom group to be displayed as a value in the 
new grouping column. 

❑ Options – Indicates how to represent unassigned values within the 
grouping column, that is, as null values, as members of a default group 
(named in the adjacent edit field), or as their own individual groups.

❑ Groups – Selects a custom group to define by adding or removing items. 

❑ Items In Group – Removes an item from a selected custom group. 

❑ Available Values – Adds items to a selected custom group.
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■ Select one of the following options to define the preferences for ungrouped 
columns:

❑ Null – Leaves the values ungrouped and disaggregated.

❑ Default – Allows you to specify a default name to assign to all 
ungrouped values. 

❑ Individual Group – Assigns each ungrouped values the name originally 
assigned to it.

5 When the grouping definitions are complete, click OK.

The new grouping column is added to the Outliner and to the table. 

You can modify a grouping column to change the group structure.

To modify a grouping column:

Adding Date Groups
Use date breakout columns to separate date-typed columns into Year, Quarter, 
and Month items. The new items are automatically derived using date 
functions available to computed items.

For example, when you add date groups for an item Order Date, the item is 
broken into constituent date items. A new Year item is created as an integer, 
Qtr as a string, and Month as a new date.

To break out date items:

1 Select a date-type column in the Content pane.

2 Choose Table→Add Date Group.

Note This feature automatically sets the display format of the new Month item to mmm so that the 
data sorts correctly. Quarters are based on the calendar year beginning 1/1.

➤ Select the grouping column and choose Table→Modify Column.

✏
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Applying Data Functions to Tables
In the Tables section, data functions can be used only for totals and subtotals. 
Data functions return to the underlying values and recalculate the value 
according to the type of function specified. 

You can apply a break (subtotal), grand, or custom total to any column. A 
grand total on a numeric column applies a default sum function. However, 
each column can have a number of grand totals, each with a different aggregate 
function applied to it. Table 2-1 lists the data functions that you can use with 
break totals and grand totals.

To calculate a column total:

Brio Intelligence adds a row labelled Total to the bottom of the table and 
displays the total as the last entry in the selected column.

Grand Total
To apply a grand total to a column using a data function:

1 Select a column and choose Table→Grand Total.

The Insert Grand Total dialog box appears.

Tab le 2 -1 Break Total and Grand Total Data Functions

 Function Description

Sum Returns sum of underlying values. 

Average Returns average of underlying values.

Minimum Returns lowest of underlying values.

Maximum Returns highest of underlying values.

Count Returns number of underlying values.

Other Allows you to create a custom function using JavaScript.

➤ Select the column to be totaled and click the summation icon on the Standard toolbar.
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2 Select a data function from the Grand Total Function drop-down list.

3 Select one or more columns to be totaled from the Add Grand Total To list and click OK.

The total and any subtotals in the column are computed to reflect the new data 
function.

Break Total
To apply a break total (subtotal):

1 Select a column and choose Table→Break Total.

The Insert Break Total dialog box appears.

2 Select a break column from the At Every Break drop-down list.

3 Select the data function you want to apply from the Break Total Function drop-down list.

4 Select one or more columns on which to display the break total and click OK.
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Working with Table Components
Brio Intelligence offers a number of options for working with table 
components (that is, columns and rows) in the Table section. These commands 
are found on the Format and Results menus. Many of these commands also 
have corresponding toolbar icons and shortcut menu items.

Selecting Columns and Rows

To select a column:

To select a row:

Deleting Columns
To delete a selected column from the Results table (and Outliner):

If an item is removed from the Content pane, it is completely removed from 
the Outliner and the data set. 

Caution Remove items with caution as computed items and other report sections may 
draw data values from the deleted item.

Formatting Commands
You can use the commands available on the Format menu to change the 
appearance of fonts, backgrounds, borders, color, row heights, and column 
widths. For more information on formatting options, see Getting Started with 
Brio Intelligence 6.6.

➤ Click anywhere inside the column.

➤ Click the row header (row number).

➤ Choose Results→Remove. [Del]

!
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Table Menu Command Reference
Table 2-2 provides a quick reference to the commands available on the Table 
menu and lists any related shortcuts.

Tab le 2 -2 Table Menu Commands

Command Description
Keyboard
Shortcut

Shortcut
Menu

Limit Opens the Limit dialog box. [Ctrl+L] ✔

Sort Ascending Sorts the selected column values in ascending order 
(alphabetical or numeric).

✔

Sort Descending Sorts the selected column values in descending 
order (alphabetical or numeric).

✔

Add Computed Item Opens the Insert Computed Item dialog box. ✔

Add Grouping Column Opens the Grouped Column dialog box. Use to 
merge dimension labels into new groupings and 
aggregate the associated data.

✔

Add Date Groups Separates date-type items into year, quarter, and 
month items.

Modify Column Use to modify a computed column or a group 
column.

[Ctrl+M]

Remove Removes the selected column (or Outliner item). [Del] ✔

Break Total Opens the Insert Break Total dialog box. ✔

Grand Total Opens the Insert Grand Total dialog box. ✔

Hide Column Hides the selected column from view. ✔

Unhide Column Opens the Unhide Column dialog box. ✔
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3 Analyzing Data with Pivot Tables

This chapter explains how to use pivot tables to quickly summarize or cross-
tabulate large amounts of data. It contains:

■ Pivot Section

■ Creating a Pivot Table

■ Working with Pivot Tables

■ Using Data Calculations in Pivot Tables

■ Pivot Menu Command Reference
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Pivot Section
The Pivot section enables you to extract meaningful information from your 
query results. Pivot tables are interactive tools used to slice and dice data for 
ad-hoc, interactive, and multidimensional analysis. Pivot tables allow you to 
add, move, rename, focus on, and group dimensions to gain customized views 
of the data. You can rotate or pivot rows and columns to see different 
summaries of data or display the details for areas of interest. You also can 
automatically include subtotals and grand totals, or use your own formulas by 
adding computed items.
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3-2 Analyzing Data with Pivot Tables



Creating a Pivot Table
Pivot tables are made up of:

■ Facts – Core numeric data that you slice and dice dimensionally in your 
analysis. 

■ Dimensions – Descriptive items that break aggregate data (facts) into 
logical categories. In the Pivot section, dimensions are either Top Labels or 
Side Labels.

For example, if you choose to analyze Unit Sales by region, the numbers are 
your data values or facts. Region is a dimension. Presented in aggregate, facts 
are subdivided by your chosen dimension labels.

To create a pivot table:

1 Choose Insert→New Pivot.

2 If the Outliner is not visible, click Outliner on the Section title bar.

3 In the Catalog pane, select one or more Request items and choose Pivot→Add Selected 
Items→Outliner Pane.

■ Add Request items such as Unit Sales or Amount Sales to the Facts pane in 
Outliner to create the data grid.

■ Add dimensions such as Product Line or Region to the Top and Side Labels 
panes in Outliner to create subdivisions.

Items are hierarchically ordered in the sequence in which they appear in the 
Outliner panes.

Pivoting Data
Use the Pivot feature to reorient the axes of a pivot table and view your data in 
new ways. Pivoting a table allows you to more easily compare the new data to 
data in the originating table, which makes pivot tables more powerful than 
common spreadsheets.

To pivot data in a table:

➤ Select a dimension handle and drag it to any position on the same or opposite 
dimensional axis.
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Charting a Pivot Table
You can automatically generate charts from your current pivot table to view a 
graphic representation of your data.

To automatically chart your pivot table:

Brio Intelligence creates a new Chart section that displays a bar chart based on 
the data from the pivot table.

Working with Pivot Tables
You can select pivot table elements and perform a wide range of tasks with data 
elements. Since report sections organize data hierarchically, if you alter a data 
value item, all instances of the item within the report are affected.

Selecting Pivot Table Elements
To select a facts column for formatting, layout, or modification:

To select a column of Side Labels or a row of Top Labels for formatting, layout, 
or analysis:

To select one complete row or column for formatting or analysis:

To select an individual Top Label or Side Label for formatting:

➤ Choose Insert→Chart This Pivot. 

➤ Click anywhere on the column of data values. Do not click on the label.

➤ Click the dimension handle at the end of the column or row of labels.

➤ Press the modifier key ([Alt] for Windows, [Option] for Macintosh, or [Ctrl+Alt] for Motif). 
Then, click the row or column label.

➤ Click the label itself.
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Moving Pivot Table Elements
To move a column to a new location in the Content pane:

To remove Request items from the Outliner or columns from the Content 
pane:

Note When you delete a Request item from the Outliner or a column from the Content pane, you 
cannot use the Undo feature to reinsert the column or Request item.

To move a pivot element item using the Outliner:

The display updates to reflect the repositioning or reassignment of the item.

Note To move items between Top Labels or Side Labels panes and the Fact pane (or vice versa), you 

must first remove them from the Outliner, and then add them again to the chosen pane.

➤ Select the column in the Content pane and drag it to a new position.

➤ Select the element you want to remove and choose Pivot→Remove Selected Item. 

➤ Click the item name in the Outliner pane to select it, then drag the item to a new position 
or to another Outliner pane. 

✏

✏
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Changing Label Nesting Levels
In pivot tables, labels from one dimension frequently are nested within another 
dimension. Nesting means that one set of labels appears as a subdivision of 
labels at a higher level of data. You can change the way labels nest to emphasize 
different relationships. 

For example, you can show Year and Quarter as data items in the Top Labels 
pane in Outliner. The Quarter labels (Q1, Q2, Q3, and Q4) are nested within 
each year label (1998, 1999). If you move Year after Quarter, then each year is 
displayed as a subset of each quarter. In this case, Q1 values are broken down 
by labels 1998, 1999.

To change the nested level of labels:

1 With more than one data item in an Outliner pane, select a data item in the Outliner.

2 Drag that item to the other side of the second data item in the same pane in Outliner.

The labels in those dimensions switch positions and the data is nested in a 
different manner.

Sorting Pivot Tables
Sorting facts or dimensions enables you to display objects in ascending and 
descending order according to value.

To sort plotted values and labels:

1 If the Sort line is not visible, click Sort on the Section title bar.

2 In the Sort list, select the item that you want to use as the basis of your sort.

3 In the By drop-down list, click the sort type (either a label or value).

4 In the Using drop-down list, select the method of calculation for a data value.

By default, Brio Intelligence plots data in ascending order. To sort in 
descending order, click the descending icon.
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Using Data Calculations in Pivot Tables
The Pivot section provides a number of way to perform data calculations that 
can help you analyze business trends. These calculations range from simple 
totals and subtotals that are useful in most types of pivot tables to more 
complex data functions for specialized contexts.

Adding Totals and Subtotals
You can calculate totals for both columns and rows in a pivot table. If you 
layered dimension items along the top or side of your pivot table, you can 
calculate totals for any level in the hierarchy. When you select inner 
dimensions for totaling, subtotals are created for each of the categories in the 
outer dimensions.

For example, suppose your pivot table has facts of Units and Amount Sold. 
These facts are further broken down by Region and Territory on the side, and 
by Year and Quarter on top. Calculating totals by Region produces a total row 
at the bottom of the pivot table, summing the data from all regions for each 
column. Calculating totals by Quarter produces one total column under each 
year label, summing the data for each set of four Quarter labels.

Tip An intelligent aggregate is applied to the specified data when totaling unless 
you specify otherwise. For example, the total of a column of averages will 
calculate an average rather than a sum total.

To add totals to a pivot table:

1 Click a side or top dimension.

2 Choose Pivot→Add Totals.

Brio Intelligence adds totals and breaks them according to the next higher 
dimension item.

To add subtotals to pivot tables:

1 Select an inner dimension.

2 Choose Pivot→Add Totals.

Brio Intelligence adds subtotals to each one of the categories of the next higher 
dimension.

✰
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Adding Cumulative Totals
Add cumulative totals to break totals by dimension and restart them at each 
dimensional grouping in a pivot table. Cumes work best when all dimensions 
are located at the top or side of the pivot table, and data label column heads are 
placed orthogonally.

To add a cumulative total:

1 Select a fact in the pivot table’s data grid.

2 Choose Pivot→Add Cume.

The Pivot Cume dialog box appears.

3 If desired, type a new name for the pivot cume.

4 Select the scope of the pivot cume from the drop-down list.

The Scope drop-down list includes all of the dimensions in the pivot table. The 
default scope is the lowest level dimension that appears in the pivot table.

5 Click OK.

A new fact column is added that maintains a cumulative running total of the 
original fact by the dimension (scope) specified.
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Using Data Functions
Data functions enable you to change the nature of the values displayed in a 
pivot table and allow you to decide the kind of value represented in a pivot 
table. When you use a data function, Brio Intelligence recalculates the selected 
values according to the function applied to the underlying data values (which 
are originally from the Results section).

Data functions are particularly useful if you want to display different types of 
values side by side. If you add the same fact (such as Amount Sales) to the 
Outliner several times, you can apply a different data function to the very same 
dimension. 

For example, you can show the total sale, average sale, and maximum sale of 
each product by quarter. Each of these computed items uses Amount Sales as its 
underlying value. They only differ in the data function used to calculate them.

Note When you add multiple instances of a Request item to the Facts pane in Outliner, Brio 
Intelligence appends number to the name (for example, Amount_2, Amount_3).

To apply a data function:

1 Select a fact in the pivot table’s data grid.

2 Choose Pivot→Data Function→Function.

The data values are recalculated and populate the row or column of the pivot 
table. 

Tip You can change the label of the new column or row if you wish.

Table 3-1 lists the data functions available in the Pivot section.

Tab le 3 -1 Data Function Definitions

Function Description

Sum Returns sum of all values. This is the default setting.

Average Returns average of all values.

Count Returns number of values.

✏

✰
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Note Null values are empty values for which no data exists. Null values are not equal to zero.

Maximum Returns highest value.

Minimum Returns lowest value.

% of Column Returns surface values as a percentage of their respective column item.

% of Row Returns surface values as a percentage of their respective row item.

% of Grand Returns surface values as a percentage of all like values in the pivot table.

Increase Returns the incremental difference between the final two instances of a total 
column or row. Apply only at the innermost dimensional level of a pivot table.

% Increase Returns the percent difference between the final two instances of a total 
column or total row. Apply only at the innermost dimensional level of a pivot 
table.

Non-Null Average Returns average of values; null values excluded.

Null Count Returns number of null values.

Non-Null Count Returns number of values; null values excluded.

Tab le 3 -1 Data Function Definitions

Function Description

✏
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Using Surface Values in Data Functions
Data functions, when applied to total rows or columns, can either apply 
calculations to surface values (the values displayed in the pivot table) or 
underlying values (the values from the original Results section).

When applied to surface values, data functions recalculate the values in the 
visible cells or surface of the pivot table. When applied to underlying values, 
data functions return to the unaggregated values beneath the pivot table and 
recalculate based on those values. When underlying values are used, the results 
often appear incongruous with the aggregate surface values of the chart 
element. In other words, a total of the underlying values does not match the 
total of the surface figures.

Consider a simple pivot table with two values of 20 and 30. Each of these is 
already a total of underlying values:

An average of the underlying values yields the result of:

An average of the surface values yields a result of:

To match surface-level values in your calculation, you can instead apply surface 
values to the totals derived from data functions. For example, if you use surface 
values for an average applied to a total, the total is converted to the average of 
the surface values in the corresponding element.

To use surface values:

➤ Choose Pivot→Use Surface Values.

20 8 12+=

30 10 20+=

12.5 8 12 10 20+ + +( ) 4÷=

25 20 30+( ) 2÷=
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Using Weighted Functions 
Weighted averages can be very useful for a variety of purposes, such as survey 
research or when you want to include demographic information in your pivot 
tables. For example, suppose you took a survey of 100 people, 75 male and 25 
female. But according to census data in that geographic region you should have 
surveyed 50 males and 50 females. The data you have is skewed toward males.

To correct for this, you assign a weight or weighting factor to correct for the 
sampling error in your survey. To calculate a weight you take the expected 
amount and divide it by the actual amount.

In the example, the men would have a weighting factor of:

The women would have a weight of:

Any calculation would calculate each man as 0.6666 and each woman as 2.

Weighted averages can also be used to apply different levels of importance to a 
given item. Take, for example, a survey, which has multiple questions. The 
responses can be rated on a scale of 1 to 5. By assigning a weight to each 
question based on the level of importance (the higher the number the more 
important), and using that weight in calculating a weighted average, you can 
arrive at averages that are more meaningful.

To use weighted averages, you must add a column of data to the database. This 
data indicates the relative weight of each corresponding value in another 
column. The statistical calculation for weighted averages depends on the 
following mathematical formula:

Tab le 3 -2 Weighted Values Example

Customer ID Units Sold Type of Store Weight

1435 80 Electronics 8

50 75÷ 0.6666=

50 25÷ 2=

c w×( ) sum w( )÷
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To use weighted averages:

1 Ensure that a column of data with the weighted values exists in the database.

2 In the Query section, select the Topic item for which weighted values are needed.

3 Choose Query→Data Functions→Weight.

The Reference dialog box appears.

4 Select the item that contains the weighted values and click OK.

The item in the Request line is renamed to indicate it is a weighted value.

5 Process the query.

The weighted values are returned in the Results section.

6 Go to the Pivot section and drag the Weighted item from the Catalog pane to the 
Outliner.

You may now use all of the various data functions on the weighted values.

Note Weighting functions work only in the pivot section.

1539 200 Computer 10

1634 60 Electronics 8

1213 900 Discount 2

Tab le 3 -2 Weighted Values Example

Customer ID Units Sold Type of Store Weight

✏
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Adding Computed Items
Use the Add Computed Items command to create new elements in the Pivot 
section. Computed items enable use to build equations or apply functions to 
existing data values. Computed items are like normal data items and can be 
included in pivot tables or reused to compute other data.

To add a computed item:

1 Choose Pivot→Add Computed Item.

The Computed Item dialog box appears. 

2 In the Name field, type a name that describes the computation.

The default name is Computed, which is numbered sequentially if there is 
more than one. If you assign a name to a computed item that is identical to an 
existing scalar function name, Brio Intelligence numbers the name starting 
with the number 2.

3 Define the new data item by building an expression in the Definition text box. 

Use the operator buttons to insert arithmetic and logical operators at the 
insertion point. 

■ Click Reference to display the Reference dialog box, and select Request 
items to place in the equation.

■ Click Functions to apply scalar functions using the Functions dialog box.

You can also type any portion of the equation or the entire equation directly 
into the Definition text box using JavaScript. The names are case sensitive, and 
you must replace spaces in item names with underscores (‘_’). 
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4 If necessary, click the Options button to set a new data type for the item.

5 When the equation is complete, click OK.

The computed item is added to the Outliner and appears as a column in the 
pivot table.

Pivot Menu Command Reference
Table 3-3 provides a quick reference to the commands available on the Pivot 
menu and lists any related shortcuts.

Tab le 3 -3 Pivot Menu Commands

Command Description
Keyboard
Shortcut

Shortcut
Menu

Add Selected Items Adds the selected item as a Top Label, Side Label, 
or Fact.

✔

Remove Selected Items Removes the selected item. [Del] ✔

Modify Modifies the selected computed item. [Ctrl+M] ✔

Sort Reorders the selected item by labels, by values, 
ascending, or descending.

Add Totals Adds the selected item to the Measures pane. ✔

Add Computed Item Allows you to add a new data item derived from 
calculations performed on an existing item.

✔

Add Cume Adds cumulative totals to break totals by dimension 
and restarts them at each dimensional grouping.

✔

Data Function Applies a prebuilt data function to the selected 
item.

✔

Use Surface Values Allows data functions to recalculate the values in 
the visible cells or surface of the pivot table

✔

Drill Anywhere Allows you to drill to any item. ✔

Drillup Returns the original view of data that you drilled. ✔

Focus On Items Updates the pivot table to include only the selected 
data.

✔
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Hide Items Hides the selected item. ✔

Show Hidden Items Restores the selected hidden item. ✔

Show All Items Updates the pivot table to include all items. ✔

Group Items Groups the selected dimensions. [Ctrl+G]

Ungroup Items Ungroups the selected dimension. [Ctrl+U]

Restore Name Restores the original name of a renamed item. ✔

Refresh Data Updates the data according to the selected option. 
Choose between After Process, When Section 
Displayed, Manually, or Refresh Now.

Tab le 3 -3 Pivot Menu Commands (Continued)

Command Description
Keyboard
Shortcut

Shortcut
Menu
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4 Charting Data

This chapter explains how to use Brio Intelligence’s charting features to 
perform interactive analysis of your data in a graphic format. It includes:

■ Chart Section

■ Charting Basics

■ Creating Charts

■ Determining What Chart Format to Use

■ Working with Two-dimensional Charts

■ Working with Multidimensional Charts

■ Manipulating Chart Data

■ Working with Chart Elements

■ Chart Menu Command Reference
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Chart Section
The Chart sections enables you to see meaningful summaries of your data. 
Graphic snapshots help you recognize patterns, trends, and other relationships 
that might not be apparent in columns and rows of tabular data.

The Chart section opens with an initial plot area for the chart. Because chart 
construction and manipulation is managed with the Outliner, plotting, 
viewing, and reviewing are easy and intuitive. Also, Brio Intelligence charts 
respond dynamically to your commands. When you make a change in a 
charted item, you see your chart instantly redrawn to reflect the change. 
Experimenting with different combinations of data can be surprisingly 
informative.

Legend

Catalog 
Pane

Content 
Pane

Y–Facts Pane in Outliner Z–Facts Pane in OutlinerX–Facts Pane in Outliner

Y-axis 
Label

Z-axis 
Label

X-axis 
Label

Y-axis 
Values

Z-axis 
Values

X-axis 
Values

Chart 
Title

Chart 
Subtitle

Sort Line Sort Type Sort AggregateSort Item
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Charting Basics
A chart is a graphic representation of data. Except for pie charts, all charts plot 
data with reference to a horizontal X-axis and a vertical Y-axis. 
Multidimensional charts sometimes plot data on an additional Z-axis. A pie 
chart uses the metaphor of the pie as a whole to delineate the relative values of 
the parts or slices. 

In Brio Intelligence, you construct a chart by dragging Request items from the 
Catalog pane to the Outliner. At least two items must populate the Outliner to 
plot a usable chart. Table 4-1 lists the appropriate uses for the Outliner panes.

Chart Terminology
Table 4-2 defines the chart terminology used in Brio Intelligence.

Tab le 4 -1 Outliner Pane Usage

Axis Pane Usage

X-Categories Label data (non-quantifiable data values) only. For example, product list-
ings, periodic information (for example, day, month or year).

Y-Facts Exclusively for facts or quantifiable values.

Z-Categories Facts or label data depending on the chart type.

Tab le 4 -2 Chart Terminology

Term Definition

Axes Straight lines on a chart that provide a framework for measurement and ref-
erence. Typically, the X-axis and Z-axis are used to display label items and 
the Y-axis shows values or facts (measurable items), such as units and 
amounts.

Values Graphic indicators that represent data. Brio Intelligence bar charts display 
values in either vertical or horizontal bars. Pie charts use wedge-shaped 
slices to represent values.

Plot Area The area bounded by the axes is called the plot area. In the case of the pie 
chart, the plot area is defined by a circle representing the totality of all data 
items.
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Understanding Chart Dimensions
To understand the differences among charts, you have to distinguish between 
dimensions in space and dimensions of data. The two dimensions are distinct.

Space can be represented as three dimensions along the X, Y and Z axes as 
shown in Figure 4-1.

t

Data can either be represented in two- or in three-dimensional (2-D or 3-D) 
space. In two dimensions, data is represented along the X-axis and Y-axis only. 
In three dimensions, data is projected back along the Z-axis also.

Planes In all charts (except pie charts), planes provide background and graphed ref-
erence for charted values. Planes define horizontal, vertical, and background 
fields for a chart.

Legend An information box containing color-keyed labels used to identify different 
data values represented on a chart.

Grid Lines Straight horizontal and vertical lines arranged in scaled increments that 
provide calibrated guidelines for value interpretation.

Bar A linear measure of a value used in bar charts.

Slice A spacial measure of a value used in pie charts.

F igu re  4 -1 Outliner Panes Corresponding to The X, Y, And Z Axes in the Chart Area

Tab le 4 -2 Chart Terminology (Continued)

Term Definition
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Two dimensions of data must be represented in 2-D space. At least three 
dimensions of data are necessary to use the third spatial dimension (Z-axis). 
But three or more dimensions of data can be represented in 2-D space. For 
example, cluster and stack represent data categories in two spatial dimensions 
(X-axis and Y-axis only).

Creating Charts
Interactive charts consists of two layout elements: graphical elements (for 
example, chart bars or pie slices) and axis labels. When you assign Request 
items to panes in the Outliner, they become values or labels in your chart.

The instructions below are a starting point for building charts. As you use and 
become familiar with the Chart section, you will learn ways to create the exact 
type of chart that fits your needs.

To create a chart using the Chart outliner:

1 Choose Insert→New Chart to create a new Chart section.

2 If the Outliner is not visible, click Outliner on the Section title bar to display the Outliner.

3 Drag each line item to be included in the chart from the Catalog pane to an Outliner 
pane:

■ Drag values or facts (such as Units or Amount) in to the Y-Facts pane in 
Outliner to create bar charts, pie charts or ribbon charts.

■ Drag a label item (such as Name, Product, or State) into the X-Categories 
pane in Outliner to create a 2-D chart.

■ Drag a label item to the Z-Categories pane in Outliner to add a third 
dimension to your chart.

4 Select a chart type from the Chart drop-down list.

Note You can select and drag multiple items to the same Outliner pane to add multiple values or 

labels for analysis. Items are hierarchically ordered in the sequence in which they appear in 
the Outliner panes.

✏
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Determining What Chart Format to Use
The chart you want to use usually depends on the data you want to analyze. 
Once you place Request items in the Outliner, you select how you want to 
display and analyze this data by selecting a chart format. 

Brio Intelligence supports 11 chart formats that graphically represent data, all 
of which can be viewed as 2-D or 3-D objects. Charts are also categorized by 
type, which is defined by how they plot values and labels along the X. Y. and Z 
axes. Chart types include:

■ Type A – Values or facts default to Y-Facts pane.

■ Type B – Values or facts default to Z-Categories pane.

■ Type C – Values or facts can be placed in either Y-Facts or Z-Categories 
panes.

Table 4-3 lists the chart formats available in Brio Intelligence and explains how 
to place values and labels in the Outliner panes to generate the various chart 
types.

Tab le 4 -3 Chart Formats and Types

Chart Format Chart Type X-Categories Pane Y-Facts Pane Z-Categories Pane

Vertical Bar A Labels Values Labels

Horizontal Bar A Labels Values Labels

Area A Labels Values Labels

Stacked with Numeric 
Categories

A Labels Values Labels or Values

Vertical Stacked Bar B Labels Labels Values

Horizontal Stacked Bar B Labels Labels Values

Stacked Area B Labels Labels Values

Cluster Bar C Labels Labels or Values Labels or Values
4-6 Charting Data



Working with Two-dimensional Charts
Pie and bar charts (of the non-stacked variety) lend themselves well to 
representing two dimensions of data. For example, imagine charting the 
amount of sales by product type. In pie charts, the two dimensions are 
represented by slices of a pie. In bar charts, the data is represented by bars 
along the X and Y axes. 

Using Pie Charts to Analyze Data
Of all charts, the pie chart is the easiest to understand. Pieces (slices) of the pie 
are drawn to represent the relative value of a measurable item category to the 
whole. Pie charts represent additional dimensions of data by further 
subdividing the pie.

In a pie chart, Request items placed in the X-Categories pane represent 
itemized slices of the pie. Request items placed in the Y-Facts pane define the 
quantitative whole of the pie.

Line C Labels Labels or Values Labels or Values

Bar-Line Combination C Labels Label or Two Values Label or Two Values

Pie Not Applicable

Tab le 4 -3 Chart Formats and Types (Continued)

Chart Format Chart Type X-Categories Pane Y-Facts Pane Z-Categories Pane
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To create a pie chart:

1 From the Chart drop-down list, select Pie.

2 Drag a value from the Catalog pane to the Y-Facts pane in Outliner.

An pie chart without slices appears.

3 Drag one or more label items from the Catalog pane to the X-Categories pane in Outliner.

The pie charts is differentiated to reflect subcategories. A legend depicting 
details of the selection appears.

Note Since pie charts plot data using only two axes, Brio Intelligence disables the Z-Categories pane 
in Outliner when creating a pie chart.

Positioning Pie Slices
You can pull individual pie slices out of the pie chart.

To toggle the position of a pie slice:

A check mark appears on the shortcut menu next to Pull Out Slice to indicate 
that this feature is active. Choose this option again to clear the check mark and 
restore the pie slice to its original position.

Showing Positive and Negative Values
Pie slices show positive values by default.

To toggle the display of negative and positive values:

A check mark appears next to Show Negative Values to indicate that negative 
values are shown. Choose this option again to clear the check mark and show 
positive values.

➤ Select a slice of the pie and choose Pull Out Slice on the shortcut menu.

➤ Select a slice of the pie and choose Show Negative Values on the shortcut menu.

✏
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Showing Pie Percentages
To toggle the display of each pie slice value as a percentage:

A check mark appears next to Show Pie Percentages to indicate that 
percentages are displayed on the chart (in parentheses next to the pie chart 
label). Choose this option again to clear the check mark and remove the 
percentages from view.

Adding Lines to Labels
To add a pointer line between an individual pie slice and its label:

Rotating Pie Charts
To rotate the perspective angle or elevation of a pie chart:

1 Click Rotate on the Shortcut menu.

The rotate icon appears on the pie chart.

2 Click the rotate icon and move the dotted line to a new location.

When you release the mouse button, the chart is redrawn to reflect the 
adjusted perspective. If you cannot drag the rotate icon in a certain direction, 
the chart has reached its farthest possible rotation in that direction.

Using 2-D Bar Charts to Analyze Data
Bar charts are the most common type of business chart and are especially 
useful for comparative analysis when you want to focus on comparing values 
and place less emphasis on time. Use a bar chart to illustrate comparisons 
among individual items. 

Two-dimensional bar charts are plotted using a single item in each of the 
X-Categories and Y-Facts panes in Outliner. The Z-Categories pane is not 
populated in 2-D bar charts.

➤ Select a slice of the pie and choose Show Pie Percentages on the shortcut menu.

➤ Select the pie slice to which you want to add a pointer and choose Format→Line To 
Label.
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To create a 2-D bar chart:

1 Select a bar chart format from the Chart drop-down list.

The default chart format is Vertical Bar.

2 Drag a label item from the Catalog pane to the X-Categories pane in Outliner.

Data labels appear on the horizontal axis in the Chart area.

3 Drag a value from the Catalog pane to the Y-Facts pane in Outliner.

A chart is plotted that summarizes the selected value (Y-Facts pane) as it 
relates to the subcategories of the label item (X-Categories pane).

Brio Intelligence automatically scales the data represented on the Y-axis and 
adds appropriate labels. The Legend provides an index of label information 
with a coordinated color scheme.

To use a different 2-D chart format, select another 2-D chart from the Chart 
drop-down list.
4-10 Charting Data



Working with Multidimensional Charts
Frequently, you want to represent more than two dimensions of data at a time. 
For example, you may want to see how the sales of product types break down 
by years or quarter. There are numerous ways to chart three or more 
dimensions of data. You can project data into the third dimension of space. 
You can also represent the data in two spatial dimensions.

About 3-D View
By default, Brio Intelligence imparts a 3-D look to your chart objects. These 
objects appear in the chart space as 3-D objects with depth. That does not 
mean that you are plotting three dimensions of data or using three dimensions 
of space to represent data. It is simply a visual effect that can be turned off.

Note If you turn off 3-D View, you cannot view charts that use a third dimension in space.

To toggle 3-D View:

A check mark appears next to the 3-D View option to indicate it is active. 
Choose this option again to clear the check mark and turn off 3-D view.

Note You can also select to view objects in 3-D using the Properties dialog box. For more 
information, see “Customizing Chart Properties and Labels” on page 4-30.

➤ Choose Format→3-D View. 

✏

✏
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Creating Three-dimensional Bar Charts
You can add more information your bar chart by adding an additional item or 
items to the Z-Categories pane in Outliner. Using multidimensional charts, 
you can show various relationships between three or more items in easy-to-
understand bar chart formats.

Brio Intelligence plots the added data in rows that extend back along the chart’s 
Z-axis. 

To create a multidimensional bar chart:

1 Select a bar chart format from the Chart drop-down list.

The default chart format is Vertical Bar.

2 Drag a label item from the Catalog pane to the X-Categories pane in Outliner.

3 Drag a label item from the Catalog pane to the Z-Categories pane in Outliner.

4 Drag a value from the Catalog pane to the Y-Facts pane in Outliner.

A chart is plotted that summarizes the selected value (Y-Facts pane) as it 
relates to the subcategories of the label items (X-Categories and Z-Categories 
panes).

Understanding Clustered Bar Charts
You can change your chart perspective so that the Z-axis data extended in the 
third dimension is shown as clusters displayed in the foreground. This charting 
option is useful when Z-axis bars are hard to distinguish in standard bar 
formats. 

Cluster charts can be used to juxtapose categories in one label item. For 
example, use clustered bars to compare stores of different types. Alternatively, 
cluster bars can also be used to compare two different value items, such as 
Amount of Sales and Units Sold.

Note You can only display cluster bar charts in vertical format.✏
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To cluster bars representing divisions in label items (Z-Categories pane for 
values):

1 Select Vertical Cluster Bar from the Chart drop-down list.

2 Drag a fact item from the Catalog pane to the Z-Categories pane and label items to the 
X-Categories and Y-Facts panes in Outliner.

To cluster bars representing two different value items (Y-Facts pane for values):

1 Select Vertical Cluster Bar from the Chart drop-down list.

2 Drag two fact items to the Y-Facts pane and a label item to the X-Categories pane.

Understanding Stacked Bar Charts
Another way to represent the third dimension of data is through stacking. In 
this way, a single bar on the chart can show data for more than one category of 
data. For example, a single bar can represent the amount of sales for CD-ROM 
drives in one year on top of a bar representing sales for other years. Stacked bar 
charts can stack data vertically or horizontally.

Stacked bar charts t show the relationship of parts to the whole. Stacking 
techniques differ depending on whether you are representing divisions within 
data categories or stacking two separate numeric categories.
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Stacked bar charts offer similar complexity to clustered charts by adding 
together component value items within chart bars or areas. By stacking items 
and assigning a different color to each item, you can effectively display trends 
among comparable or related items, or visually emphasize a sum of several 
indicators.

To create a Stacked bar chart, you need more than one Request item in the 
Y-Facts pane in Outliner. Each value item adds a segment to the length of the 
bar.

Understanding Area Charts
Area charts are essentially bar charts with the discontinuous breaks removed 
along the horizontal axis. Data is not broken into discrete bars but appears in a 
continuous ebb and flow as defined against the Y-axis. Consequently, area 
charts are particularly useful for emphasizing the magnitude of change over 
time. In addition, area charts can be used for the same purposes as bar charts.

Because area charts do not break data along the horizontal axis, they are most 
useful for charting three dimensions of data. The Z-Categories pane should be 
used to either project data into a third spatial dimension, or to stack two 
categories of data in a stacked area chart.

To create an area chart:

1 Select Area from the Chart drop-down list.

2 Drag a value item from the Catalog pane to the Y-Facts pane in Outliner.

3 Drag a label item from the Catalog pane to the X-Categories and Z-Categories panes in 
Outliner.

4 Select Legend On Z from the Legend drop-down list.

Setting the legend on the Z-axis properly distributes color.

To create a stacked area chart:

1 Select Stacked Area from the Chart drop-down list.

2 Drag a value from the Catalog pane to the Z-Categories pane in Outliner.
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Understanding Ribbon Charts
A ribbon chart is very similar to a line chart, but with a few visual differences. 
In a ribbon chart, items in the Y-Facts pane determine the height of the line, 
and items in the X-Categories pane itemize the line sections. You can create 
multiple lines by adding items to the Z-Categories pane.

To create a ribbon chart:

1 Select Ribbon from the Chart drop-down list.

2 Drag a value item from the Catalog pane to the Y-Facts pane in Outliner.

3 Drag a label item from the Catalog pane to the X-Categories pane and one or more label 
items to the Z-Categories pane in Outliner.
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Understanding Line Charts
Line charts show trends in data at equal intervals and are effective for 
comparing highs and lows in a continuum. In a line chart, items in the Y-Facts 
pane determine the height of the line, and items in the X-Categories pane 
itemize the line sections. You can create multiple lines by adding items to the 
Z-Categories pane.

Line charts have one advantage over bar charts. They do not allow one set of 
data to obstruct the representation of another. Since lines are thin compared to 
bars, the data displayed in the front does not block out the data behind.

As a result, data that is not easily represented in bar or area charts work well in 
line charts. Many more dimensions of data can be superimposed without 
impairing the chart’s effectiveness.

To create a standard line chart (Y-Facts for values):

1 Select Line from the Chart drop-down list.

2 Drag a value item from the Catalog pane to the Y-Facts pane in Outliner.

3 Drag label items from the Catalog pane to the X-Categories and Z-Categories panes in 
Outliner.

4 Select Legend On Z from the Legend drop-down list to distribute colors along the Z-axis.

Understanding Combination Charts
Combination charts combine some of the strengths of bar charts with the 
advantages of line charts. Solid bars can be used for the most important data 
against which other dimensions are represented in lines. In this way, emphasis 
is given to a portion of data based on its importance. A combination chart is 
especially useful for comparing two numeric values, such as amount and units 
of sales.
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To create a combination chart that compares values:

1 Select Bar-Line from the Chart drop-down list.

2 Drag two values from the Catalog pane to the Y-Facts pane in Outliner.

3 Drag label items from the Catalog pane to the X-Categories and Z-Categories panes in 
Outliner.

To create a combination chart that compares categories within a label:

1 Select Bar-Line from the Chart drop-down list.

2 Drag a value item from the Catalog pane to the Z-Categories pane in Outliner.

3 Drag one or more value items from the Catalog pane to the Y-Facts pane in Outliner.

4 Drag a label to the X-Categories pane in Outliner.

Note A combination chart is most effective when the Y-Facts pane contains only two value items. It 
represents one value as bars and the other value as a line. When more than two values are 
present, the chart alternates between bars and lines in depicting the values (1st, 3rd, 5th … 

items are bars; 2nd, 4th, 6th … items are lines).

✏



Manipulating Chart Data
Brio Intelligence offers a number of ways to manipulate the data in your chart 
for better analysis. Review the following sections for information on:

■ Using Different Scales to Compare Related Values

■ Using Data Functions in Charts

■ Adding Computed Items

■ Sorting Chart Items

■ Creating Pivot Tables from Charts

■ Drilling into Charts

■ Hiding and Focusing on Charted Data

Using Different Scales to Compare Related Values
To chart comparison values or to combine two related indicators on the same 
chart, you may need to compensate for different numeric scales. For line, 
clustered bar, and combination charts, you can use a second Y-axis to represent 
values on a scale that differs from the scale of the first Y-axis. 

For example, you might like to chart the sales of your two fastest growing 
product lines together to get an idea of how business is growing. However, 
while the growth rates are similar, the two product lines may sell at entirely 
different volumes. If this is the case, the chart will not provide much 
comparative information because each line needs to be charted at a different 
scale.

By using different scales for the two Y axes, you can correctly scale each value 
for the most effective presentation of the data. 

To use a different scale for a value on the second Y-axis:

Brio Intelligence automatically changes the scale of the Y-axis for the value you 
selected, and the italicizes the value name in Outliner. Double-click the item 
again to return the scale to its default setting.

For information on manually setting scales for left and right Y-axis values, see 
“Setting Chart Value Axis Properties” on page 4-33.

➤ Double-click the one of the two values in the Y-Facts pane in Outliner.
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Using Data Functions in Charts
In a chart, you may want to display average sales instead of total sales. You can 
use data functions to recalculate these values. Table XX lists the data functions 
available in the Chart section.

Note Null values are empty values for which no data exists. Null values are not equal to zero.

To apply a data function:

1 Select a label in the Chart area.

2 Choose Chart→Data Function→Function. 

Tab le 4 -4 Chart Section Data Functions

Data Function Description

Sum Returns sum of all values. This is the default setting.

Average Returns average of all values.

Count Returns number of values.

Maximum Returns highest value.

Minimum Returns lowest value.

% of Grand Returns values as a percentage of all like values in the chart.

Non-Null Average Returns average of values; null values excluded.

Null Count Returns number of null values.

Non-Null Count Returns number of values; null values excluded.

✏
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Adding Computed Items
You can create new chart elements by building equations to compute data 
items, or by applying functions to existing data items. Computed items are like 
normal data items, and can be included in charts or re-used to compute other 
data.

For example, you can modify the Amount Sold item by building an equation 
around it, multiplying it by the Unit Price item and renaming the resulting 
item Revenue. You can also apply a scalar function such as Cume to Amount 
Sold and return each individual value as a cumulative running total, or simply 
multiply Amount Sold by the local tax rate to find the tax owed on each sale.

To create a computed item:

1 Choose Add Computed Item from a Section menu (for example, Query, Results, and so 
on).

The Computed Item dialog box appears. 

2 In the Name field, type a name that describes the computation.

The default name is Computed, which is numbered sequentially if there is 
more than one. If you assign a name to a computed item that is identical to an 
existing scalar function name, Brio Intelligence numbers the name starting 
with the number 2.
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3 Define the new data item by building an expression in the Definition text box. 

Use the operator buttons to insert arithmetic and logical operators at the 
insertion point. 

■ Click Reference to display the Reference dialog box, and select Request 
items to place in the equation.

■ Click Functions to apply scalar functions using the Functions dialog box.

You also may type any portion of the equation or the entire equation directly 
into the Definition text box using JavaScript. The names are case sensitive, and 
you must replace spaces in item names with underscores (‘_’). 

4 If necessary, click the Options button to set a new data type for the item.

5 When the equation is complete, click OK.

The computed item is listed in the Outliner and is added to your chart. 

Sorting Chart Items
Data in charts is sorted alphabetically by default. You can use the sort buttons 
on the Standard toolbar to perform simple sorts on selected items and reverse 
the sort order. In charts, however, you generally want to override the default 
alphabetical setting and sort dimensional data with reference to other data.

For example, if a chart lists each type of widget your company sells and the 
total amount sold of each, initially the widget types are ordered alphabetically. 
But this data becomes more meaningful when you instead sort the widget 
types with reference to the total produced by each. This approach allows you to 
rank each widget from the highest to lowest total sales.

You can use the Sort line in the Chart section to impose a sort condition for 
each dimensional data item in your chart. The Sort line includes three drop-
down menus used to define the sort conditions. The contents of the menus 
vary depending on the data items in your chart.

To specify a sort using the Sort line:

1 If the Sort line is not already displayed, click Sort on the Section title bar.

2 Select an item to sort from the Sort drop-down list.
Manipulating Chart Data 4-21



3 Select a value from the By drop-down list as a sort reference, or select Label to sort the 
item alphabetically.

4 If desired, select an aggregate function from the Using drop-down list when sorting by 
values.

The Using drop-down menu is not available when you sort by labels.

5 If desired, click the ascending or descending Sort button on the Sort line.

The Sort line stores a sort condition for each dimensional item included in the 
chart.

Sort Items
The Sort drop-down menu lists the data items that can be sorted. Each 
dimensional item included in the chart (name and date) is listed in this menu. 
Dimensional items can include Pivot top and side labels.

Reference Items
The By drop-down menu lists items used as a basis for a complex sort 
condition (for example, sorting Cities by the revenue generated in each). 

■ Label – By default, Brio sorts dimensional data items alphabetically by 
name when you create your chart: this is equivalent to sorting by label. 
When selected, labels indicates that the item chosen from the Sort list is 
sorted by label or name, rather than by reference to corresponding numeric 
data values in the chart

■ Value – Sorting by a numeric data item orders each value of the target item 
chosen from the Sort list by its corresponding numeric value in the Value 
list.

Sorting by values produces an entirely different sort order. For example, your 
chart may list each state in which your company has made sales revenue and 
the total cost-of-sales for each. The states are initially listed in alphabetical 
order. When you sort by cost-of-goods, the states are ranked in order by each 
corresponding cost-of-sales figure.
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Functions
The Using drop-down menu contains aggregate statistical functions that are 
available when you sort by values. The sort aggregate functions are usually the 
same as the data functions available in a section. (See Table 4-4 for a list of the 
data functions available in the Chart section.)

When you sort by values, Brio Intelligence initially sorts labels by the 
corresponding numeric values of the referenced item (for example, sorting 
states by the sum total of the cost of goods sold in each state).

Creating Pivot Tables from Charts
Once you have a final version of your chart, use the automatic pivot table-
generator to create a pivot table based on the layout of your chart. 

To create a pivot table based on your chart:

The Brio Intelligence workspace switches to a new Pivot section that displays 
the pivot table created using the data from the chart. 

➤ In the Chart section, choose Insert→Pivot This Chart.

A pivot table created using the Pivot This Chart feature.
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Drilling into Charts
The Drill Anywhere feature allows you to drill into items in the Chart section 
that are resident in the Results section without having to return to reprocess 
your query or locate the item in the Catalog pane. Drill anywhere items are 
automatically added as new label items. 

The advantage of this feature is that it instantly allows you to add items to the 
data set to reflect temporary or hypothetical situations. You can always 
suspend or delete the item to return to the original chart display.

The extent to which you can drill into your data depends on how the original 
query was built, since Drill Anywhere retrieves data from the Results section. 
This feature does not allow you to interactively query the database.

To drill anywhere into a chart:

1 Select one or more items for analysis and choose Chart→Drill Anywhere→Item.

Brio Intelligence redraws the chart drilled to the selected item. In the Outliner, 
an item selected for drill-down is identified with a drill-bit icon.

2 Choose Chart→Drillup to return to the original view of your chart.

Tip If no options are available in the Drill Anywhere menu, all Request items have 
been used in the Chart section’s Outliner.

Note Drill Anywhere is enabled on the General page of Data Model Options. To display the General 
tab, choose DataModel→Data Model Options.

✰

✏
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Hiding and Focusing on Charted Data
A straightforward way to refresh your view of a chart is to single out items for 
closer focus or remove some of the charted elements. This allows you to 
concentrate on particular items of interest.

Focus On Items
To focus on a chart item:

1 Select one or more objects on which you want to concentrate.

Brio Intelligence displays the item(s) with a dotted outline.

2 Choose Chart→Focus On Items.

The chart is redrawn to display only the chart object(s) selected. A drillbit icon 
appears in the Outliner next to the item(s) on which you focused.

To return to the original chart display:

Hide Items
To hide charted data:

1 In the chart, select the objects you want to hide.

Brio Intelligence displays the item(s) with a dotted outline.

2 Choose Chart→Hide Items.

Brio Intelligence redraws the chart with the selected objects removed. A drillbit 
icon appears in the Outliner next to the item(s) you hid.

To restore hidden chart items:

➤ Choose Chart→Show All Items.

➤ Choose Chart→Show Hidden Items.
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Working with Chart Elements
In the Chart section, you can easily reorganize or reposition data to 
reconfigure your charts and highlight different relationships between the same 
items. You can drag items to a different order within an Outliner pane, drag 
label items between Outliner panes designated for labels, or delete items from 
the Outliner. Brio Intelligence automatically redraws your chart to reflect your 
changes. 

You can also work directly with elements in the Chart area. Most elements are 
selected by clicking the element in the chart or the element’s label in the 
legend. For axis labels, a change to one axis label changes all labels along that 
axis. 

Selecting Chart Elements
To select chart elements as graphic objects in the Chart area:

1 Place the cursor over the edge of an item in the Chart area.

The cursor changes to a move cursor .

2 Click to select the object.

A gray outline appears around the item. You can move the selected chart item 
anywhere in the Chart area or resize it using the handles. Also, check the 
shortcut menu for additional options. 

Changing the View of a Chart
You may want to enlarge your chart to better work with chart details, or change 
the perspective or angle from which a chart is viewed.

Zooming Charts
You can resize charts to fit the Content pane or the printed page.

To resize a chart:

1 Choose View→Zoom→Size.

100% is the default size, which prints to fit on 8½-by-11-inch paper 
(216 mm × 279 mm). Best fit changes the size of the chart to fit within the 
Content pane. 
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Rotating and Elevating Charts
By default, charts are displayed in 3-D foreshortened perspective from above 
and to the right. You can alter the perspective from which a chart is viewed by 
rotating it.

Tip Before you can rotate the chart, the background plane must be visible and the 
chart must be in Best Fit view. 

To rotate the angle of vision or change the elevation of a bar, line, or area chart:

1 Choose View→Zoom→Best Fit. 

2 Choose Chart→Properties.

The Chart Properties dialog box appears. 

3 Click the General tab to view the General properties page.

4 In the Planes area, select the Show Back Plane check box and click OK.

5 Place your cursor at the top right corner of the chart.

The cursor changes to indicate that you can rotate the chart.

6 Hold down the left mouse button and drag the chart to rotate it.

When you release the mouse button, the chart is redrawn to reflect the 
adjusted perspective. If you cannot rotate in a certain direction, the chart has 
reached its farthest possible rotation in that direction.

Displaying Axis Grid Lines
Axis grid lines are straight lines on a chart that provide a framework for 
measurement and reference. Typically, the X and Z axes are used for label items 
and the Y-axis shows values or facts (measurable items), such as units and 
amounts.

In Brio Intelligence, you can view or hide these axis gridlines depending on the 
chart you are designing.

✰
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To toggle the display of axis grid lines:

1 Click anywhere within the main plot area of the chart.

2 Choose Show X Axis Grid Lines (or Show Y Axis Grid Lines) on the shortcut menu.

A check mark appears next to the selected option to indicate that the grid lines 
are visible. Choose this option again to clear the check mark and remove the 
gridlines from the Chart area display.

Inserting Text 
You can insert text anywhere around or within the chart to further explain or 
emphasize a chart component.

To insert text:

1 Select Insert Text on the shortcut menu.

The Set Inserted Text dialog box appears.

2 Type the text you want to display in the text box and click OK.

The text appears in the location where you initially invoked the Insert Text 
command.
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Changing Chart Legends
 Brio Intelligence allows you to choose the axis along which you want to 
distinguishes your data by setting the chart legend on that axis. This is a great 
way to view values on the selected axis without rearranging the values in the 
Outliner. A chart legend can be set on either the X-, Y-, or Z-axis. You can also 
reposition or resize a legend to take advantage of either the horizontal or 
vertical space within the chart area.

Note Brio Intelligence preserves chart legend color settings when the chart type, chart legend axis, 
and number of chart axis label values are changed.

✏

Legend on X-Axis

Legend on Y-Axis

Legend on Z-Axis



To set the axis used for a chart legend:

1 Choose Format→Set Legend On.

The Set Legend On dialog box appears.

2 Select the axis on which you want to set the legend and click OK.

Brio Intelligence redistributes colors to highlight the data associated with the 
selected item and color coordinates corresponding labels in the Legend.

To resize a chart legend:

1 Click a border on the legend.

Sizing handles appear on each corner of the selected legend.

2 Drag a sizing handle until the legend is the desired size that you want.

Customizing Chart Properties and Labels
Use the Properties command on the Chart menu to customize general chart, 
labels axis, and values axis properties, as well as general bar chart attributes. 

Setting General Chart Properties
General chart properties control the display of various objects, such as titles, 
legends, and borders, in the Chart area. They are also used to specify default 
plane and rotation settings.

To adjust general chart properties:

1 Choose Chart→Properties.

The Properties dialog box appears.

2 Click the General tab to display the General properties page.
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3 Change any of the following properties:

■ Show Title – Toggles the display of the chart title as entered in the text field. 

■ Show Subtitle – Toggles the display of a subtitle as entered in the text field.

■ Show Legend – Toggles the display of color-coded chart legends in the 
Chart area.

■ 3-D Objects – Toggles the 3-D display of chart objects, including pie slices, 
chart bars, side planes, and perspective view. 

■ Show Border – Toggles the display of the Chart area border in the Content 
pane.

■ Auto Resize – Toggles the automatic resizing of a chart within the Content 
pane whenever the Brio Intelligence workspace is resized. 

■ Planes – Toggles the display of horizontal, vertical, and back planes of a 
chart.

■ Horizontal\ Vertical rotation degrees – Shift the perspective angle or 
elevation (–60 to 60 degrees) for all types except the pie chart, which has its 
own rotation (see below)

■ Rotation – For pie charts, rotates the pie the specified number of degrees 
(between -90 and 90), and changes the pie height the specified number of 
degrees (0 to 90). For all other charts except line charts, shifts the horizontal 
and/or vertical angel or elevation a specified number of degrees (between 
-60 and 60). 

4 Click OK to apply your changes.
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Setting Chart Label Axis Properties
Chart label axis properties control the display of the X-axis and Z-axis labels, 
tickmarks, and values for items in the X-Categories and Z-Categories panes in 
Outliner.

To adjust chart label axis properties:

1 Choose Chart→Properties.

The Properties dialog box appears.

2 Click the Labels Axis tab to display the Labels Axis properties page.

3 Modify the properties shown as desired and click OK to apply your changes. 

Choose whether to display X-axis and Z-axis labels, tickmarks, and values, and 
whether the intervals at which X-axis labels and tickmarks appear is 
automatically determined by Brio Intelligence or manually set to the specified 
value.
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Setting Chart Value Axis Properties
Chart value axis properties control the display of axis labels, tickmarks, values, 
and position for items in the Y-Facts pane in Outliner.

To adjust chart value axis properties:

1 Choose Chart→Properties, or right-click the chart and select Properties.

The Properties dialog box appears.

2 Click the Values Axis tab to display the Values Axis properties page.

3 Modify the properties shown as desired and click OK to apply your changes. 

Choose whether to display labels, tickmarks at intervals, and values at intervals 
for primary and secondary value axes. 

You may also choose whether to set the left axis and right axis scales using a 
logarithmic scale, which plots line charts with logarithmic (base 10) values; 
and whether the values displayed on the scale are automatically set by Brio 
Intelligence, or set by manually specifying minimum and maximum values. 
For the left axis scale, you may specify the interval at which to separate axis 
values or have Brio Intelligence automatically assign the interval.

Note If you choose to plot a line chart with a logarithmic (base 10) value axis, any chart values less 
than one (1) are represented as zero (0) on the logarithmic scale and an information message 

appears on the Windows status bar.

✏



Setting Bar Chart Properties
Bar chart properties control the general attributes for the various bar chart 
formats available in Brio Intelligence. 

To adjust bar chart properties:

1 Choose Chart→Properties.

The Properties dialog box appears.

2 Click the Bar Chart tab to display the Bar Chart properties page.

3 Modify the properties shown as desired and click OK to apply your changes. 

■ All Bar Charts – Toggles the display of values on each bar in the chart.

■ Clustered Bar Charts – Choose to cluster bars by items on the Y-axis or 
X-axis. For example, if you have Quarter on the Y-axis, each cluster consists 
of four bars, one for each quarter.

■ Bar-Line Charts – Toggles the display of values on bars and for lines, and 
the inclusion of null values (which disrupt the line, area, or ribbon). Zero’ 
(0) values are included.

You may also choose whether to place line chart plot points to the left of or 
centered on bars, and whether to stack or cluster bars on the Y-axis.
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Customizing Chart Patterns, Colors, and Labels
In addition to the generic label axis properties that apply to all charts, you can 
change properties of individual charts, such as patterns, colors, and data labels. 
You can also 

Changing Chart Color Schemes and Fill Patterns
Brio Intelligence allows you to redistribute chart colors to emphasize specific 
charted items listed in the Outliner and change chart focus. Colors are 
differentiated along a specific axis.

To change the pattern or color scheme of a chart: 

1 Double-click a chart element in the legend, or select an element in the chart (such as a 
bar or a pie slice) and choose Chart→Properties.

A Properties dialog box appears that may contain one or more tabs (Patterns, 
Axis, Data Labels), depending on the format of the active chart.

2 Click the Patterns tab to display the Patterns page.

3 Select the fill pattern and color for the chart segment, line, or marker.

■ Automatic – Automatically sets the fill pattern and color to the default 
setting. The default setting for fill pattern is Solid. The default setting for 
color varies between chart formats.

■ None – Sets a transparent fill pattern and color for the selected element.

■ Custom – Allows you to select a foreground color and fill pattern for the 
chart. Choices include Solid, Hollow, Horizontal, Vertical, Cross, 
Diagonally Up, Diagonally Down, Diagonally Cross.

For line charts, you can also select the width, style and color of lines, and 
the size, style, border colors, and fill colors of markers.

4 Click OK.
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Changing Chart Data Labels
You can change the type of data used in the labels in your chart. The choices 
available depend on the chart format.

To change a chart’s data labels:

1 Double-click a chart element in the legend, or select an element in the chart (such as a 
bar or a pie slice) and choose Chart→Properties.

2 Click the Data Labels tab to display the Data Labels page.

3 Select the fill pattern and color for the chart segment, line, or marker.

■ Pie Charts – Select whether to show pie slice labels, values, percentages, 
negative values, and lines that connect a data label to its pie slice.

■ Bar Charts – Select whether to show individual bar values and the 
placement of the values inside the bar.

■ Line Charts – Select whether to show values and ignore null values, and 
select the placement of the values relative to the line.

For line charts, you can also use the Axis page to specify whether to plot values 
on the primary (left) axis or secondary (right) axis.
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Changing Color of Chart Elements, Lines, and Text
Use the Format toolbar to change the line, fill, and text color of a chart element 
or text and add emphasis to your chart. 

Note If the Format toolbar is not visible, choose View→Toolbars→Formatting.

To change line color:

1 Select a plot point in the line whose color you want to change.

2 On the Format toolbar, open the Line Color list and select a color from the palette.

To change the fill color of a chart element:

1 Select the chart element whose fill color you want to change.

2 On the Format toolbar, open the Fill Color list and select a color from the palette.

To change the color of text:

1 Select the label or other text element whose text color you want to change.

2 On the Format toolbar, open the Text Color list and select a color from the palette.

✏
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Chart Menu Command Reference
Table 4-5 provides a quick reference to the commands available on the Chart 
menu and lists any related shortcuts.

Tab le 4 -5 Chart Menu Commands

Command Description
Keyboard
Shortcut

Shortcut
Menu

Sort Sorts the selected column values in ascending order 
(alphabetical or numeric).

✔

Data Function Applies a prebuilt data function to the selected item.

Add Computed Item Enables you to add a new data item derived from 
calculations performed on an existing item.

✔

Modify Computed 
Item

Enables you to modify a computed item. ✔

Remove Selected 
Items

Removes the selected items. [Del] ✔

Drill Anywhere Allows you to drill to any item. ✔

Drillup Returns the original view of the data you drilled. ✔

Focus On Items Updates the chart to include only the selected items. ✔

Hide Item Hides the selected item from view. ✔

Show Hidden Items Restores the selected hidden item. ✔

Show All Items Updates the chart to include all items removed by 
focusing.

✔

Group Items Groups the selected items. [Ctrl+G] ✔

Ungroup Items Ungroups the selected grouped item. [Ctrl+U] ✔

Restore Name Restores the original name of a renamed item. ✔

Refresh Data Updates the data according to the selected option. 
Choose between After Process, When Section Dis-
played, Manually, or Refresh Now.

Properties Opens the Properties dialog box for the chart or 
selected chart element.

✔
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5 Designing Custom Reports

This chapter explains how to use the Report Designer, Brio Intelligence’s 
dynamic analytical report writer, to create free-form, presentation-quality 
reports. It includes:

■ Report Section

■ Creating a Custom Report

■ Working with a Report Page

■ Setting Up a Report

■ Enhancing Report Data

■ Using Multiple Data Sources in a Report

■ Creating Smart Reports

■ Formatting Report Items

■ Converting Detail Reports from Brio Intelligence Versions Earlier than 6.0

■ Report Menu Command Reference
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Report Section
The Report Designer in the Report section helps you to easily develop a 
complete range of reports, from small ad-hoc reports to mission-critical 
operational reports. After you create your database query, you can use this 
section’s visual layout capabilities to drag and drop columns, expressions, 
charts, pivot tables, logos, bitmaps and other objects to quickly design and 
customize your reports.

Groups Outliner

Expression Button

Expression 
Line

Catalog 
Pane

Query 
Sections

Content 
Pane

Sort Line

Graphic 
Items

Report 
Fields

Dimension 
and Fact 
Columns

Dimensions Pane in Table Outliner Facts Pane in Table Outliner

Section 
Pane

Embedded 
Chart

Report 
Group 
Headers
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Report Section 5-3

Report Section Elements
The Report section differs slightly from other Brio Intelligence sections in 
order to provide you with as robust a report designer as possible. Key 
differences include:

■ Expression Line – Accessed via the Expression button on the Section title 
bar, the Expression line enables you to build common computed 
expressions using JavaScript. 

■ Catalog Pane – Contains all of the of drag-and-drop elements you use to 
create a custom report, including:

❑ Query – Contains all the sections associated with a selected query, 
including Results, Pivot, and Chart sections. You can drag individual 
Results columns from the Results and Table sections to a report page, as 
well as entire Pivot and Chart sections to create Smart Reports.

❑ Graphics – Contains standard vector graphics text labels, and pictures 
(bitmaps only). 

❑ Fields – Contains predefined fields that can be dragged to various areas 
of the report to enhance the look and feel of the report. 

To use any of these elements, simply drag them to the desired report 
component band.

■ Outliner – Consists of the Groups Outliner and Table Outliner. The Table 
Outliner is divided into the Dimension and Fact panes.

❑ Groups Outliner – Defines the overall or highest levels used to group 
data in a report. When you designate an item to serve as a group header 
(also known as a break value), you are instructing Brio Intelligence to 
organize the rest of the data in repeating collections of records according 
to the group header.

❑ Dimensions Pane in Table Outliner – Includes the descriptive 
information as a column in a table that is included in the body of the 
report. 

❑ Facts Pane in Table Outliner – Includes the measurable or quantifiable 
data as a column in a table included in the body of the report. Brio 
Intelligence automatically calculates and inserts subtotals for each fact 
column.

Brio Intelligence quantifies values by group header and dimension. If 
you have a descriptive numeric value that should not be calculated, such 
as Retail Price or Target Sales, use it as a group header or table 
dimension instead of a fact.



Report Section Toolbar
The Report Section toolbar provides icons that enable you to quickly 
maneuver multiple report objects.

■ Align – Aligns several objects at the same time. Objects are aligned to the 
first object you select. Select the first object, then hold down the Control 
key and select the remaining objects. Click the arrow on the Align icon and 
choose an alignment option: left, center, right, top, middle, or bottom. 

■ Make Same Size – Resizes the selected objects to the same size. Objects are 
resized to match the first object you select. Select the first object, then hold 
down the Control key and select the remaining objects. Click the arrow on 
the Make Same Size icon and choose a resizing option: width, height, or 
both.

■ Layer – Stacks a single object in relative position to other objects. Layer 
include four rearrangement options: Send To Front, Send To Back, Bring 
Forward, and Send Backward. Use this feature to layer multiple objects so 
that only the sections of the objects you want visible are shown. 

■ Spring Objects – Maintains relative vertical spacing between dynamic 
objects. That is, you can spring one object to another so that if the first 
object is moved, increased or diminished, the second object moves in the 
same flow. 

Select an object, then hold down the Control key and select the remaining 
objects. Click the Spring Objects icon to spring the objects.

To remove spring from objects, select the objects click the Spring Objects 
icon again. 

■ Zoom – Sets the magnification level of the report. Options include whole 
page, page width, or a percentage of magnification based on 100%. 

Align
Make Same Size
Layer
Spring Objects
Zoom
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Expression Line
Use the Expression line to apply and display aggregate functions and 
computing fields. For each item in a report, you can display its JavaScript 
syntax and modify it to fit your own needs. 

The Expression line includes the following components:

■ Data Function – Shows available data functions that can be applied to table 
columns.

■  × – Cancels and removes a formula. This icon appears only when you enter 
syntax.

■ √ – Accepts and applies the formula. This icon appears only when you enter 
syntax.

Table 5-1 lists the default syntax for Report section items. 

Tab le 5 -1 Report Expression Syntax

Report Element Syntax

Table Dimension CurrBreak.Value["Column Name"] 

“Column Name” refers to the dimensional column name. The column name 
can be modified.

Table Fact Tables["Section"].Columns
["Column Name"].Sum[currBreak]

“Section Name” refers to either the Results or Table section. Column Name 
refers to the fact column name. Sum refers to the return of underlying values 
and can also be an applied Data functions such as Avg, Max, and Min. 

Group Label CurrBreak.Value["Column Name"]

“Column Name” refers to the dimension or fact column name. 
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You can concatenate the syntax listed in Table 5-1 with other JavaScript 
expressions to customize the content of labels, facts, and dimensions.

For example, if you wanted a group header to show a union of the Total label 
and the amount, you could insert a field in the Expression line to concatenate 
Total with the table fact syntax.

Or, you could insert a field to show the sum (or any other data function) of the 
column divided by the sum of the parent level expressed as a percentage.

If you plan to use this feature, add the labels in a computed field. For 
information on how to add a computed field, see “Adding Computed Items” 
on page 5-21.

Group Fact Tables["Section"].Columns
["Column Name"].Sum[currBreak]

“Section Name” refers to either the Results or Table section. “Column Name” 
refers to the fact column name.

To apply a break at the parent level (the highest level), use the following 
syntax:

Tables["Section Name"] .Columns
["Column"].Sum[currBreak. Parent]

Tab le 5 -1 Report Expression Syntax (Continued)

Report Element Syntax
5-6 Designing Custom Reports



Report Components
The Report Designer offers a variety of dynamic tools for constructing the 
report you want to create with all of the components you want it to contain. 
Understanding how these components perform and how they integrate with 
Report section elements is fundamental to building a successful report.

Report pages are structured areas, or bands, of information. Each band 
contains a different report component and can be customized to include other 
report elements such as graphic objects, predefined fields, computed fields, 
charts, and pivot tables. A report’s components are:

■ Body – Contains one or more tables whose contents are based on the items 
listed in the Table Dimensions and Table Facts panes of Outliner. Every 
report has a body that holds a table of data. Tables can be based on the same 
or different results sets within the document.

■ Report Group Headers – Categorize data into repeating collections of 
records organized according to the header band. 

Page Header

Report Header

Report Group Headers

Body

Page Footer
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■ Report Header/Footer – Fully customizable summary bands of 
information. Report headers print only on the very first page of the report. 
Report footers print only on the very last page. 

■ Page Header/Footer – Contain data this is repeated on every page, such as 
page numbers. These bands are also fully customizable.

Creating a Custom Report
The Report section uses tables as the basic building blocks of custom reports. 
Tables contain columns of dimensions and facts as determined by the Results 
items you place in the Dimensions and Facts panes in Table Outliner. 

To create a basic report:

1 Choose Insert→New Report. 

Brio Intelligence creates a new Report section and inserts a blank table in the 
Body band of the report in the Content pane.

Tip Choose Report→Section Boundaries to view the bands for the report 
components.

2 If the Table Outliner is not visible, click Table on the Section title bar to open the Table 
Outliner. 

The Table Outliner has two panes: Dimensions and Facts. 

3 Drag Results items from the Query sections of the Catalog pane to the Table Outliner 
panes.

Use the Dimensions pane to build dimension (label) columns, such as Month, 
Region, or Product Line. Use the Facts pane to build the facts (numeric values) 
in the report, such as Amount Sales or Units Sold. Results and Table items 
added to the Facts pane are automatically totaled.

Table 5-2 lists the column formatting options available in Brio Intelligence.

✰
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Tab le 5 -2 Table Column Formatting Options

Options Description

Changing the 
Column Name 
Heading (Title)

To modify the column title, click Expression on the Section title bar, then 
select the column title that you want to modify. In the Expression line, type 
the new title between the quotation marks (“ ”) and click the check mark.

Hide/Show 
Column Name 
Heading (Title)

To toggle the display of column titles, choose Column Titles on the short-
cut menu. A check mark appears next to Column Titles to indicate that 
column titles are visible. Choose this option again to clear the check mark 
and hide column titles from view.

Remove Column To remove a selected column from the report (and Table Outliner), choose 
Remove Column on the shortcut menu. This option is available for dimen-
sion and fact columns. Items should be removed with caution as com-
puted items may draw data values from the deleted item. 

Hide/Show 
Column Total

To toggle the display of column totals, choose Show Column Totals on the 
shortcut menu. A check mark appears next to Column Totals to indicate 
that column totals are visible. Choose this option again to clear the check 
mark and hide column totals from view.

This option is available only for fact columns.

Select Column Click anywhere inside the column.

Suppress Dupli-
cates

To suppress the duplicate values for a column, select the column and 
choose Format→Suppress Duplicates. Use this feature if you want to 
display only the first instance in the column of a duplicate value when indi-
vidual database records include redundant information. This feature is 
especially useful if records are associated with the same date, location or 
customer.

Text Wrap To wrap text within a column, select the column and choose Format→Text 
Wrap.

Reordering 
Columns

If you want the columns in the table to appear in a different order, drag the 
item in order of how you want it to appear in the Table Outliner. You can 
also select the column in the actual report and drag it to a new position in 
the report.
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Inserting Additional Tables in a Custom Report
A custom report may contain multiple tables, each originating from the same 
or different result sets in the document. Multiple tables in one band are a 
powerful way to compare values.

To add multiple tables to one report:

1 Choose Report→Insert Table.

The cursor changes to a crosshair .

2 In the Body band, left-click and hold your left mouse button to position your cursor where 
you want to insert the table, and then drag to create the table. 

A numbered table is inserted.

3 Drag the Results items from the Query sections of the Catalog pane to the Table2 
Outliner panes.

Each new table that you insert has its own corresponding dimensions and facts 
pane in the Table Outliner.

Adding Report Groups
A report group is the topmost level at which you can structure data in a report. 
When you drag an item from the Catalog pane into the Groups Outliner, Brio 
Intelligence automatically supplies a report group header band and adds a label 
inside the band that identifies the group.

For example, if you create a report to show purchases by state, each state would 
serve as a report group header in the report. You can place multiple items in 
one header or add a multiple levels of group headers.

This step is not necessary to create a report, but it may help you to better 
organize the content of the report. You can show additional headings, graphics, 
and totals in the report group header band.

To create a report group:

1 If the Groups Outliner is not visible, click Groups on the Section title bar to open the 
Groups Outliner.

2 Drag the item on which you want to group data from the Catalog pane to the Report 
Group1 field in the Groups Outliner.

The selected item automatically populates the group header. 
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Inserting Report Headers and Footers
 Report headers and footers are summarizing bands of information. Report 
headers print only on the first page of a report. Report footers print only on 
the last page of a report.

Tip Do not confuse report headers and footers with report group headers. Report 
group headers categorize data into repeating collections of records in a header 
band, based on the Results columns in the Groups Outliner.

To view and create a report header or footer:

1 Choose Report→Section Boundaries to view the bands for the report components.

2 Choose Report→Headers And Footers→Option.

You can view the report header, the report footer, or both. The Report Header 
band appears on the first page of the report. The Report Footer band appears 
on the last page of the report.

3 Drag objects from the Catalog pane to the Report Header or Report Footer band.

The selected item automatically populates the report header or footer. 

Inserting Page Headers and Footers
Page headers and footers allow you to specify data that is repeated on every 
page, such as a page number.

To insert a page header or page footer:

1 Choose Report→Section Boundaries to view the bands for the report components.

2 Choose Report→Headers And Footers→Option.

You can view a page header, a page footer, or both. 

3 Drag objects from the Catalog pane to the Page Header or Page Footer band.

The selected item automatically populates the report header or footer.

✰
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Adding Other Report Elements
You can resize report band items and use the tools available on the Format 
toolbar to change properties such as number, font, alignment, border, and 
background.

You can also add graphic items and fields from the Catalog pane to enhance 
your report. For example, use the Text Label tool to add text labels that identify 
values for numeric report group headers.

Working with Graphic Elements
Brio Intelligence provides a complete set of graphic elements to assist you in 
designing presentation-quality reports (see Table 5-3). Lines, rectangles and 
ovals are considered vector graphics. Vector graphics consist of commands for 
creating the measures and shape of each line, rectangle, arc, and so on. The 
resolution of the output device defines the look of the vector graphic, since a 
vector graphic has no fixed resolution. This property enables you to resize the 
vector graphic without changing its resolution. Since a vector graphic contains 
only the instructions for creating an image, it requires less disk space.

Pictures are considered bitmapped graphics. A bitmap graphic consists of 
pixels, which have the appearance of small points. In computer memory, a 
pixel is shown as one or more bits, containing instructions for color, density 
and appearance for each pixel shown. As a result, bitmaps use more disk space 
and have a fixed resolution. If you resize a bitmap image, it may distort the 
original image.

Tab le 5 -3 Report Section Graphic Elements

Element Description

Line Creates a line that you can rotate.

Hz Line Creates a horizontal line.

Vt Line Creates a vertical line.

Rectangle Creates a rectangle.

Round Rectangle Creates a rectangle with rounded corners.

Oval Creates an oval.
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Working with Fields 
Brio Intelligence provides a computable field and predefined fields to assist you 
constructing and producing reports (see Table 5-4). These fields can be 
dragged and dropped anywhere within the report page, body, report group 
header, report header/footer, and page header and footer. You can also 
customize how numbers, dates, time, and text fonts appear in your report. For 
numbers, you can choose whether to use commas, decimals place, dollar signs 
or percentage symbols. For text items, you can choose fonts styles and sizes. 
For Query and Result limits, you can select specific limits.

Text Label Creates a text label that you can use as a caption.

Picture Allows you to insert bitmaps (.bmp extension).

Name Sets the object’s name.

Visible Allows the object to be visible during Run mode. Use this to hide objects.

Locked Locks an object. Use this to lock objects so they cannot be changed.

Tab le 5 -4 Report Section Fields

Field Name Description

Field Inserts a computed field.

Query Limit Inserts a selected query limit.

Result Limit Inserts a selected result limit.

Query SQL Inserts the last SQL sent to the database when you process a query.

Page Number Inserts a page number.

Number of Pages Inserts the total number of pages.

Page X of Y Inserts the current page of the total number of pages.

Last Saved Inserts date on which the report was last saved in MM/DD/YYYY format.

Last Printed Inserts date on which the report was last printed in MM/DD/YYYY format.

Date Inserts and stamps the current date in MM/DD/YYYY format.

Tab le 5 -3 Report Section Graphic Elements (Continued)

Element Description
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About Computed Fields
A computed field contain a single value based on a calculation. You can create 
customized JavaScript expressions or modify JavaScript syntax for an existing 
report element. A computed field is repeated based on the report component 
in which it is inserted.

To create a computed field:

1 Choose Report→Insert Field.

The cursor changes to a crosshair .

2 Left-click and hold your left mouse button to position your cursor in the report 
component where you want to insert the field, and then drag to create the table. 

A field labelled Empty Field is inserted. 

3 Click the empty field to select it, and then enter JavaScript syntax in the Expression line.

You can copy and paste JavaScript syntax from existing report items into the 
Expression line to build the expression. To do this, select an existing item and 
copy the syntax in the Expression line. Then select the new field and paste the 
syntax into the Expression line.

4 When you have defined the equation, click .

The field displays the computed value.

Time Inserts and stamps current time in HH:MM:SS format.

Date & Time Inserts and stamps date and time in MM/DDYYYY and HH:MM:SS format.

Date Now Inserts the current date in MM/DD/YYYY format.

Time Now Inserts the current time in HH:MM:SS format.

Date & Time Now Inserts the current date and time in MM/DDYYYY and HH:MM:SS format. 

File Name Inserts the Brio Intelligence document (.bqy) name.

Path Name Inserts the full path name of the document.

Report Name Inserts the report name.

Tab le 5 -4 Report Section Fields (Continued)

Field Name Description
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Inserting Limit Values
You can select and show limits applied in the Query and Results sections to aid 
in the visual construction and production of the report. 

To use a limit value in a report:

1 Choose Report→Insert Predefined Field→Query Limit or Result Limit. 

The cursor changes to a crosshair .

2 Left-click and hold your left mouse button to position your cursor in the report 
component where you want to insert the limit field, and then drag to create the field. 

The Insert Limit Values dialog box appears.

3 In the Query or Result Sections list, select the section that contains the limits that you 
want to show.

A list of applied limits populates the Limit Names list.

4 Select the Limit Name that you want to use from the Limit Names list.

To show the operator used in the expression, select the Include Limit Operator 
check box.

5 Click OK.

To modify the Limit field name or the values being shown:

The JavaScript expression for the Limit Value field appears in the Expression 
line.

➤ Double-click the Limit field and modify the statement on the Expression line.
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Inserting Page Breaks
You can insert a page break before or after a report group header.

To toggle page breaks:

1 Choose Report→Section Boundaries to view the bands for the report components.

2 Select a report group header.

3 Choose Insert→Page Break Before or Page Break After.

A check mark appears next to the selected page break option to indicate that it 
is active. Choose this option again to clear the check mark and remove the page 
break.

Concatenation operator (+) concatenates 
two string values together

Section Name 
as string

Limit field name 
represented as a 
Literal String

Number Format 
String

Limit operator (if 
included) represented 
as a Literal String

Local (Results) or 
server (Query) 
limit values

Column name Comma delimiter 
(shows how multiple 
limits are separated)
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Working with a Report Page
Brio Intelligence gives you complete control of your report page setup and 
provides a number of features that assist you in designing effective, high-
quality reports. 

Displaying Rulers
Horizontal and vertical rulers help you line up items based on precise units of 
measure. Available units of measurement include inches, centimeters, and 
pixels, which you select by clicking the measure indicator  at the intersection 
of the top and left rulers. 

To toggle the display of the ruler:

A check mark appears next to Ruler to indicate the ruler is visible. Choose this 
option again to clear the check mark and remove the ruler from view.

Using Grids
Brio Intelligence provides a layout grid that automatically snaps all objects to 
the closest grid spot. 

To toggle the display of the grid:

A check mark appears next to Grid to indicate the grid is visible. Choose this 
option again to clear the check mark and remove the grid from view.

Using Design Guides
Design guides are horizontal and vertical lines that you place in your report to 
help you line up objects. Design guides are similar to grids in that objects 
automatically snap to align to the design guides. 

If rulers are visible, click the ruler and drag one or more design guides from 
both the horizontal and vertical rulers. 

➤ Choose Report→Ruler.

➤ Choose Report→Grid. 
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To toggle the display of design guides:

A check mark appears next to Design Guides to indicate they are visible. 
Choose the option again to clear the check mark and remove the design guides.

Setting Up a Report
Use the Report Page Setup command to specify report page parameters 
including, page size, margins, and columns.

Specifying Page Size
When deciding on page size for your report, consider the type of output you 
want. Do you want to print the report or view it onscreen? Brio Intelligence 
allows you to select printer dimensions or to specify custom dimensions for 
your report pages. 

To specify page size:

1 Choose Report→Report Setup.

The Report Setup dialog box appears.

2 Click the Page Size tab to view the Page Size page.

3 Choose the page dimension option you want to use.

■ Use Printer Dimensions – Determines the printable area based on your 
printer. If you want to only print the report, select the option. 

■ Use Custom Dimensions– Allows you to specify the width and height of 
your report page. 

If you export reports to HTML pages, you can use this setting to control the 
number of “pages” that are included in each HTML file. Each page is 
exported to a single HTML file by default. To ensure that all pages in your 
report are contained in a single HTML file, set the page height to a large 
number. 

4 Click OK.

➤ Choose Report→Design Guides. 
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Specifying Page Margins
Use the Margin tab to specify the blank space that borders the report area on 
your page. Since the report area can hold a variety of objects, such as page 
numbers, text, and lines, change the margin area to accommodate the size of 
your report area. Margins are set for an entire report.

To specify page margins: 

1 Choose Report→Report Setup.

The Report Setup dialog box appears.

2 Click the Margin tab to view the Margin page.

3 Enter the Top, Bottom, Left and Right margin sizes.

Margins are measured in units of inches, pixels or centimeters. To change the 
margin units, click the Measurement icon  located above the Content pane 
until you find the measurement unit you want to use.

4 Click OK.

Setting Up Page Columns
You can set up a multicolumned report and have data flow from the bottom of 
one column to the top of the next column. You can specify as many columns as 
you want.

To create a multicolumned report:

1 Choose Report→Report Setup.

The Report Setup dialog box appears.

2 Click the Column tab to view the Column page.

3 Select the number of columns that you want to include on the page.

If you want to include more than four columns on the page, enter the number 
of columns in the Other field.

Brio Intelligence automatically determines the column width and spacing 
based on the number of columns specified, the page size, and the page 
margins. Column width and spacing measurements are set in either inches, 
pixels, or centimeters. 
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Enhancing Report Data
You can apply limits, sorts, computations, and break totals to refine the data in 
your reports. 

Sorting Report Items
You can use the Sort icons to quickly sort a report group header or table 
column.

To sort items quickly:

1 Drag the table column that you want to sort.

2 Click the Ascending or Descending icons on the standard toolbar.

To apply sort conditions using the Sort line for report group labels

1 If the Sort line is not already displayed, click Sort on the Section title bar.

The Sort line appears below the Section title bar.

2 Click a report group label in the Content pane.

The Sort line should read Report Groupx, where x = 1, 2, 3, and so on.

3 Drag a report group label from the content area to the Sort line.

4 Double-click the name of the report group label on the Sort line to toggle between 
ascending and descending sort order.

To sort table columns:

1 If the Sort line is not displayed, click Sort on the Section title bar.

The Sort line appears below the Section title bar.

2 Click anywhere within the table column (dimension or fact) in the Content pane.

3 Drag table dimensions or table facts from the Content pane to the Sort line.

4 Reorder the Sort items to determine the nested sort order.

5 Double-click the item in the Sort line to toggle between ascending and descending sort 
orders.
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Adding Computed Items
Use the Add Computed Items command to build equations to compute totals, 
or to apply functions to existing values. Since a report may derive its values 
from a wide range of data sources (relational database queries, OLAP queries, 
imported data sets, and local-join queries), you select the Request item that 
you want to use from the applicable Results section.

To add a computed item:

1 Select a table column and choose Report→Add Computed Item.

The Computed Item dialog box appears.

2 In the Column Name field, type a name that describes the computation.

The default name is Computed.

3 In the Item pane, select the Request column from which to compute the new data item. 

Note that the columns available for reference are only the columns that exist in 
the results set that is the source for the rest of the table.

4 Modify the existing syntax of the table column you selected or define a new computed 
item by building an expression in the Formula pane. 
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Brio Intelligence uses JavaScript to compute data items. The JavaScript engine 
supported in Brio Intelligence does not accept European or non-US number 
formats for computing data items. More information about JavaScript can be 
found in BrioQuery Object Model and Executive Information Systems.

5 Click OK to apply the definition to the computed item column.

A new computed column is added to the Facts pane in Table Outliner for the 
selected table.

Applying Data Functions
Data functions enable you to determine the nature of the values represented in 
a Table Fact column in the Report section. Data functions retrieve underlying 
values and recalculate the value according to the type of data function that you 
specify. For example, the totals for a column are sums (the default data 
function) of the values in a column. You can use other data functions to change 
the totals to averages instead of sum. 

Brio Intelligence provides a variety of prebuilt data functions that can be 
accessed from the Expression line. You can also define your own data functions 
using JavaScript.

To apply a prebuilt data function in the Report section:

1 Select a table fact. 

2 Choose Report→Data Function→Function.

The totals in the column are recomputed to reflect the selected data function. 
Table 5-5 lists the prebuilt data functions available in the Report section.

Tab le 5 -5 Report Section Data Functions

Data Function Description

Column Name Returns the table column name.

Sum Returns sum of underlying values. This is the default data function.

Average Returns average of underlying values.

Count Returns number of underlying values.

Maximum Returns highest of underlying values.
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Applying Break Totals
To apply a break total to a column in a report table:

1 Select a column and choose Report→Break Total.

The Insert Break Total dialog box appears.

2 Select a break column from the At Every Break in drop-down list.

3 Select the data function you want to apply from the Break Total Function drop-down list.

See “Applying Data Functions” on page 5-22 for a list of data functions that 
you can use with break totals.

4 Select one or more columns on which to display the break total and click OK.

Minimum Returns lowest of underlying values.

% of Category Returns group total percentage of the value.

Null Count Returns number of nulls among underlying values.

Non-Null Count Returns number of underlying values; null values are excluded.

Non-Null Average Returns average of underlying values; null values are excluded.

Tab le 5 -5 Report Section Data Functions (Continued)

Data Function Description
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Hiding and Focusing on Reported Data
A straightforward way to refresh your view of a report is to single out items for 
closer focus or remove some of the reported elements. This allows you to 
concentrate on particular items of interest. Hiding a group item removes the 
item from the report, but not from the Outliner. Focusing a group item 
removes all items except the focused item from the report, but not the 
Outliner.

Focus On Items
To focus on a report item:

1 Select a group header and choose Report→Focus On Item.

Brio Intelligence updates the report to focus on the data. A drill icon  
appears in the Outliner next to the column you selected.

2 Choose Chart→Focus On Items.

The chart is redrawn to display only the chart object(s) selected. A drill icon  
appears in the Outliner next to the item(s) on which you focused.

To return to the original chart display:

Hide Items
To hide a group item:

You can only select one group item to hide at a time.

Brio Intelligence updates the report to hide the data. A drill icon  appears in 
the Outliner next to the column that you selected to hide.

To restore all hidden groups:

All items listed in the Outliner are fully restored to view. The drill icon 
disappears.

➤ Choose Chart→Show All Items.

➤ elect a group header and choose Report→Hide Item. 

➤ Choose Report→Show Hidden Item.
5-24 Designing Custom Reports



Using Multiple Data Sources in a Report
You can create reports that contain data from multiple queries that use a wide 
range of data sources (relational database queries, OLAP server queries, 
imported data sets, and local join queries).

In a sense, the data in a single table correlates data across queries in a report, 
retrieving all rows from the table on the “left” and any rows from the table on 
the “right” that have matching values. Unlike actual joined topics in the Query 
section, the tables are not linked in the same sense. In the Report section, data 
is only in the report.

The rules for using multiple data sources in a single report are:

■ Report group headers require a common value that belongs to all results or 
table sets be included in the report. If you introduce a unique value 
belonging to one results or table set, nothing is returned for any band below 
that group header. 

■ Table Dimensions items can originate from only one data source.

■ Values from multiple data sources can be included in Table Facts.

■ The Results column that you place as a table determines the Facts used. For 
example, you have two Results sets:

If you place “Region” from Results 1 into the Table Dimension and then 
dropped Results 1: Sales and Results 2: Units into the Table Facts, you get 
the following table:

Results 1 Region Sales Results 2 Region Units

East 10 East 100

West 20 West 200

South 400

Region Sales Units

East 10 100

West 20 200
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Note that the data from Results 2: South is not included.

■ Smart charts and pivot tables added to a multiple data source report are 
subject to the same restrictions as described above.

To build a multiple data source report:

1 Build the queries that you want to include in the report:

■ Verify item data types and associated data values in source documents so 
that you know how to correlate them when creating the reports.

■ Build the Request line, and add server and local limits, data functions, and 
computations to the query as needed.

2 Click Process.

3 Choose Insert→New Report.

A new report section appears.

4 In the Catalog pane, expand the  button of the Results or Table set that you want 
to include in your report.

5 If necessary, click Groups on the Section title bar to open the Group Outliner.

A group header categorizes data into repeating collections of records in a 
header band.

6 If necessary, click Table on the Section title bar to open the Table Outliner.

The Table Outliner shows two panes: Table Dimensions and Table Facts. Use 
the Table Dimensions pane to build the column dimensions (labels) in the 
report. Use the Table Facts pane to build the numeric values in the report.

7 To build the group header band, drag the item(s) from the Results sections of the 
Catalog pane to the Groups Outliner.

8 To build the column dimensions of the report, drag the item(s) from the Query sections 
of the Catalog pane to the Table Dimensions in Outliner pane.

9 To build the column numeric values of the report, drag the item(s) from the Query 
sections of the Catalog pane to the Table Facts in Outliner pane.
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Creating Smart Reports
Smart reports allow you to embed charts and pivot tables into a report body. 
These reports show only the data that is relevant to the report section in which 
they are placed. For example, if the report is grouped by year and you insert a 
chart in the report body, the chart replicates automatically so that there is a 
chart for each year of data in the report. Each year’s chart contains data specific 
to that year.

Tip Smart reports are refreshed whenever you reprocess the query. Also, if you 
change a chart or pivot table in its home section, the Smart report is updated 
and the changes are reflected in the Report section.

To embed a chart or pivot in a report:

1 In the Catalog pane, drag an existing pivot table or chart to either the report group 
header, page header, footer, or report body.

2 Size the pivot table or chart by clicking the embedded report until handles appears. The 
pointer changes to a two-sided arrow.

Formatting Report Items
Table 5-6 lists formatting techniques you can use in the Report section.

Tab le 5 -6 Report Section Formatting Techniques

Format Description

Number To modify the way numbers, dates and currency appear, select the item and 
choose Format→Number. When the Number tab appears, apply any desired 
changes.

Style To modify the appearance of a report item, select the item and choose For-
mat→Style→Option. Options include bold, underline, italic, and so on

Alignment / 
Justify

To modify the way an item is justified within a row or column, select an item, 
choose Format→Justify→Option. Options include left, center, right, top, 
middle, and bottom.

✰
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For information about formatting commands, see Getting Started with Brio 
Intelligence.

Font To modify the font of a report item, select the item and choose Format→Font. 
When the Font tab of the appears, apply any desired changes.

Keep Together Instructs Brio Intelligence not to split a band when a break is encountered. 
When a break is encountered, the entire band is moved to the next page.

Keep With Next Instructs Brio Intelligence to keep bands within a group together when paginat-
ing a report. If the lower band cannot fit on the page when the report is pagi-
nated, both bands are moved to the following page.

Tab le 5 -6 Report Section Formatting Techniques (Continued)

Format Description
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Converting Detail Reports from Brio Intelligence Versions Earlier 
than 6.0

You can use the Report Designer to modify Detail reports created in 
documents prior to Brio Intelligence version 6.0.

Brio Intelligence version 6.0 and later opens Detail reports in read-only mode. 
To work with the contents of a Detail report, you must first convert it to the 
new Report Designer format.

Note You can convert Detail reports to Report Designer format only if the results set is saved with the 
document. If your results set is not saved with your document, reprocess the query and then 

choose File→Save Results With Document.

To convert a Detail report to Report Designer format:

1 In the Section catalog, select the Detail report you want to convert. 

The detail report is displayed in the Content pane and a Detail menu appears 
on the menu bar.

2 Choose Detail→Convert To Report.

Brio Intelligence converts the Detail report to the new Report Designer format 
and inserts a new Report section into the document. The original Detail report 
is left unchanged.

While every effort has been made to make the converted report as close as 
possible to the original Detail report design, you may need to clean up some 
reports, especially those that use computed items, multiple page 
headers/footers, or complex formatting.

Detail reports can be exported from Brio Intelligence 6.x to all of the 
previously supported formats, including Excel (.xls), Lotus 1-2-3 (.wks), 
tab-delimited text (.txt). comma-separated text (.csv), and HTML (.htm). 

✏

Converting Detail Reports from Brio Intelligence Versions Earlier than 6.0 5-29



Display Differences
The page margins of a report created by the conversion process may appear 
smaller than in the original Detail report. This is because the new Report 
section is a WYSIWYG display that includes the unprintable area that exists 
outside of report margins. In Brio Intelligence version 5.x, Detail reports did 
not display or store information about the unprintable area. You can manually 
adjust the margin sizes in the converted report if needed.

If a Detail report contains multiple page header and footer sections, Brio 
Intelligence resolves these to a single page header and footer section during the 
conversion process. The height of the headers and footers in the converted 
report is equal to the combined heights of all headers and footers in the 
original Detail report. This may cause graphic and text objects in the headers 
and footers to overlap. You should manually adjust the properties, size, and/or 
position of these objects as necessary.

Conversion of Detail Report Categories
Categories from Detail reports are converted into report groups in the new 
Report section. The converted report displays Report Group Header and 
Footer sections if the corresponding category header and footer bands are 
visible in the original Detail report. The height of these header and footer 
sections remains the same. Detail report category labels are converted into 
JavaScript-based computed fields. Display properties remain unchanged.

Conversion of Data Area
In order to preserve as much of the original data and layout as possible, the 
conversion process translates the Detail report body information to a single 
table object in the body section of the converted report. This may lead to a loss 
of fidelity when converting complex or non-tabular style Detail reports.
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Conversion of Facts
During report conversion, Detail report facts are added to the right of the 
dimension columns in the body section table. Number formats applied to 
Detail report facts are migrated to the converted report. If no number format 
exists, then the default number formats are applied to date, time, and number 
fields.

Because Brio Intelligence version 6.x uses JavaScript as the scripting, the 
conversion process does not automatically convert any computed facts 
contained in the Detail report. For computed items located in the Detail report 
body, the expression is omitted from the version 6.x table object. The 
conversion process may attempt to replace the computed column with another 
fact. If that occurs, simply delete the extraneous column.

For computed items located in a group header or footer, the code of the old 
Brio scripting language expression is placed in a text field in the associated 
header/footer area to aid in manual conversion. Before you correct these 
placeholder items, Brio displays an error message in the field which reads 
<string>(1):unterminated string literal. The Detail report’s 
Surface Math option has no equivalent in the converted report and is ignored.

Conversion of Smart Reports
Brio Intelligence 6.x is able to convert Detail reports containing multiple smart 
charts and pivot tables. Some converted smart charts may look different or 
even invisible once converted and displayed in the Brio Intelligence 6.0 Report 
section. This is due to some changes in the chart section that affect the way that 
charts are plotted within a given sized area. As a result, embedded charts may 
need to be resized manually by the user.

Conversion of Graphic Objects
Certain graphic object properties are no longer supported and are ignored 
during the conversion process. These properties include the shadow, sunken 
button, and raised button fill effects.

The width of line objects in Detail reports is expressed in whole pixels. When a 
report is converted, the pixel line widths are converted to the nearest point 
equivalent.
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Report Menu Command Reference
Table 5-7 provides a quick reference to the commands available on the Report 
menu and lists any related shortcuts.

Tab le 5 -7 Report Menu Commands

Command Description
Keyboard
Shortcut

Shortcut
Menu

Design Guides Toggles the display of design guides.

Grid Toggles the display of grid lines.

Rulers Toggles the display of rulers.

Section Boundaries Toggles the display of section boundaries (bands).

Page Margins Toggles the display of page margins

Sort Sorts the selected column values in ascending order 
(alphabetical or numeric).

✔

Data Function Applies a prebuilt data function to the selected item. ✔

Add Computed Item Opens the Insert Computed Item dialog box. ✔

Break Total Opens the Insert Break Total dialog box. ✔

Focus On Items Updates the report to include only the selected data. ✔

Hide Item Hides the selected item from view. ✔

Show Hidden Items Restores the selected hidden item. ✔

Show All Items Updates the report to include all items removed by 
focusing.

✔

Insert Table Inserts a blank table in the report. ✔

Insert Field Inserts a blank field in the report.

Insert Predefined Field Inserts a predefined field in the report.

Insert Graphic Inserts a vector graphic in the report.

Picture Inserts a picture in the report.
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Remove Selected 
Items

Removes the selected item from the report. [Del] ✔

Headers and Footers Toggles the display of report and page headers and 
footers.

Report Setup Opens the Report Page Setup dialog box for adjust-
ing page size, margins, and columns.

Tab le 5 -7 Report Menu Commands (Continued)

Command Description
Keyboard
Shortcut

Shortcut
Menu
Report Menu Command Reference 5-33



5-34 Designing Custom Reports



Glossary
Adaptive Report Level The level of privilege that a 
user can interact with a Brio Intelligencedocument. 
The adaptive report levels are View; View and 
Process; Analyze; Analyze and Process; Query and 
Analyze; and Data Model, Query, and Analyze. When 
a document is registered to the OnDemand Server, 
groups of users are granted access to it with specific 
Adaptive Report level privileges. 

ADR (also called as sync) See Automatic 
Distributed Refresh. 

Aggregate Limit Limits placed on aggregated 
request line items or aggregated meta topic items. 

API Application Programmer Interface

API Socket (DaAPISock) The API (such as ODBC, 
SQL Net, and so on) or protocol level information 
used when connecting to a database that has been 
abstracted in an API Socket. Brio has one API socket 
for each supported API/communication protocols.

Application Server A framework for developing 
applications that provides fundamental capabilities 
required by many applications such as session and 
resource management, and security.

Auditing The monitoring of Brio Intelligence 
Repository objects to determine usage patterns.

Automatic Distributed Refresh The process of 
synchronizing locally saved documents and the 
version in the repository.

Auto-Join An administrator can configure a 
connection file to cause joins to occur automatically 
for users using the Auto-Join feature. Auto-Join can 
be configured one of three ways: Best Guess, Custom, 
and Server-Defined.

Auto-Process The automatic processing of a query.

Axes Straight lines on a chart used for measurement 
and categorization. Typically the X-axis and the Z-
axis are both used for categories while the Y-axis is 
used for quantification (for example, Facts/Values). 
Pie charts only use the X-axis for its categories and 
the Y-axis for its Facts/Values.

BCS See Broadcast Server.

Brio Repository, Brio Intelligence Repository A 
specific group of tables created using Brio 
Intelligence on a database server and used to store 
Brio Intelligence document objects, including data 
models and standard queries. Administrators can use 
Brio Intelligence Designer to upload these objects to 
the repository for end-users to download, providing 
a template for query and report building. 
Documents built from repository objects can be 
version-controlled or audited through a link to the 
repository.

Brio Intelligence Designer A client/server-based 
tool that delivers query, analysis, and reporting 
capabilities and centralized solution administration 
for developers, database administrators, and system 
administrators. 



Brio Intelligence Explorer A client/server-based 
tool that delivers query, analysis, and reporting 
capabilities for power users who need to directly 
access data sources—or to explore the information 
organized in prebuilt data models stored in the 
repository. 

Brio Intelligence Navigator A client/server-based 
tool that provides simplified query, analysis, and 
reporting for analysts who need more structured 
access to the data stored in the repository, but need 
full analysis and reporting functionality. 

Broadcast Server A Brio application, residing on a 
server, that enables users to schedule queries to 
process on a regular basis or during convenient off-
hours, and then distribute the results across a 
network or to an intranet. 

Business Intelligence Organizations utilize 
information from various operational systems, data 
marts and/or data warehouses in order to improve 
business processes, enhance customer service, 
accelerate sales and increase profitability.

Catalog A collection of database tables and local 
results. This is the information the user can use in 
his/her data model or query.

Catalog Pane Shows a list of elements available to 
the active section. For example, if Query is the active 
section, the Catalog pane displays a list of database 
tables. If Pivot is the active section, the Catalog pane 
displays a list of results columns. If EIS is the active 
section, the Catalog pane displays a list of 
embeddable sections, graphic tools, and control 
tools.

Categories Groupings by which the data is 
organized (for example, month).

CGI See Common Gateway Interface.

Chart A graphical representation of data. Users 
create charts to convert raw data into eloquent, 
visual information. 

Chart Section With a varied selection of chart 
types, and a complete arsenal of OLAP tools like 
group and drill-down, the Chart section is built to 
support simultaneous graphic reporting and ad-hoc 
analysis.

Client/Server A network architecture in which each 
computer or process on the network is either a client 
(requests information) or a server (delivers requested 
information). 

Clustered Bar Charts Occurs when the categories 
are viewed side by side within a given category, useful 
for side by side category analysis. Clustering is only 
done with vertical bar charts.

Common Facilities One of the four categories of 
objects defined by the Object Management 
Architecture (OMA). The Common Facilities is a 
collection of services that many applications may 
share, but the services are not as fundamental as 
Object Services. For example, Print Facility and 
Mobile Agent Facility.

Common Gateway Interface A native executable 
launched by the Web server. The role of our CGI is to 
pass requests from Web clients to ODS and results 
from ODS back to Web clients.

Computed Item A virtual column (as opposed to a 
column that is physically stored in the database or 
cube) that can be calculated by the database during a 
query, or by Brio Intelligence in the Results section. 
They are calculations of new data based on 
functions, data items and operators provided in the 
dialog box. They can be included in reports or reused 
to calculate other data.

Connection File See Open Catalog Extension Files.

Controls Folder Contains prebuilt items that can be 
added to your EIS section, such as list boxes, radio 
buttons, and command buttons. You can then attach 
scripts to the controls embedded in the EIS section to 
execute actions. 
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Correlated SubQueries Subqueries that are 
evaluated once for every row in the parent query. A 
correlated sub query is created by joining a topic 
item in the subquery with one of the topic items in 
the parent query. 

Cross Join Creates a query where none of the tables 
is joined. Every row in one table is joined to every 
row in another table.

Cube The data in OLAP databases (MS Plato, 
Essbase, MetaCube) is stored in 3-dimensional cubes, 
which is different from standard relational databases 
(2-dimensional). Cubes are made up of dimensions 
and measures. A cube may have dozens of 
dimensions.

DaConnect (aka DaConn) Brio Intelligence’s main 
connectivity class. Contains all the connectivity 
specific information. Instance of a connection class is 
made whenever Brio Intelligence needs to connect to 
any database.

Daemon-mode BQ The Brio client/server 
executable. It is spawned in daemon mode by node 
JREs. The role of the daemon-mode BQ is simply to 
execute database queries and return results.

DaSession When a client needs to perform an 
operation such as select, insert, update on a database, 
a session is created. The life time of a session 
synchronizes with the operation’s duration. Sessions 
are created when a client needs to perform 
operations on the database and are destroyed when 
the operation is considered complete.

Data Function Compute aggregate values, 
including averages, maximums, counts and other 
statistics, which summarize groupings of data. You 
can use data functions to aggregate and compute 
data from the server before it reaches the Results 
section, or compute different statistics for aggregated 
totals and items in the other analysis sections.

Data Model A representation of a subset of actual 
database tables that acts as a menu for the query-
builder. Data models are the sources for building the 
Request, Limit, and Sort lines in a query section. You 
create a data model by dragging database tables from 
the Catalog pane Table Catalog into the Content 
pane. The data model displays database tables 
graphically as topics when they are in the Content 
pane. 

Data models can be distributed through the Brio 
repository and used by end users to create their own 
queries. 

Database Function A predefined formula in a 
database.

Database Server A computer that stores database 
management system software (DBMS, for example, 
Oracle, Sybase, Essbase), and a database shared by a 
network of computer clients. Most databases are 
used in a client/server environment. 

By storing data on a single, powerful machine on a 
network, the data is centralized and accessible to 
many users. The server ensures that the data is 
maintained correctly and serves as a traffic cop to 
regulate client machine access to the data. The 
server’s computing power is also useful in computing 
and filtering data from the database before it reaches 
your workstation. For small or localized databases, 
your own computer can act as both database server 
and client. 

Datatype The type of data stored in a specific 
column in a database. For example, data can be 
stored as a numeric datatype.

Date Group A feature in the Results and Table 
sections that separates a date into Year, Quarter and 
Month columns. The display format for the new 
Month column is automatically set to mmm so that 
the month names sort chronologically (as opposed 
to alphabetically) in the report sections. Quarters are 
based on the calendar year, beginning January 1.
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Design Mode A toggled environment used to build 
and modify EIS sections. In Design mode, you build 
EIS sections with an array of prebuilt control items 
and graphic items. 

Designers can switch out of design mode to test EIS 
features and deploy them to end users. Design mode 
is only available in EIS sections. Brio Intelligence 
Navigator users cannot switch to EIS Design mode. 

Detail View Displays a topic as a database table. 
When Detail view is selected by the user, the database 
returns ten sample rows from the associated table. 
Each topic item is displayed as a database field. Detail 
view enables users to browse a sample of the raw 
data, which is useful when unfamiliar with the data 
model or the underlying data. Users cannot view a 
meta topic in Detail view.

Dimension In an OLAP database cube, categories of 
information are called dimensions. Examples of 
dimensions may be Location, Products, Stores, and 
Time.

In Brio, related, nonquantifiable items in a topic are 
also referred to as dimensions, such as Contact or 
Store Name.

Dimension (Legend Dimension) The current axis 
categorization or grouping method. This can be set 
to the X, Y, or Z-axis for most chart types. For line 
and area charts it can only be set to the Y or Z-axis. 
For pie charts it is always set to the X-axis. When you 
change the Legend Dimension the color is 
distributed along the new axis you change to.

Dimension Tab In the Pivot section, the tab that 
enables you to pivot data between rows and columns. 

Dimension Table Consists of numerous attributes 
about a specific business process. Each row in a 
dimension table is unique.

Drill Anywhere This feature enables a user to drill 
into and add items to pivot reports residing in the 
Results section, without having to return to the 
Query section or trying to locate the item in the 
Catalog pane. Drill Anywhere items are broken out 
as new pivot label items.

Drill to Detail This feature enables a user to 
retrieve items from a data model that are not in the 
Results section, without having to rerun the original 
query. This feature provides the ability to 
interactively query the database and filter the data 
that is returned. Drill to Detail sets a limit on the 
query based on the user’s selection and adds the 
returned value as a new pivot label item 
automatically.

Drilldown Allows you to progressively narrow your 
focus on a selected chart category. Very useful when 
you have too many categories on a particular axis. 

EIS See Executive Information System.

EIS Home This button returns you to the EIS section 
that has been designated as the EIS Home section. If 
you have only one EIS section, then EIS Home will 
return to that section. If you have several EIS 
sections, the default EIS Home will be the top EIS 
section in the Catalog pane. In Design mode you can 
specify another EIS section to be the EIS Home 
section.

Embedded Section A Brio Intelligence section that 
is embedded in a Smart report or other Brio 
Intelligence section. All embedded sections maintain 
live data content and formatting from the original 
section. Reprocessing the query, or modifying the 
original section will automatically update the display 
of that embedded section.

Executive Information System Allows users to 
build and deploy analytic applications. Analytical 
applications focus on delivering significant 
prepackaged business content that is encapsulated 
within an application. With Brio Intelligence, 
customers and independent software vendors can 
leverage their knowledge of industry specific best 
practices and assemble their own analytical 
applications for deployment to end users using the 
Web. Combining embeddable Report sections with 
enhanced EIS controls into a visual workspace and 
hooking up interactivity between these controls and 
the native Brio Technology application, an 
application designer can quickly create a variety of 
robust applications.
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Expression Line Displays displays the JavaScript 
syntax for each item displayed in a report. Use this 
line to build equations in the Report section. For ease 
of use, it can be undocked and resized.

Extranet An intranet that is partially accessible to 
authorized outsiders. Extranets are secured by user 
names and passwords. 

Fact Table Created to store business activity 
measures. Most fact tables are extremely large. Each 
row in a fact table contains numeric measures (fully 
additive measures, nonadditive measures and/or 
semiadditive measures) and foreign keys to each 
dimension table.

Facts The numeric values that are broken up in the 
body of the Pivot section. To add facts to the Pivot, 
put Results columns from the Catalog pane into the 
Outliner’s Facts pane. Facts are the numeric values in 
a relational database that are available to analyze. In 
an OLAP Query, they are called measures.

Facts/Values The data that is being visually 
represented, usually a numeric amount (for example, 
$15,000)

File Server A computer and storage device 
dedicated to storing files.

Filters In the OLAPQuery section, filters enable you 
to define and apply limits to the query once Top or 
Side Labels have been added to the query. You set a 
filter by applying comparison operators on the 
values for a specific member. Additional server-
specific functions are available based on the selected 
OLAP database cube. Filters are built to include or 
exclude data according to specific criteria. Filters can 
be set on any level in a dimension. However, they 
must be one of the labels in the Outliner. Filters can 
be made of members of one of the dimensions or 
selected by a measure. OLE DB for OLAP has other 
filter operator types (Top N, Top Sum, Top N %, 
Bottom N, Bottom N %, Bottom Sum.) Essbase and 
MetaCube have their own operator types. In Essbase 
and MetaCube, filters can be done on measures. In 
OLE DB for OLAP, filters cannot be placed on 
measures.

Foreign Key A database column or set of columns 
included in the definition of a referential integrity 
constraint.

Fully Additive Measure Attributes in a table that 
can have their values added together across any 
dimension. 

Grain The level of detail at which measures in a 
table are recorded is referred to as the grain. 

Grouping Columns This feature, in the Results and 
Table sections, creates a new column in a dataset by 
grouping data from an already existing column. 
Grouping columns consolidate nonnumeric data 
values into more general group values and map the 
group values to a new column in the dataset. 

Hardwire Mode In hardwire mode whenever the 
OLAP Query is changed, the database is queried to 
fetch new cube data. In contrast, process mode is 
manually controlled. You add or remove several 
items to the Outliner, and then press Process to 
query the database. When determining whether to 
use hardwire mode or process mode, consider the 
size of the cube in which you are working.

Hierarchy In an OLAP database cube, a hierarchy 
organizes a dimension’s levels and corresponding 
members into parent and child relationships. For the 
levels in a Location dimension, the hierarchy would 
have Country as the parent of the child City and City 
as the parent of the child Address.

Home Abstract base interface that some Lightning 
interfaces derive from. Provides basic methods to 
manipulate and create Bean objects.

HTML See Hypertext Markup Language. 

Hypertext Markup Language A programming 
language used to create World Wide Web pages, with 
hyperlinks and tags that explain how to format the 
information on the screen.
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Icon View Icon View shrinks a selected topic to an 
icon in the Content pane. The topic remains part of 
the data model, but is deactivated and can not be 
accessed by the query. Associated items are removed 
from the Request line when a topic is made into an 
icon, and the topic is not recognized as joined to 
other topics. Icon view is helpful in restricting the 
use of server time when a topic is infrequently used, 
and does not have to be active at all times. 

Imported Files  Excel, Text, or CSV files imported 
into Brio Intelligence. The information in the file 
goes into a table or a results object. Imported results 
can be used in other queries (like regular results) for 
local join purposes.

Indexes Indexes are created in a database to increase 
the performance of data retrieval. Just as book 
indexes help to locate specific information faster, 
database indexes provide a faster access path to table 
data. Indexes are created on one or more columns of 
a table. 

Insight A Web plug-in that delivers query, analysis, 
and reporting functionality for intranet, Internet, or 
extranet access to information. Based on user 
profiles or report-level security, the client 
environment adapts in six stages from full query, 
analysis, and reporting with data refresh to static 
report viewing. 

Integrity Constraints Constraints on tables that 
guarantee the data adheres to certain business rules. 
Integrity constraints are defined with a table and are 
stored as part of the table definition, central to the 
database data dictionary, so that all database 
applications adhere to the same set of rules.

Internal Function Internal functions are built-in 
formulas, defined in the Brio application.

Internet A global network connecting millions of 
computers. Unlike online services, which are 
centrally controlled, the Internet is decentralized by 
design. Each Internet computer, called a host, is 
independent. 

Interval Equal subdivisions within a given scale. 
The interval can be set manually or to best fit.

Intranet A network belonging to an organization, 
usually a corporation, accessible only by 
organization members, employees or other 
authorization users. Intranet Web sites look and act 
just like any other Web site, but the firewall 
surrounding an intranet fends off unauthorized 
access. 

ISAPI  This is a shared library that implements 
HTTP using Microsoft’s Web server plug-in API 
(ISAPI). Thus it is appropriate for customers with 
Microsoft Web servers. Functionally it is equivalent 
to our CGI. Its advantage is that it is far more 
scalable than a CGI executable.

Item An item is a visual representation of a database 
column and is a member of a topic in the Query 
section. Items are used to create queries and reports. 
For example, the Customer Topic may have items 
including Name, Address, and Phone. You select 
items from data model topics to build the Request, 
Limit, and Sort lines in the query section.

Java Server The OnDemand server classes packaged 
in a single JAR file (ODSClasses.jar). This 
component is responsible for managing, routing, 
and queuing client requests.

JavaScript The scripting language for Brio 
Intelligence products. Brio Intelligence 6.x includes 
the Netscape JavaScript interpreter (version 1.4.) 
JavaScript and Brio’s Object Model allow application 
developers to use the full functionality of the 
industry-standard scripting language to control Brio 
Intelligence applications.

Job Repository A set of database tables which store 
a queue of scheduled jobs. There can be multiple job 
repositories in an organization. Job repositories are 
polled periodically by a Broadcast Server, which 
downloads and processes jobs when they are due to 
run. 
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Join A relational database concept indicating a link 
between two topics. A join typically occurs between 
identical or similar items within different topics. 
Joins allow row records in different tables to be 
linked on the basis of shared information in a 
column field. For example, a row record in the 
Customer table is joined to a related record in the 
Orders table when the Customer ID value for the 
record is the same in each table. This allows the order 
record to be linked with the record of the customer 
who placed the order. If you request items from 
unjoined topics, the database server has no way to 
correlate the information between the two tables and 
leads to awkward datasets and run-on queries.

Brio displays joins visually in the workspace between 
topics to indicate joins between database tables. 
Users can also create new joins which are not already 
specified in the database. 

Join Path A predetermined join configuration for a 
data model. Administrators create join paths for 
users to simply select the type of data model needed, 
in a user-friendly prompt, upon processing a query. 
Join paths ensure that the correct tables in a complex 
data model are being used in a query.

JRE (Java Runtime Environment) This is the Java 
interpreter used to run the Java Server. We ship this 
as part of our ODS product. Internally we often use 
the term “JRE” to refer to a running instance of our 
Java Server.

Legend Box An informative box containing color-
keyed labels to identify the data categories of a given 
dimension.

Level Similar types of members in an OLAP 
database cube are grouped at the same level. For 
example, using the members listed in a Location 
dimension, France, the USA, and Japan belong to the 
Country level. Paris, Palo Alto, and Tokyo belong to 
the City level. 35 Main Street belongs to the Address 
level.

Limit Constraints placed on topic items or request 
line items to limit them to a certain set of values. 
Limits appear on the limit line in Brio Intelligence. 
For example, although the database may display 
worldwide sales figures for all stores, you may only 
want to see sales for stores in Germany. Limits make 
data sets retrieved through a query more efficient 
and manageable by filtering out unnecessary 
information. 

Limit Joins Joins that are created between a 
database table and a local results object. The topic 
item being joined is limited by the values of the 
column being joined in of the local results object. A 
limit join is one of the options that can be chosen in 
a Modify Join operation between a topic item and a 
local results item.

Linked Data Model Documents that are linked to a 
master copy in a repository. When changes are made 
to the master, users are automatically updated with 
the changes when they connect their duplicate copy 
to the database.

Load Balancing A technique used to improve the 
scalability of the OnDemand Server. 

Local Computed Meta Topic Items Computed 
item definitions evaluated by Brio Intelligence results 
engine. Local computed items are created to be meta 
topic items. They can be dragged to the request line 
like regular topic items. The only difference is that 
the results engine evaluates these items as opposed to 
the database.

Local Joins A join between a local results object and 
a database table or another local results object. Brio 
Intelligence performs the actual join in this case.

Local limits Limits placed on the local dataset in the 
Results section, as opposed to the Query section. 
Limits in the query section restrict the data retrieved 
by the query to the desktop. Local limits screen data 
from view in the Results set; although it’s still there, 
you cannot see the data that has been excluded or use 
it in reports unless the limit is removed. 
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Local Results Results of other queries within the 
same data model. These results can be dragged into 
the data model to be used in local joins. Local results 
are displayed in the catalog when requested.

Locked Data Model Data Models that are locked 
cannot be modified by a user.

Manager See server.

Master Data Model A Data Model that exists 
independently and has multiple queries that 
reference it as a source. When using a master data 
model, the text “Locked Data Model” appears in the 
Content pane of the Query section. This means that 
the data model is linked to the master data model 
displayed in the Data Model section, which may be 
hidden by an administrator.

MDX Multi Dimensional eXpressions is the 
language used to give instructions to OLE DB for 
OLAP- compliant databases (MS Plato), as SQL is 
the language used for relational databases. When you 
build the OLAP query section’s Outliner, Brio 
Intelligence translates your requests into MDX 
instructions. When you process the query, MDX is 
sent to the database server. The server returns a 
collection of records to your desktop that answer 
your query. See SQL.

Measures Numeric values in an OLAP database 
cube that are available for analysis. Measures may be 
margin, cost of goods sold, unit sales, budget 
amount, and so on. See Facts.

Members In an OLAP database cube, members are 
the content values for a dimension. In the location 
dimension, they could be Palo Alto, Paris, Tokyo, 35 
Main Street, USA, France, Japan, and so on. These 
are all member values for the location dimension.

Metatopic A customized, virtual topic, built from 
regular topics that reflects the exact topic and item 
structure of database tables. Metatopics allow items 
from disparate topics to be consolidated in a single 
topic, simplifying its appearance and reducing its 
conceptual resemblance to the underlying database 
structure. You can choose to view a data model in 
terms of its original topics, metatopics, or a 
combination of both. 

Metadata Data about data. Stored in database 
tables, metadata describes the history, content, and 
function of database tables, columns and joins in 
understandable business terms. Metadata can 
overcome the awkward names or ambiguous 
abbreviations often used in a database. For example, 
in a table named CUST_OLD, metadata may use a 
descriptive business name, such as Inactive 
Customers.

Mime Type A browser mapping of a file type to 
either a helper application or a plug-in. When a 
browser attempts to open a file of a particular mime 
type, it either loads the associated plug-in or 
launches the associated helper application. A file’s 
mime type is determined either by a) the file 
extension or b) the HTTP header. Plug-ins tell 
browsers what mime types they support and what 
file extensions correspond to that mime type. 

Brio Web clients support the following mime types: 
application/x-brioquery mime type (for .bqy files). 
This is the default mime type our Web clients 
support and are ordinary Brio files. application/x-
brioquerydata (for .bqd files). These are data files in 
text or Excel format, whose extension has been 
changed to .bqd. When a Brio Web client is 
launched to open a BQD file, it imports the data and 
executes any BrioScript or JavaScript the file 
contains.

Morphing Mechanism by which Brio Web clients 
provide document security. See Adaptive Report 
Level.
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Multidimensional Database A database that stores 
data in a format often referred to as a cube, such 
Essbase, MS OLAP, MetaCube, and so on. See also 
Relational database and OLAP database.

Nonadditive Measure Attributes in a table that 
cannot be added across any dimension, such as a 
percentage value (for example, margin rate).

NSAPI This is a shared library that implements 
HTTP using Netscape’s Web server plug-in API 
(NSAPI). It is equivalent to our CGI. Its advantage is 
that it is far more scalable than a CGI executable.

Null Value A null value is absent of data.

OCE See Open Catalog Extension Files.

OCE Wizard Wizard or set of screens used to create 
a new OCE or modify an existing OCE.

ODS See OnDemand Server.

OLAP Database A database that stores its 
information in cubes. Cubes contain dimensions and 
measures. A cube may have dozens of dimensions. 
Cubes are built to hold aggregated data, which 
anticipate how users think about business models. 
Cubes deliver this information efficiently and 
quickly.

OLAPQuery Section Analyzes and interacts with 
data stored in an OLAP cube. When you use Brio 
Intelligence to connect to an OLAP cube, the 
document immediately opens an OLAP Query 
section. The OLAPQuery section displays the 
structure of the cube as a hierarchical tree in the 
Catalog pane. Queries are built by dragging measures 
and dimension levels or members directly into the 
Outliner panes.

OnDemand Server A Brio server application that 
enables users to view and select from a list of 
available documents over the Web, as well as to build 
and process new queries.

OOA Object Oriented Analysis.

OOA&D Object-Oriented Analysis & Design. 

Open Catalog Extension Files Encapsulate and 
store connection information used to connect Brio 
applications to a database. OCE files specify the 
database API (ODBC, SQL*Net, etc.), database 
software, the network address of the database server, 
and your database user name. Once created, a user 
can specify the OCE file and database password and 
logon. An OCE file is required for a Brio Intelligence 
document to use a database. the file extension is 
.oce.

Open Client DBLib  API to connect to Sybase, 
Redbrick, SQL Server, and so on.

Open Metadata Interpreter The Tables, Columns, 
Joins, Lookups and Remarks tabs available in the 
connection wizard when you edit a custom metadata 
source. These tabs allow Brio administrators to 
specify a customer source of metadata that can be 
accessed through SQL statements, and provided to 
end users with data models.

Outliners Drag-and-drop command lines used in 
the Pivot, Chart, OLAPQuery and Report sections. 
Each Outliner pane corresponds to a specific layout 
element of the report. When an item is dragged to an 
Outliner pane, the item assumes the layout attributes 
of the respective report element. Data appears 
simultaneously in the Content pane with the 
appropriate formatting.

Pivot Dimension A row or column of labels that 
corresponds to an item in the Catalog pane.

Pivot Section The Pivot section is used to create 
crosstab reports and analyze data.

Pivot Table Analytical tools that resemble 
spreadsheets or crosstabular reports. A pivot table 
overlays a dynamic datacube, which allows data to be 
sliced and diced for ad-hoc, interactive, and 
multidimensional analysis. 

Pivoting In the Pivot section, pivoting is the ability 
to change a label from a top to a side (or a side to a 
top) orientation with a simple click and swing of the 
label’s Dimension tab.
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Plot Area The area bounded by the X-, Y-, and 
Z-axis. For pie charts, it is the rectangular area 
immediately surrounding the pie.

Plug-in A special application file placed in the 
browser Plug-in directory. Plug-ins add seamless 
functionality to a Web browser, enabling the browser 
to open particular plug-in file types. 

Plug-in / Helper The two implementations we 
support for our Web clients. The terms are short for 
browser plug-in and helper application respectively. 
The plug-in implementation is a shared library 
which the browser loads when the user requests a 
document of the application/x-brioquery mime 
type. The helper implementation is an application 
launched by the browser when that same mime type 
is requested. The plug-in is generally considered a 
better implementation because it runs within the 
browser. Brio provides helper applications on all 
platforms (Windows, Mac and Unix) and plug-ins 
on Windows only.

Predefined Drill Paths Enables a user to drill 
directly to the next level of detail, as defined in the 
data model.

Primary Key A database column or set of columns 
included in the table definition of the PRIMARY 
KEY constraint. Primary key values uniquely identify 
the rows in a table. Only one primary key is defined 
per table.

Query A query is set of database instructions to 
return an answer set to a specific question. Each row 
returned in the Results section of a document is an 
answer to the question posed in the Query section.

Query Computed Items Item definitions created by 
the user. This can include other request line items or 
topic items and or database functions. The definition 
is sent to the database and the database evaluates 
them.

Query Log Log of all SQL statements sent to the 
database (also referred to as SQL Log).

Quickview A Web plug-in that offers simplified 
report viewing and data refresh for users who need 
to view published, formatted reports within their 
browser.

Relational Database A database that stores its 
information in tables that are related or joined to 
each other by common pieces of information called 
keys. Relational databases store information in 
tables. A table is subdivided into column fields. 
Related information is grouped in column fields. 
Column fields have parents and children. For 
example, the Customer table may have columns 
including Name, Address, and ID number. Each 
table contains row records that describe information 
about a singular entity, object, or event, such as a 
person, product, or transaction. Row records are 
segmented by column fields. Rows contain the data 
that you retrieve from the database. Database tables 
are linked by Joins. (See also Join)

Report Group In the report section, embedded 
reports and tables are grouped by other data items. 
Items placed in the Groups Outliner break 
information into these dimensional groupings. For 
example, your table may include the name, contact 
information, and sales for each of your distributors. 
This table gains in clarity when broken into 
groupings that classify the stores by geographical 
region, year, or both.

Report Section A dynamic, analytical report writer, 
that provides users with complex report layouts and 
easy to use report building tools. Pivot tables, tables, 
and charts can be embedded in a report. The report 
structure is divided into group headers and body 
areas, with each body area containing a table of data. 
Tables are created with dimension columns and fact 
columns. These tables are elastic structures. Multiple 
tables can be ported into each band, each originating 
from the same or different result sets.

Repository Central location used to store data 
models, queries and queries with reports. Repository 
is usually a database chosen by the user. 
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Request Line Holds the list of items requested from 
the database server and that will appear in the user’s 
results. 

Request Line Items Columns listed in the request 
line.

Results Section A section in a Brio Intelligence 
document that contains the dataset derived from a 
query. Data is massaged in the Results section for use 
in the report sections.

Run Mode A toggled environment used to test EIS 
sections. It simulates a Navigator user’s view of the 
section. In Run mode, you can not add any features, 
but you can use features that are part of the deployed 
EIS sections. See also Executive Information System 
and Design Mode.

Scale The range of values that allows one to gauge 
how much each category represents. This range can 
be either at equal intervals or at logarithmic interval. 
The scale can be set manually or to best fit.

Script A series of instructions for a computer. 
Scripts are activated when an event occurs, such as 
clicking a button or selecting an item from a drop 
down list. Brio Intelligence’s scripting language is 
JavaScript.

Section Pane Lists all the sections that are available 
in the current Brio Intelligence document. 

Section Title Bar A navigational aid under the 
toolbars that provides a means of moving between 
sections and toggling section-specific tools and 
gadgets, such as the outliner.

Semiadditive Measure Attributes in a table that can 
be summarized across some dimensions, but not all. 

Server Administrator A stand-alone executable for 
administering the Brio OnDemand Server and the 
Brio Broadcast Server. 

Server Components The components that make up 
the OnDemand Server. These include the Web 
Broker, the ODS Manager, the ODS Node(s), and the 
ODS Repository (ies).

Server Computed Meta Topic Items Metatopic 
item definitions created by the user. These can use 
any of the database functions available. These items 
can also use any of the other topic items in the data 
model. These items are evaluated by the database.

Session Socket (DaSessionSocket) Session 
information specific to each database or API is 
abstracted in a session socket. We have session 
sockets for each of the APIs we support.

Simple Join Retrieves rows to create a query where 
the values in joined columns match.

Slicer An axis that filters the data in an OLAPQuery. 
Only individual members can be used in a slicer. A 
slicer can be thought of as a third axis in a OLAP 
Query. The other axis are the Side Labels and the Top 
Labels. Every dimension folder contains a members 
subfolder named “Values for…” that dimension. 
This subfolder contains the members that are eligible 
for the slicer.

Snapshot A read-only table snapshot is a local copy 
of table data that originates from one or more 
remote master tables. 

Sort Conditions placed on request line items to sort 
the results in ascending or descending order. These 
are displayed in the sort line in Brio Intelligence.

SQL See Structured Query Language. 

SQL Net Oracle’s native API to connect to an 
Oracle database.

Stacked Charts A chart where the categories are 
viewed on top of one another for visual comparison. 
This type of chart is useful for subcategorizing 
within the current category. Stacking can be used 
from the Y- and Z-axis in all chart types except pie 
and line. When stacking charts the Z-axis is used as 
the Fact/Values axis.

Stored Procedure Precoded queries in languages 
other than SQL. This is a feature available in some 
database software. Brio Intelligence can run stored 
procedures and retrieve the Results.
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Structure View Displays a topic as a list of 
component items allowing users to see and quickly 
select individual data items. Structure view is the 
default view setting.

Structured Query Language The language used to 
give instructions to relational databases. When you 
build the query section’s Request, Limit, and Sort 
lines, Brio Intelligence translates your requests into 
SQL instructions. When you process the query, the 
SQL instructions are sent to the database server. The 
server returns a collection of records to your desktop 
that answers your query. This reply is displayed as the 
Results section. You can look at the SQL generated by 
a query in the Query Log, or code a query directly in 
SQL using the Custom SQL window.

Subquery A query embedded within another query.

Surface Values A setting in the Pivot section to base 
aggregate calculations on the values in the report, 
rather than the values in the Results section.

Synonym An alias for a database table or view. It is 
a direct reference to a table view.

Table The basic unit of data storage in a database. 
Database tables hold all of the user-accessible data. 
Table data is stored in rows and columns.

Table Catalog Displays tables, views, and synonyms 
to which users have access. Users drag tables from the 
Table catalog to the Content pane to create data 
models in the Query section.

Table Section Used to create tabular-style reports. It 
is identical in functionality to the Results section, 
including grain level (table reports are not 
aggregated). Other reports can stem from a Table 
section.

Top and Side Labels In the Pivot section, labels are 
the column and row headings on the top and sides of 
the pivot. These define categories by which the 
numeric values are organized.

Topic A topic is a visual representation of a 
database table in the Content pane. Topics are part of 
data models displayed in the Query section and can 
contain one or more items.

Topic Items Individual items in a topic or 
metatopic.

Topics Visual representation of tables in the 
database, related by joins that link certain items in 
each topic. Each topic title bar displays the topic’s 
name. The topic shows a list of items, one for each 
column in the database table.

Underlying Values Another name for Results 
values. When Use Surface Values is disabled in a 
Pivot section, aggregate calculations are based on 
values in the Results section.

Union/Intersection/Minus Queries Queries 
created to perform set operations such as Union, 
Intersection, and Minus. These queries are created by 
the Append Query option. 

Variable Limits Limits that prompt users to enter 
or select limit values before the queries are processed 
on the database. 

View A custom-tailored presentation of the data in 
one or more database tables. Views do not actually 
contain or store data; rather, they derive their data 
from the tables on which they are based, referred to 
as the base tables of the views. 

Web Clients The Web-enabled counterparts of our 
client/server application (Brio Query). See Insight 
and Brio Intelligence Designer.

Web Components Web server components of the 
OnDemand Server are Web Broker, HTML pages 
without ODS tags, and the Zero Administration Web 
client installers. See OnDemand Server.

World Wide Web A system of Internet servers that 
support specially formatted documents. The 
documents are formatted in a language called HTML 
(HyperText Markup Language) that supports links to 
other documents, as well as graphics, audio, and 
video files. 

WWW See World Wide Web.

Zero Administration Installs Brio Web 
applications (Insight and Quickview) automatically 
without the help of an administrator when a user 
logs on to the OnDemand Server. 
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Symbols

% Increase function, 3-10

% of Category function, 5-23

% of Column function, 3-10

% of Grand function, 3-10, 4-19

% of Row function, 3-10

Numerics

2-D bar charts, 4-9

2-D bar charts, using to analyze data, 4-9

3-D bar charts, 4-12

3-D View, 4-11

A

Add Computed Item command, 2-13, 3-15, 4-38, 
5-32

Add Cume command, 3-15

Add Date Group command, 2-13

Add Grouping Column command, 2-13

Add Selected Items command, 3-15

Add Totals command, 3-15

adding computed items, 2-6, 3-14, 4-20, 5-21

adding cumulative totals, 3-8

adding date groups, 2-9

adding grouping columns, 2-7

adding lines to labels, 4-9

adding other report elements, 5-12

adding report groups, 5-10

adding totals and subtotals, 3-7

applying data functions to tables, 2-10

area charts, 4-14

ascending sorts, 2-13, 4-38, 5-32

Average function, 2-10, 3-9, 4-19, 5-22

axes, 4-3

axis grid lines, showing, 4-27

B

bar, 4-4

bar charts

2-D, 4-9

3-D, 4-12

clustered, properties, 4-34

properties, 4-34

stacked, 4-13

three-dimensional, 4-12

two-dimensional, 4-9

bar-line charts

properties, 4-34

best fit, charts, 4-26

Break Total command, 2-13

break total data functions, 2-10

break totals, 2-11

C

changing chart color schemes and fill patterns, 4-35

changing chart data labels, 4-36



changing chart legends, 4-29

changing color of chart elements, lines, and text, 
4-37

changing column names, 5-9

changing label nesting levels, 3-6

changing the view of a chart, 4-26

chart angle and elevation

changing, 4-27

chart dimensions, 4-4

chart elements, 4-8, 4-26

chart elements, working with, 4-8

chart format, determining what to use, 4-6

chart formats and types, 4-6

chart label properties, 4-32

Chart menu commands, 4-38

chart properties, changing, 4-30

Chart section

applying sorts in, 4-21

computed items, 4-20

data functions, 4-19

diagram, 4-2

Outliner, 4-5

chart terminology, 4-3

chart terminology , 4-3

Chart This Pivot command, 3-4

charting a pivot table, 3-4

charting basics, 4-3

charts

adding computed items, 4-20

adding lines to labels, 4-9

area, 4-14

building, 4-5

combination, 4-16

creating, 4-5

creating from pivot tables, 3-4

inserting text, 4-28

line charts, 4-16

multidimensional, 4-11

Outliner, 4-5

pie charts, 4-7

pivoting, 4-23

ribbon charts, 4-15

stacked bar, 4-13

terminology, 4-3

three-dimensional, 4-11

three-dimensional bar, 4-12

two-dimensional, 4-7

two-dimensional bar, 4-9

zooming, 4-26

clustered bar charts, 4-12

properties, 4-34

color

changing, in charts, 4-37

Column commands

Add Grouping, 2-13

Hide, 2-13, 4-38, 5-32

Modify, 2-13

Unhide, 2-13, 4-38, 5-32

Column Name function, 5-22

column names

changing, 5-9

hiding, 5-9

columns, 2-8 – 2-12, 5-9, 5-19

combination charts, 4-16, 4-34

commands

Chart menu, 4-38

formatting, 2-12

Pivot menu, 3-15

Report menu, 5-32

Table menu, 2-13

Tables menu, 2-13

comparing related values, 4-18

components, report, 5-7

computed fields, 5-13 – 5-14

computed items

adding, 2-13, 4-38, 5-32

Chart section, 4-20

Report section, 5-21
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Table section, 2-6

concatenating report element syntax, 5-6

converting detail reports, 5-29 – 5-31

Count function, 2-10, 3-9, 4-19, 5-22

creating

charts, 4-5

custom reports, 5-8

pivot tables, 3-3

pivot tables from charts, 4-23

smart reports, 5-27

tables, 2-3

three-dimensional bar charts, 4-12

cumulative limits, 3-8

cumulative totals, adding, 3-8

custom functions, 2-10

custom totals, inserting, 2-10

customizing chart patterns, colors, and labels, 4-35

customizing chart properties and labels, 4-30

D

data calculations, in pivot tables, 3-7

Data Function command, 3-15, 4-38, 5-32

data function definitions, 3-9

data functions

in charts, 4-19

in custom reports, 5-22

in pivot tables, 3-9

data, pivoting, 3-3

Date & Time field, 5-14

Date & Time Now field, 5-14

Date field, 5-13

Date Group command, Add, 2-13

Date Now field, 5-14

dates, breakout columns, 2-9

deleting columns, 2-12

descending sorts, 2-13

design guides, 5-17

Design Guides command, 5-32

Detail reports, converting, 5-29

display differences, 5-30

displaying axis grid lines, 4-27

displaying rulers, 5-17

Drill Anywhere command, 4-38

Drill Down command, 3-15

Drill Up command, 3-15

drilling into charts, 4-24

Drillup command, 4-38

duplicate values, suppressing, 5-9

E

elements

selecting pivot, 3-4

working with chart, 4-8

Expression line, 5-5

expression syntax, 5-5

F

facts, 3-3

features, sort line, 4-21

fields, 5-13

File Name field, 5-14

focus on items, 4-25, 5-24

Focus On Items command, 3-15, 4-38, 5-32

font styles, changing, 5-27

fonts, changing, 5-28

footers

page, in custom reports, 5-11

report, 5-11

formatting commands, 2-12

formatting report items, 5-27

formatting reports, 5-27

functions

in sorts, 4-23

weighted, 3-12
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G

Grand Total command, 2-13

grand total data functions, 2-10

grand totals, 2-10

grand totals, inserting, 2-10

graphic elements, 5-12

Grid command, 5-32

grid lines, 4-4

grids, 5-17

group fact syntax, 5-6

group headers, report, 5-10

Group Items command, 3-16, 4-38

group label syntax, 5-5

grouping columns, 2-13

guides, design, 5-17

H

headers

page, in custom reports, 5-11

report, 5-11

report group, 5-10

Headers and Footers command, 5-33

Hide Column command, 2-13, 4-38, 5-32

hide items, 4-25, 5-24

Hide Items command, 3-16, 4-38, 5-32

hiding and focusing on charted data, 4-25

hiding and focusing on reported data, 5-24

hiding column names, 5-9

hiding column totals, 5-9

horizontal lines, 5-12

I

Increase function, 3-10

Insert Field command, 5-32

Insert Graphic command, 5-32

Insert Predefined Field command, 5-32

Insert Table command, 5-32

inserting

additional tables in a custom report, 5-10

limit values, 5-15

page breaks, 5-16

page headers and footers, 5-11

report headers and footers, 5-11

text, 4-28

text in charts, 4-28

items, sort, 4-22

K

Keep Together command, 5-28

Keep With Next command, 5-28

L

label properties

chart, 4-32

charts, 4-32

label reference, in sorts, 4-22

labels, nested, 3-6

Las Saved field, 5-13

Last Printed field, 5-13

legend, 4-4

legends, positioning and resizing, 4-29

Limit command, 2-13

limit values, in reports, 5-15

limiting data in a table, 2-4

limits

cumulative, 3-8

removing, 2-5

tables, 2-4

limits, cumulative, 3-8

line charts, 4-16

lines, 5-12

Locked command, 5-13
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M

manipulating chart data, 4-18

manipulating table data, 2-4

margins

Report section, 5-19

Maximum function, 2-10, 3-10, 4-19, 5-22

menu commands

Chart, 4-38

Pivot, 3-15

Report, 5-32

Table, 2-13

Minimum function, 2-10, 3-10, 4-19, 5-23

Modify Column command, 2-13

Modify command, 3-15

Modify Computed Item command, 4-38

modifying pivot tables, 3-4

moving pivot table elements, 3-5

multicolumned reports, 5-19

multidimensional charts, 4-11

multiple data sources, in reports, 5-25

N

nested

labels, 3-6

Non-Null Average function, 3-10, 4-19, 5-23

Non-Null Count function, 3-10, 4-19, 5-23

Null Count function, 3-10, 4-19, 5-23

number formats, changing, 5-27

Number of Pages field, 5-13

O

object names, 5-13

Outliner

Chart section, 4-5

Pivot section, 3-4

Table section, 2-3

Outliner pane usage, 4-3

Outliner Panes and X, Y, And Z Axes, diagram, 4-4

ovals, 5-12

P

page breaks, inserting, 5-16

Page Margins command, 5-32

Page Number field, 5-13

Page X of Y field, 5-13

Path Name field, 5-14

Picture command, 5-32

pictures, 5-13

pie charts

analyzing data, 4-7

rotating, 4-9

pie slices, positioning, 4-8

pivot elements, selecting, 3-4

Pivot menu commands, 3-15

Pivot menu commands , 3-15

Pivot Outliner, 3-4

Pivot section, diagram, 3-2

pivot tables

calculating totals and subtotals, 3-7

charting, 3-4

how to use, 3-3

modifying, 3-4

selecting elements, 3-4

subtotals, 3-7

working with pivot items, 3-4

pivoting data, 3-3

planes, 4-4

plot area, 4-3

positioning pie slices, 4-8

Properties command, 4-38

properties, chart label, 4-32

Q

Query Limit field, 5-13

Query SQL field, 5-13
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R

rectangles, 5-12

reference Items, 4-22

reference items, in sorts, 4-22

Refresh Data command, 3-16, 4-38

Remove command, 2-13

Remove Selected Items command, 3-15, 4-38, 5-33

removing columns, 5-9

reordering columns, 5-9

report components, 5-7

report element syntax, concatenating, 5-6

report expression syntax , 5-5

report group headers, 5-10

report headers and footers, 5-11

Report menu commands, 5-32

Report Name field, 5-14

report pages, 5-17

Report section

computed fields, 5-14

computed items, 5-21

creating smart reports, 5-27

data functions, 5-22

elements, 5-3

Expression syntax, 5-5

fields , 5-13

formatting items, 5-27

formatting techniques, 5-27

graphic elements , 5-12

limit values, 5-15

toolbar, 5-4

using multiple data sources, 5-25

Report section, diagram, 5-2

Report Setup command, 5-33

reports

adding computed items, 5-21

data functions, 5-22

inserting page breaks, 5-16

multicolumned, 5-19

smart, 5-27

Restore Name command, 3-16, 4-38

Result Limit field, 5-13

ribbon charts, 4-15

rotating and elevating charts, 4-27

rotating pie charts, 4-9

round rectangles, 5-12

rows, selecting, 2-12

Rulers command, 5-32

S

Section Boundaries command, 5-32

selecting chart elements, 4-26

selecting columns, 5-9

selecting columns and rows, 2-12

selecting pivot table elements, 3-4

setting

bar chart properties, 4-34

chart label axis properties, 4-32

chart value axis properties, 4-33

general chart properties, 4-30

setting up

page columns, 5-19

reports, 5-18

Show All Items command, 3-16, 4-38, 5-32

Show Hidden Items command, 3-16, 4-38, 5-32

showing column names, 5-9

showing column totals, 5-9

showing pie percentages, 4-9

showing positive and negative values, 4-8

slice, 4-4

smart reports, 5-27

Sort Ascending command, 2-13, 4-38, 5-32

Sort command, 3-15, 5-32

Sort Descending command, 2-13

sort items, 4-22

sort line features, 4-21

sorting

chart items, 4-21

charts, 3-6
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pivot tables, 3-6

report items, 5-20

reports, 5-20

tables, 2-5

specifying

page margins, 5-19

page size, 5-18

stacked bar charts, 4-13

staging data in tables, 2-3

subtotals, 3-7

Sum function, 2-10, 3-9, 4-19, 5-22

suppressing duplicate values, 5-9

surface values, in data functions, 3-11

syntax

concatenating, 5-6

expression, 5-5

syntax, concatenating, 5-6

T

table column formatting options, 5-9

table dimension syntax, 5-5

table fact syntax, 5-5

Table menu commands, 2-13

Table Outliner, 2-3

Table section

computed items, 2-6

data functions, 2-10

diagram, 2-2

tables

adding computed items, 2-6

limits, 2-4

modifying pivot, 3-4

pivot, 3-3 – 3-4, 3-7

working with, 2-12

tables as a data staging area, 2-3

text in charts, inserting, 4-28

text labels, 5-13

text, wrapping, 5-9

three-dimensional bar charts, 4-12

Time field, 5-14

Time Now field, 5-14

Total commands, 2-13

totals

break, 2-11

calculating pivot totals, 3-7

cumulative, 3-8

inserting in Tables section

break, 2-10

custom, 2-10

grand, 2-10

surface, 3-10

two-dimensional bar charts, 4-9

two-dimensional charts, 4-7

U

Ungroup Items command, 3-16, 4-38

Unhide Column command, 2-13, 4-38, 5-32

Use Surface Values command, 3-15

V

value reference, in sorts, 4-22

values, 4-3, 4-18, 5-9

vertical lines, 5-12

Visible command, 5-13

W

weighted functions, 3-12

weighted values example, 3-12

wrapping text, 5-9

X

X-Categories, 4-3
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Y

Y-Facts, 4-3

Z

Z-Categories, 4-3

zooming charts, 4-26
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